
Cannot Export Recipes

Once you have been successful exporting recipes, you will rarely experience problems. Some of 
the most common symptoms you may encounter during your first attempts to export are 
discussed in this Help file along with suggested solutions. 

--------------------------------------------------------

SYMPTOM: MC Recipe Mailer was unable to send the message
CAUSE/SOLUTION: Either you have not yet performed the "Setup" for the Recipe Mailer, or the 
information you provided is not correct. Verify that the "Setup" contains the correct information for 
your system, including the right SMTP host name. If the information is correct and you still cannot 
send an e-mail message, check the networking parameters in your operating system. It may be 
that they have not been defined or were defined incorrectly.

--------------------------------------------------------

SYMPTOM: "=20" characters appear within the recipes you want to e-mail
CAUSE/SOLUTION: MS Exchange inserts these characters and all non-MSExchange users 
will experience this problem. If MS Exchange users perform the following procedure, the 
recipes they send via Email will not contain these characters.

PROCEDURE for MS Exchange users: Go to Tools...Services. Highlight Internet Mail and press 
the Properties button. Press the Message Format button. Uncheck the "Use MIME When Sending
Messages". Press the Character Set.button. Make sure that the drop down listbox has"US ASCII".

--------------------------------------------------------

SYMPTOM: File too large to send or be received by intended recipient

CAUSE/SOLUTION: Some Internet service providers and some e-mail programs have limits 
on the size of file you may send. It is wise to not try to include too many recipes in one e-mail 
message because some users may not be able to receive them. In addition, many e-mail 
systems will break a large file into several smaller components, and then users must take 
extra steps to concatenate the message prior to importing.

TIP: If sending recipes embedded in email, send several separate messages instead of one 
large one. If sending recipes or a cookbook as attached document, or uploading, consider 
compressing or "zipping" the file first. If it is still too large, break it into several smaller files. 
The recipient can concatenate them after receipt.

--------------------------------------------------------

SYMPTOM: Extraneous characters (such as ">") appear at the beginning of each line in the
recipe you e-mail.
CAUSE/SYMPTOM: You most likely "Replied to" or "Forwarded" the e-mail message. When 
sending recipes embedded in e-mail messages, do not use either of these e-mail options. Use 
"Send Again" instead.



Downloading Complete Cookbooks
Some Internet sites have complete MasterCook cookbooks available for downloading (such as 
the MC Web page: http://www.sierra.com ). These cookbooks are NOT text files and should be 
downloaded as "raw data" ("binary") files. If a cookbook is downloaded as a text file, you may not 
be able to open it from MasterCook.

You may use any of the many programs available that allow you to download files to your 
computer from the Internet. Some of the more popular programs include Netscape, Mosaic, 
Fetch, and Gopher.

Once a cookbook is downloaded, all you need to do is open it with MasterCook. If you *thought* 
you downloaded a complete cookbook, but you cannot open it from within MasterCook, see What 
Went Wrong? for trouble-shooting and problem solving hints. 



Exporting from Meal Master
From the Main Menu select Utilities. 

Choose Export Recipe from the Utilities menu.

In the "Export Recipe" window, type a name for the file that you will be exporting. Select the type 
of file to export:

Create a new file 

Append the end of the last file

Replace an existing file.

Select the recipes you will be exporting:

Individual recipe

Marked recipes

Range of recipes specified

Type the number of the recipe(s) you wish to export (Example: (1-15)).Select an export formats:

Normal Format

BB Format

MM Format

Export the ingredients in:

Single Columns

Dual Columns

Select Go, or Exit.



Generic Format
Following is the description of the Generic import format. It is the easiest format to use if you are 
preparing unformatted text files for import.

This format uses blank lines {or the "|" (vertical bar) control character, MC 4.0 only} as recipe 
section delimiters. Consequently, theorder of blank lines and text lines is rigid. However, because 
no keywords are used in this format, the position of text on any line is extremely flexible. 
Additionally, there are three possible delimiters that can be used in the ingredient section (see the
"NOTE:" below).

(Instructional comments appear within brackets, "[ ]", below a line and are NOT part of the format.
All lines are REQUIRED unless the comments indicate otherwise.) 

------------------------------------------

1st line: @@@@@    [that's 5 "at" signs] 

2nd line: TITLE of the recipe 

3rd line: BLANK Line [OR "|" (vertical bar) as the first character, MC 4.0 ONLY]

4th line: NOTES -- ONE line of text[Optional in MC 4.0. Required for MC 3.0 Mac users!

]5th line: BLANK Line [OR "|" (vertical bar) as the first character, MC 4.0 ONLY][Optional when the
NOTES line is not used.]

6th line: amount unit ingredient preparation method [You may repeat this line up to 100 
times;there must be NO blank lines      between ingredients.] 

BLANK Line[OR "|" (vertical bar) as the first character, MC 4.0 ONLY]

DIRECTIONS. Free form text. Blank lines may exist in this section.

End-of-Recipe: _____[MC 4.0 ONLY. (5 underscores) Optional.]

-----------------------------------------

NOTE: The generic format uses any of the following delimiters to separate ingredient and 
preparation method: comma:      1 cup carrots, chopped        semi-colon:      1 cup carrots; 
chopped                <tab> :      1 cup carrots<tab>chopped



How to Export Recipes
To export one or more recipes from a cookbook to a text file, first select "Export from" cookbook. 
Then select the recipes you wish to export and select "export" from the MasterCook menu 
options. After identifying the location and name of the exported recipe text file, all selected recipes
will be exported.



Import Results Window

When the Recipe Translator detects a possible import error, the recipe in question is placed on 
the "Import Results" window.    

Import errors are handled identically in MC 3.0 and 4.0 for Windows and MC 3.0 and 4.0 for 
Macintosh. That is, the same errors will result in ecipes being placed in the Import Results 
window on both systems.

However, Windows users WILL NOT receive a warning message that a possible problem was 
detected and that a recipe was placed in the Import Results window. (Exception: a warning 
message WILL be issued when a duplicate recipe name is encountered, renamed, and placed in 
the window.)

1. "NOTE" Error:
CAUSE:    Fields in the original recipe were truncated because the ingredient or preparation 
method was too long. Or other limits, such as number of categories, were exceeded.

CONDITION:    The recipe is most likely OK. This typically is only to inform you that some 
changes were made to the recipe. If a field was truncated, it was wrapped to the next line. 
There could be some loss of data, in which case you will need to refer back to the source text 
to correct the recipe.

EXAMPLES:    

Too many categories (limit is 10)

Too many ingredients (limit is 100)

Preparation Method field is too long (limit is 20 characters)

2. "CAUTION"    or "ALERT" Error:
CAUSE:    Invalid data was found in one or more of the fields. If the error was recoverable and
the translator continued, the caution will be used. Note that if the error occurred in an 
ingredient, the error line will have a "bullet" in the preparation method field. (This will appear 
as a blank rectangle on Windows systems and a black dot on Macintosh systems.) 

CONDITION:    Recipe may be OK but it is advisable to look it over. The problem is usually in 
the ingredients and is very often resolved by the translator. On occasion there may loss      of 
data, so you will need to refer back to the source file to correct the recipe. 

EXAMPLES:    Invalid amount and unit combination, such as

(16 oz) lb butter (This is invalid because    the units are equal (16 oz = 1 lb). Whereas "1 (16 oz) 
cantomatoes"    IS valid because the size of a container is being defined.)

3.    "STOP" or "FATAL" Error:
CAUSE:      The Recipe Translator could not find or recognize the next part of the recipe. In 
this case, the remainder of the recipe is not imported. 

CONDITION:    The recipe is NOT fit for human consumption. Go back to the original text file 
& look for obvious errors such as missing required blank lines.

EXAMPLES:    

The correct "Amount Unit Ingredient    Preparation Method" delimiter is missing.

Text file contains Unix EOL delimiters.



4.    DUPLICATE RECIPE NAME Error:
CAUSE:    The Recipe Translator encountered a recipe in the target cookbook with the same 
name as one it is importing. The importer will rename the new recipe by appending a numeric
suffix to the name.

CONDITION:    The recipe is fine. It is placed in the Import Results window only to alert you 
that a duplicate recipe name had been encountered and that the recipe was renamed.



Importing Downloaded Recipes
Many Internet sites have recipes stored as text files that you may download. Often times these 
recipes are in format that MasterCook recognizes. (For example, the recipes were exported from 
MasterCook or Meal-Master.)

You may use any of the many programs available that allow you to download recipes to your 
computer from the Internet . Some of the more popular programs include Netscape, Mosaic, 
Fetch, and Gopher.

All recipes that you wish to import into MasterCook must be in a format that MasterCook 
recognizes and must be downloaded into a text file.    Once the recipes are downloaded, you may 
import them into a MasterCook cookbook following the normal import procedures.

TIP: Make sure you download the file in the correct format. For example,it is important that 
text files are downloaded as "text" and not as "raw data" ("binary") files. Downloading a file 
with the incorrect text type may prevent MasterCook from being able to import the recipes. 

TIP: Many Internet sites store files on Unix systems. Depending on how the text was stored and 
on your downloading program,the text type may be wrong for your system. Many network 
programs will translate the end-of-line delimiters as it downloads. If the MasterCook importer 
doesn't recognize the recipes you downloaded, look at them with Notepad or Simple Text. If they 
appear to be "run on" and/or contain foreign characters (such as black rectangles or blank 
squares), then the text type must be converted before the import will succeed.

If you are having difficulty importing recipes that you downloaded from the Internet, see What 
Went Wrong? for trouble-shooting and problem solving hints.



Importing Formatted Text Files
Once the recipes in a text file are all in an acceptable format, you are ready to import them into an
existing cookbook.    You simply need to openthe cookbook into which you wish to import, select 
Import from the File menu, and identify the file that contains the recipes you want to import.    The 
Recipe Translator will read the file and present you with a listing of all recipes it recognized.    
Make your selection of one recipe,several recipes, or the entire list. 

MASTERCOOK 3.0 and 4.0 (Windows and Macintosh) USERS ONLY: You do not have to import 
into an existing cookbook.    If you would like a new cookbook to be created for the recipes in an 
import file, instead of selecting Import from the File menu, select Open.... Select the file which 
contains the recipes you want to import, and then you will be asked what to name the "converted 
cookbook" and where you would like it to be placed. After selecting the recipes you want to 
import, a new cookbook containing those recipes will be created.

FOR MASTERCOOK 4.0 USERS ONLY: Often recipes come with many "Categories" that you do 
not use.    The Import dialog window gives you the option of including or excluding the categories 
when recipes are imported.    Simply click the "Include Categories" to make your choice.

TIP: It is often preferable to import into an empty cookbook because there is no way to 
distinguish newly imported recipes from existing ones. You may wish to create an "import" or 
"temporary" cookbook thatyou use solely for importing new recipes.    This gives you the 
opportunity to inspect the imported recipes and make changes as necessary. When you are 
satisfied with the recipes, you need simply copy (or in the case of MC 3.0 and 4.0, drag & 
drop) them into the destination cookbook.

TIP: Often recipes come complete with many "Categories" that you do no use.    By importing 
into an empty cookbook, it is easier for you to delete the unwanted categories and assign 
your preferred categories to the recipes. With MC 3.0 and 4.0, this is even more easily 
accomplished via the "drag & drop" feature.

DUPLICATE RECIPE NAMES WHEN IMPORTING:
MASTERCOOK II and MASTERCOOK MAC: The importer will inform you when it encounters an 
import recipe with the same name as one already in the target cookbook. You will be asked if you 
wish to "replace" the old recipe with the one you are importing, if you wish to "skip" importing that 
recipe and continue to the next, or if you wish to cancel the entire import.

MASTERCOOK 3.0 and 4.0 will automatically append a numeric suffix to the import recipe when 
it encounters a recipe with the same name in the target cookbook. (Ex., "Banana Bread" will 
become "Banana Bread 2")    If recipe names with numeric suffixes already exist in the cookbook, 
the importer will assign the next numeric value. (Ex., "Banana Bread 1"through "Banana Bread 4" 
exist, so the importer will name the importrecipe "Banana Bread 5".)    

A warning message will be issued telling you that the importer encountered duplicate recipe 
names.    The newly imported, renamed recipes will be placed in the Import Results window for 
your easy inspection.

OK, you inspected the text file and you *thought* that it contained correctly formatted recipes.    
But they didn't import, or they didn't import "cleanly". See What Went Wrong? for trouble-shooting 
and problem solving hints.



Importing Recipes from E-mail
The majority of recipes you will receive will be embedded in e-mail messages. An e-mail message
may contain one or many recipes and you may import any or all of these recipes.    Of course, 
each recipe must be in an import format that MasterCook recognizes (see the MasterCook Import
Formats Help file). If it is not, then you will need to edit the recipe and put it in an acceptable 
format prior to importing.

When recipes are embedded in an e-mail message and surrounded by other text (which is 
common in e-mail messages and mailing list digests), there is often no need to first edit the file to 
strip out the extraneous text. The MasterCook importer will begin importing from the "beginning-
of-recipe" header and will stop when it comes to the beginning of the next recipe, the end-of-file 
indicator, or to an end-of-recipe delimiter.    Any other text, such as e-mail headers,signature lines,
or even comments that are not a part of the recipe will not be imported.

EXCEPTIONS: MC 3.0, MC II, and MC Mac users:    In the following circumstances, you will need 
to delete all extraneous text that follows a recipe (ie, e-mail signatures) prior to importing.    If you 
do not, then the trailing text will be imported as part of your recipe.

-- When a recipe is in the Generic format.

-- When a recipe in the standard MXP format contains a "Notes"section

-- When a recipe in the standard MXP format contains a Serving Ideas section.

-- When a recipe in the standard MXP format contains a "SuggestedWine" section.

NOTE: There are occasions when an e-mail message will contain extraneous characters 
within the body of the recipe.    For example, if the recipe was "forwarded" or "replied to," it will
probably contain ">" symbols at the beginning of each line.    In cases such as this, the recipe 
will NOT import as is.    You must first edit the recipe to remove all unwanted characters.

TIP: If there are changes that you would like to make to the recipe itself (such as changing 
categories), it is typically easier to make the changes from within MasterCook, AFTER the 
recipe is imported. Likewise,i f unwanted text was imported as part of the recipe (ie, e-mail 
signatures), it can be easily removed by editing the recipe within MC.

--------------------------------------------------------

There are two ways that recipes may be imported from e-mail messages.Depending on your 
particular e-mail program, you may be able to use one or both methods.

1) SAVE THE E-MAIL message containing the recipes you wish to import as a text file. Then you 
follow the normal MasterCook importing procedures, pointing the MC importer to the saved text 
file.

TIP: When you save an e-mail message as a text file, make sure that you do NOT select 
options such as "Guess Paragraphs" or "Wrap".    These options may alter the format of the 
recipe, preventing successful importing.    It does not matter if the e-mail header information is
stored with the recipe; MasterCook will strip that when it imports.

TIP: Many e-mail programs will allow you to save multiple e-mail messages in one text file.    
The advantage in doing this is that you can import many recipes by invoking the import 
operation only once. Be careful, however, if you are not a MC 3.0 and 4.0 user that every 
recipe in one file is in the same format (ex., they all are from MM or all in MC MXP format).

TIP: Many e-mail programs will separate a large e-mail message into multiple parts, typically 
appended with a numeric suffix. This may very well happen when someone posts many 
recipes in one e-mail message.    When you do the "Save," make sure that you save all parts 
of the message in the same file.

TIP: Often users will preface the formatted recipe with interesting comments that you might 



like to save with your recipe.    In this case, you should edit the e-mail message and copy and 
paste the extra comments into the recipe.    In order to prevent altering the recipe format (if 
you do change it, it may not import), the safest place to insert these additional comments is 
either at the beginning or the end of the "directions" section.

2) IMPORT DIRECTLY from an e-mail mailbox. Some e-mail programs (such asEudora) maintain 
the mailboxes as text files that can be opened and viewed as normal text files from other 
programs. If this is the case with your e-mail program, then you may simply point the MasterCook 
importer at the mailbox which contains the recipes you wish to import.

NOTE: Not all e-mail programs store the e-mail messages in a fashion thatyou can access 
from outside the e-mail program. If your e-mail program stores the e-mail messages    
"internally" or in a format that only the e-mailer can recognize, you must first save the e-mail 
message as a text file before you can import it.

TIP: When you import directly from a "mailbox", every message in that mailbox is searched 
for recipes in an import format. This has the advantage of importing many recipes by invoking
the import operation only once. Be careful, however, if you are not a MC 3.0 and 4.0 user that
every recipe in the file is in the same format (ex., they all are from MM or all in MC MXP 
format).

TIP: Many e-mail programs will separate a large e-mail message into multiple parts, typically 
appended with a numeric suffix. This may very well happen when someone posts many 
recipes in one e-mail message.    The e-mailer will not necessarily break the file at the end of 
a recipe, so in order to correctly import recipes from multi-part e-mail messages, you should 
first concatenate all parts of the message. One way to do this is to "save" all parts of the 
message to one file

TIP: Some e-mail programs (such as Eudora) permit you to create mailboxes in addition to 
your "In" box. If this is your case, you may wish to create at least one recipe mailbox (for 
example, "Recipes") and transfer all recipes that are in a format MC recognizes into that 
mailbox. When you are ready to import, point the MC importer to the "Recipes" mailbox.

If you create several recipe mailboxes, it will enable you to pre-sort recipes prior to importing.    
For example, if you are not a MC 3.0 and 4.0 user, you may want to keep one mailbox for MC 
MXP formatted recipes and one for MM exported recipes. Or you may wish to separate your 
mailboxes by recipe category (such as a "main dish" mailbox, a "dessert" mailbox,etc).    Then 
when you import from any particular mailbox, you already know in which categories, or 
cookbooks, the recipes belong.

Another example of creating multiple mailboxes is to create one for each mailing list from which 
you receive recipes. For example, you create a mailbox for the "mc-recipe list", one for the 
"foodwine" list, etc. This enables you to easily keep track of the recipe source when importing.

Make use of the "sorting" features of your e-mail program to facilitate importing your MasterCook 
recipes. Develop the approach that works best for you.

TIP: Some e-mail programs will not allow you to edit mail in the "In"box. So in the cases when
you want to edit the recipe prior to importing, you need to save the e-mail message as a text 
file first and then open it for editing. (Reasons you might want to edit prior to importing: you 
may want to add the comments from the recipe poster that were outside of the recipe or you 
may need to remove some extraneous characters.) 

TIP for Macintosh and Eudora users: Create an "alias" of the Eudora mailbox that contains 
the recipes you want to import and put that in your MC cookbook folder. When it comes time 
to import, the mailbox name will be right there and you won't have to search through several 
dialogue boxes.

Can't import recipes successfully from e-mail messages? Then see What Went Wrong?    for 
trouble-shooting and problem solving hints.



Importing Recipes: Handling Unformatted Text Files
In addition to importing recipes that are in either the MXP or Mac formats, MasterCook 3.0 and 
4.0 will also import recipes in the Generic format.    This format provides a very simple method of 
preparing unformatted text recipes for import.

GENERIC IMPORT FORMAT
Following is the EXACT format that MasterCook expects when using the"generic import" feature.  
You will find that it takes very little timeand effort to put most unformatted text recipes into this 
format.

NOTE: The descriptive comments appearing inside the bracket signs, "[ ]", are NOT a part of 
the format and appear here only for clarification.

1st line: @@@@@    [that's 5 "at" signs] 

2nd line: TITLE of the recipe 

3rd line: BLANK [this MUST be BLANK, not spaces!]

-- OR MC 4.0 ONLY --

3rd line: | [ (vertical bar) This eliminates the need for a BLANK line]

4th line: NOTES -- ONE line of text. [Optional]

5th line: BLANK [again, no spaces or non-display characters! Optional if no Notes line]

-- OR MC 4.0 ONLY --

5th line: | [ (vertical bar) This eliminates the need for a BLANK line] 

6th line: amount unit ingredient preparation method [amount, unit, prep method are optional]      .

Last INGREDIENT    [up to 100 ingredients] 

BLANK    [once again, no spaces!]

DIRECTIONS and any "free form" text you wish to include. These lines are optional.

Last line: _____ [end-or-recipe indicator, MC 4.0 ONLY]

NOTE: Everything until the "_____" (MC 4.0 ONLY) or the next "@@@@@" will be put in the
direction section.    You can add the "recipe by", "serving size", and "categories" once the 
recipes have been imported.

TIP: Hate the tedium of deleting all those preceding spaces on each line of your recipe? Well,
there's no need to!    With the exception of the"@@@@@", the lines in the generic format do 
NOT have to be left-justified. Each text line may be preceded by non-printing characters,such 
as spaces.

TIP: The easiest way to force the "preparation method" into the"preparation method field" is 
to place either a comma or a semi-colon after the ingredient. (Ex., 1 small onion, chopped --
OR-- 1 small onion;chopped)

TIP:  A BLANK line MUST truly be BLANK. (Or in the case of MC 4.0, thecontrol character "|" 
(vertical bar) may begin the line.) The import will not work correctly if any non-displayable 
characters, such as spaces, are contained in a "blank" line. If you are experiencing difficulty 
importing a recipe, it may be helpful to view the recipe with an editor (ex., WordPerfect, MS 



Word, Notepad, BBedit, etc.) that will display non-printable characters.    Only the end-of-line 
delimiters (carriage returns,line feeds, etc) should be in a blank line.

TIP: If a recipe is not left justified in an e-mail message, what appearsto be blank lines are 
most likely lines with spaces. So, if the original recipe is indented, be sure to delete and 
replace every blank line.    Or,if using MC 4.0, insert a "| (vertical bar) at the beginning of each
separator line.

TIP: Make sure that where a blank line is required, there is only ONE blank line. If more than 
one blank is encountered, the importer may not store the recipe properly.

TIP: MC 3.0 does not recognize an end-of-recipe delimiter, so EVERYTHING following the 
first direction line until the next "@@@@@" is encountered will be imported as directions.    
Therefore, you need to delete any extraneous text (such as e-mail signatures) that you do not
want stored as part of your recipe.    When using the generic format, MC will not strip out 
trailing text that is not part of your recipe.

TIP: Recipes are posted on the Internet in a very wide variety of styles and formats. 
Sometimes the ingredients are embedded within sentences and it may be difficult to ready the
recipe for importing.    In these instances, you may find it easier to manually enter the recipe 
using MC fast-fill feature and doing a copy and paste of the directions.

EXAMPLE of a recipe in the "generic" format:

@@@@@

Grilled Tossed Vegetables

Serve with meat or poultry. Good vegetarian dish also.

6 cups eggplant,peeled and cubed

1 medium green bell pepper;chopped

1 large onion,chopped

1 tablespoon margarine    

1/4 teaspoon basil

2 tomatoes            

salt        to taste

pepper    to taste

1. Peel and cube eggplant to make about 6 cups. Mix with the chopped green pepper and 
chopped onion.

2. Cut 3 pieces of heavy-duty foil about 12 x 18 inches.    Divide the eggplant mixture evenly on 
foil.    Place 1 teaspoon margarine on mixture; sprinkle with basil, or if preferred use chopped 
fresh basil.    Close foil tightly

3. Place foil packs on grill 3-4 inches from heat; cook for about 35 minutes.

4. Chop tomato and place on another piece of foil.    Close foil and place on grill the last 15 
minutes of eggplant cooking time.

5. Remove vegetables from foil; blend together in large bowl.    Season to taste with salt and black
pepper.



Recipe By: Jo Anne Merrill in from the MasterCook cookbook, "Kitchen Classics."

_____

------------------------------------------

If you prefer, instead of using the "generic format", you may put your recipes into the MXP format. 
MC 3.0 and 4.0 removed the column and position dependency of the MXP format, making it 
significantly more flexible. It is now quite easy to create a keyword template for MXP and simply 
insert the appropriate recipe sections.



Mac Format

Following is the description of the Mac import/export format. This format uses a combination of 
keywords and tabs as recipe section and field delimiters. It is not recommended that you 
exchange recipes in theMac format via the Internet, because many Internet Service Providers and
email programs strip all tabs from text files.

(Instructional comments appear within brackets, "[ ]", below a line andare NOT part of the format. 
All lines are REQUIRED unless the commentsindicate otherwise.)

 ------------------------------------------

{ Exported from MasterCook Mac }

Recipe Title

BLANK Line

Recipe By: <tab> name    [Keywords "Recipe By:" are required]

Serving Size: <tab> number    [This line is optional; if used, Keywords "Serving Size:" are reqd.]

Preparation Time: <tab> hours:minutes    [This line is optional;if used, Keywords "Preparation 
Time:" are reqd]

Categories: <tab> category1 <tab> category2 <tab> category3    [This line is optional; if used 
Keyword "Categories:" is required; there may be 10 categories]

BLANK Line

Amount Measure Ingredient Preparation Method

amt <tab> unit <tab> ingredient <tab> preparation method [You may repeat this line up to 100 
times; there must be NO blank lines between ingredients.]

BLANK Line

Directions. Free form text. Blank lines MAY exist in this section.

<tab> ----- <tab> 

[End-of-Directions; optional if you do not use "Notes" and "Serving      Ideas"]

Notes: <tab> Text    [This line is optional]

Serving Ideas: <tab> Text    [This line is optional]

_____ [Designates end of recipe.

]------------------------------------------

NOTE: The Mac format delimiter to separate ingredient and preparation method is: 

<tab> :      1 cup carrots<tab>chopped 



MasterCook Export Formats
You may export one, all, or a selected group of recipes from any MasterCook cookbook.

 All recipes selected for exporting will be put in a text file. The exporter will ask you for the name 
and location of the file it will create. You may view or edit this file, using your choice of text editors 
(ex., Notepad, Simple Text,etc.) or word processing programs (ex., MicroSoft Word, WordPerfect, 
etc.).

Because an exported recipe is simply a text file, it may be embedded into any text document of 
your choosing or opened with any editor or word processing programs. If you intend to share the 
exported recipes with other MasterCook users, it is recommended that you do not in any way 
change the format of the recipes via an editor. They may not import properly if you do.

When you export recipes from a MasterCook cookbook to a text file, they typically will be 
exported in the MXP format.



MasterCook Import Formats
A recipe MUST be in a format that MasterCook recognizes before it can be imported into a MC 
cookbook.    The MC "Recipe Translator" (or "importer") is very flexible and supports many 
different formats, including export formats from many popular commercial and shareware cooking
programs.    However, if a recipe is not in one of the accepted formats which contain specific 
delimiters that MC recognizes, it cannot be imported.

MasterCook will successfully import, or convert, text files containing recipes that were exported 
from the following programs:MasterCook programs:

MasterCook 4.0 ("MXP", "Mac", or "Generic" formats)
MasterCook 3.0 ("MXP", "Mac", or "Generic" formats)
MasterCook II    ("MXP" format)
MasterCook Mac ("MXP" or "Mac" formats)

Other cooking programs:

Cookbook USA 
Cooking Companion 1.x
Cooking Light Cookware 1.x (Windows & Mac)
From Scratch 3.x 
Key Home Gourmet
Meal-Master 7.x and 8.x    (Note: MC 4.0 supports MM    2-column recipes with dividers)
Micro Cookbook 1.x (Mac)
Micro Cookbook 3.x (Windows or DOS)
Micro Cookbook 4.x and 5.x
MicroKitchen Companion 2.x and 3.x

If a recipe was exported from any of the above formats, in most cases,you will not need to edit it 
prior to importing. It is ready to be imported into a MC cookbook as is. However, if the recipes are 
not in an acceptable format, they must be edited prior to importing. MasterCook can NOT import 
unformatted recipes.

TIP: To determine if recipes in your text file are formatted, look for "Beginning-of-Recipe" 
headers such as the following.    If none exist, then the recipes are not acceptable for 
importing.

*    Exported from    MasterCook    *

 ------OR------

MMMMM----- Recipe via Meal-Master (tm) v8.02

------OR------

@@@@@

TIP: If a file appears to be in an acceptable format,    try importing it and see if MC recognizes 
any or all of the recipes.    The recipes that can be imported will be presented to you in the 
"import selection" window.    Recipes that are not included in this list are not in a format that 
MC recognizes and need to be edited before they can be imported.



TIP: Many formats include an End-of-Recipe delimiter, such as "MMMMM" or"_____". Any 
text outside of the recipe "beginning-of-recipe header" or "end-of-recipe trailer" will NOT be 
imported. 



Recipes Import, but not Correctly
When a recipe does not adhere to a valid import format, it may still import into your MasterCook 
cookbook, but it may not import "cleanly." This section describes the most common formatting 
errors so that you may both correct and avoid them in the future.

TIP: By far, the most common cause of recipes not importing correctly has to do with BLANK 
lines. If a blank line is not encountered where a true blank line is required as a recipe section 
separator, OR if a blank line is found where a TEXT line is required, import errors will very 
likely occur.

This common problem is easily avoided in MC 4.0 by use of the new end-of-section delimiter ("|").
Start each required BLANK line with this control character, and you need no longer worry about 
hidden spaces or other non-displayable characters!

------

A required BLANK line MUST truly be BLANK; that is, it CANNOT contain any text characters, 
including non-printing ones such as spaces or tabs.    Required BLANK lines MUST contain ONLY
the end-of-line delimiter, such as a carriage return and line feed or a carriage return only.

Ensure that the ONLY characters on a required BLANK line are the end-of-line (or paragraph) 
delimiters. The easiest way to do this is to delete the entire line and insert a blank line by 
depressing the"Return" key.

TIP: MC 4.0 ONLY: Use the    "|" (vertical bar) control character at the beginning of each 
required separator line instead of the BLANK line!

------

A TEXT line MUST contain at least one text character. Non-printing characters, such as spaces 
and tabs, do qualify.

If a TEXT line contains only the end-of-line delimiter, insert at least one valid text character.

TIP: If you do use a non-printing character, it may be more difficult for you to distinguish a text
line from a blank line. Consider inserting a printing character such as an "*" instead of a 
space.

TIP: When a recipe does not import cleanly, view the text with an editor or word processing 
program that has an option to display non-printing characters, and inspect all lines that 
appear to be blank. "Editmaster","BBedit", "MS Word" or "Word Perfect" are examples of such
programs.This option is often called "Show Paragraphs", "Show", or "ShowInvisibles."

HOW DO YOU KNOW IF RECIPES IMPORTED INCORRECTLY?
MASTERCOOK 3.0 and 4.0 use the Import Results window to notify you that a possible error was
detected when importing a recipe.

The Recipe Translator will place all suspect recipes in the Import Results window. While in many 
cases the recipe did, indeed, import correctly, you should inspect each one listed in this window to
ensure that it is OK. If it is not, then you should correct the format in the text file and import again, 
or edit the imported recipe from within MasterCook. 

Most of the symptoms described below will result in the recipe being "flagged" (placed in the 
Import Results window). On occasion, you may find that even though the importer did not detect a
problem, a recipe still did not import correctly. Consequently, it is advisable that you import into a 
temporary or "import only" cookbook so you can easily identify all newly imported recipes.

NOTE: A recipe that is placed in the Import Results window is still imported into your 
cookbook. There is no need to copy or move the recipe to your cookbook as it is already 



there. You may open a recipe for inspection and editing from either the Import Results 
window or the cookbook window.

------

MasterCook 3.0 and 4.0 Windows users will NOT receive a warning message that a possible 
problem was detected and that a recipe was "flagged."    Therefore, it is recommended that you 
examine the Import Results clipboard after each import.

(Exception: When a duplicate recipe name is encountered, MC Windows users WILL receive a 
warning and the recipe will be renamed and placed on the Import Results clipboard.)

------

MASTERCOOK 3.0 and 4.0 Macintosh users will receive a warning messagewhen the Recipe 
Translator encounters suspected problems. These recipeswill be then be placed in the Import 
Results window with an accompanyingicon indicating the nature of the error.

------------------------------------------

See the Import Results Window  Help file for details on the nature of import errors that cause a 
recipe to be placed in this window.

--------------------------------------------------------

SYMPTOM: TITLE ONLY IMPORTED, everything else was blank
CAUSE/SOLUTION: The recipe did not adhere to a valid import format. In this case, 
MasterCook was able to identify the recipe title, but it could not identify any other parts of the 
recipe. You need to examine the recipe and make the necessary changes and then re-import 
it. "A-D" below address some specific cases.

------------------------------------------

A. If the recipe is in the Generic import format, then there MUST be a BLANK line following the 
title. The next line MUST be a "NOTE" line (comments that will appear in the "Note section"), 
followed by another BLANK line. Then the ingredients begin. You may not typically use "Notes"; 
however, one Note line is REQUIRED for MC 3.0 Mac users in the generic format. If you do not 
include the specified sequence of Title, a BLANK line, a non-blank line for "Notes," and another 
BLANK line, the Recipe Translator will not recognize the ingredients and/or directions.Inspect the 
Blank lines and ensure they contain only the EOL delimiter or the "|" (vertical bar) control 
character at the beginning of the line in MC 4.0! 

TIP: You want to include "Recipe By" information in the generic format?    Enter it on the 
required "Notes" line. After the recipe is imported, you can cut and paste the author to the 
"Recipe By" field, if you wish. 

TIP: You absolutely do NOT want "Notes" in any circumstance? Then put a non-printing 
character (such as a space or tab) on the required "Notes" line. Caution: This will result in the 
APPEARANCE of three blank lines in a row. It may be confusing or difficult for you to 
distinguish between the two blank lines and the line that contains a non-printing character.

------------------------------------------

B: The Ingredient section delimiter is missing in the format. Even ifyour recipe contains no 
ingredients, the formatted text must stillcontain the "Amount    Measure    Ingredient    Preparation 
Method" delimiter, ollowed by a blank line.For example: In the MXP format, the following 
ingredient header must be present (both lines exactly as they appear below), IMMEDIATELY 
beforethe first ingredient:

Amount      Measure            Ingredient -- Preparation Method

-------- ------------ -------------------------------- 

------------------------------------------



In the Mac format, the following ingredient header must be present (oneline, exactly as it appears 
below), IMMEDIATELY before the first ingredient:

Amount<tab>Measure<tab>Ingredient<tab>Preparation Method

------------------------------------------

In the Generic format, which does not use a keyword ingredient delimiter, TWO blank lines must 
precede the directions section if there are no ingredients.

TIP: To ensure "clean" importing by having the recipe format correct, it is much easier to 
include at least one ingredient in the recipe. For example, you might use " **** " as an 
ingredient. This is commonly used to denote that everything is included in the "direction" 
section.

------------------------------------------

C. If you are a MasterCook 3.0 and 4.0 user, this error may indicate that the text file contains Unix
end-of-line delimiters (line feeds only). MC cannot import these recipes until you change the text 
type.    See Supported Recipe Formats and Text Types for procedures on identifying and changing
the text types.

------------------------------------------

D. Ensure that all lines (if any) between the recipe title and the next part of the recipe format are 
indeed blank.

--------------------------------------------------------

SYMPTOM: DIRECTIONS ENDED UP IN THE INGREDIENTS
CAUSE/SOLUTION: There was not a BLANK line between the ingredients and directions.

View the text and insert a BLANK line by pressing the"Return" or "Enter" key. If a line that 
appears to be blank exists, it most likely contains non-printing characters such as spaces or 
tabs.Delete the line and insert a BLANK one that contains ONLY the EOL delimiters, by using the 
"Return" or "Enter" key.    If using MC 4.0, simply insert a "|" (vertical bar) at the beginning of each 
required Blank line.

--------------------------------------------------------

SYMPTOM: PART of the INGREDIENTS ENDED UP IN THE DIRECTIONS
CAUSE/ SOLUTION: A BLANK line was encountered in the ingredient section.

The Recipe Translator looks for a blank line to indicate the end-of-ingredient section. Therefore, 
everything following a blank line will be placed in the direction section.You must remove the blank
line or make the line non-blank by entering one or more text characters on the line, including a 
space or "tab."

TIP for MC 4.0 Users: A line that contains a space or "tab" that appears to be blank, can exist 
in the ingredient section to separate groups of ingredients. This line will be kept when 
importing.

TIP for MC 3.0, MC II, and MC Mac Users: A line that contains a space or other non-printing 
character (such as a tab) that appears to be blank can exist in the ingredient section. The 
ingredients will import properly, however, if the recipes are in MXP format; the line 
thatappears blank will not be preserved on import. Consequently, if you wish to separate 
groups of ingredients, use printing characters, such as "***" or "---", instead of spaces.

--------------------------------------------------------

SYMPTOM: ALL of the INGREDIENTS ENDED UP IN THE DIRECTIONS 
CAUSE/SOLUTION: The recipe did not adhere to a valid format. Examine the text and make 
the necessary changes. "A-D" below address the various conditions that might cause this 



error.

------------------------------------------

A: A BLANK line was encountered BEFORE the first ingredient. Delete the blank line, or make it 
non-blank by entering one or more text characters on the line, including a space.

-----------------------------------------

B. In the Generic format, TWO blank lines were encountered before the ingredients. One blank 
line after the "Notes" line indicates the beginning of ingredients. Two blank lines after the "Notes" 
indicates the beginning of directions.

-----------------------------------------

-C. In the MXP format, the following correct ingredient header was not encountered. Using any 
editor, insert BOTH of these lines, exactly as they appear below, IMMEDIATELY before the first 
ingredient.

Amount      Measure            Ingredient -- Preparation Method

-------- ------------ -------------------------------- 

------------------------------------------

D. In the Mac format, the following correct ingredient header was not encountered. Using any 
editor, insert this line, exactly as it appears below, IMMEDIATELY before the first ingredient.

Amount<tab>Measure<tab>Ingredient<tab>Preparation Method

--------------------------------------------------------

SYMPTOM: EXTRANEOUS TEXT at the end of the recipe's "DIRECTION" section 
CAUSE/SOLUTION: This text is most likely e-mail signatures and possibly all of the following 
headers and complete e-mail messages (if you are importing from a mailing list "digest").

The Recipe Translator will import all text found after the beginning of the direction section until it 
comes to an end-of-recipe delimiter, the next beginning-of-recipe header, or the end-of-file.

You may edit the text file BEFORE you import, and either: 

REMOVE all text following the recipe that is not part of the directions

 -OR-    

ADD the appropriate end-of-recipe delimiter for the recipe's format.    

(In MC 4.0, the end-of-recipe delimiter is "_____" (5 underscores).) 

If you prefer, you may easily edit the recipe AFTER it was imported by simply opening the recipe 
and deleting all unwanted text from thedirections.      

TIP for MC 3.0, MC II, and MC Mac Users: The Generic import format does not use an end-of-
recipe delimiter. EVERYTHING following the first line of directions will be imported as directions 
until the next "@@@@@" or end-of-file is encountered. You may either add "@@@@@" at the 
end of the directions to begin another new recipe, or delete all text that is not part of the recipe.

--------------------------------------------------------

SYMPTOM: EXTRANEOUS TEXT at the end of the "NOTES" section
CAUSE/SOLUTION: A "Notes" section existed in the MXP format.    All text following the 
keyword "Notes :", will be imported as text until a beginning-of-recipe header or end-of-file is 
encountered. 

You may edit the text file BEFORE you import and remove all text following the Note that is not 
part of the recipe. OR you may edit the recipe AFTER it is imported and simply delete all 
unwanted text from the"Notes" section.



--------------------------------------------------------

SYMPTOM: PREPARATION METHOD IMPORTED IMPROPERLY: it was placed in the 
"Ingredient" field instead of the "Preparation Field"

CAUSE/SOLUTION: An incorrect delimiter was used to separate the ingredient and the 
preparation method.

NOTE: This is typically only of concern if you plan on using the Nutritional Analysis feature of 
MasterCook. If the preparation method (ex., "chopped") ends up with the ingredient (ex., 
"carrots") in the "ingredient field",    MC is likely to not recognize the ingredien ("carrots, 
chopped") for calculating the nutritional analysis

."A-C" below offer possible ways to resolve this problem.

------------------------------------------

A: Edit the import source file so recipes use the correct delimiter according to the following:

Format                Delimiter                                                                                                  Example

-------------        ------------------------------------------------------------      ----------------

MXP                   "space 2 dashes space" (" -- ") 1 cup carrots -- chopped

Mac                      <tab> 1 cup carrots<tab>chopped

Generic          semi-colon    (;) 1 cup carrots;chopped      OR 

comma (,) 1 cup carrots,chopped      OR

<tab> 1 cup carrots<tab>chopped

TIP: The "generic" format and the "Mac" format both support the use of"TABS" as a delimiter; 
however, it is advisable that you do NOT use tabsi f you plan on sharing recipes via the 
Internet. Some Internet service providers and some e-mail programs strip all tabs from text 
documents.This will prevent the preparation method from importing properly.

TIP: MC 3.0 and 4.0 users: In MealMaster recipes, the semi-colon is the ONLY delimiter 
recognized by the recipe translator. So if the preparation method is not importing correctly, 
insert a semi-colon between the ingredient and the preparation method.

------------------------------------------

B: Open the recipe(s) in MasterCook and manually move the preparation method to the correct 
field.

------------------------------------------

C: Edit the ingredients list and create a new ingredient with a name that includes the preparation 
method.Example: Edit "carrots" and save a copy of the nutritional information with a new name of 
"carrots, chopped."

--------------------------------------------------------

SYMPTOM: Text that was in the ingredient field was moved to the amount or unit field on 
import.

CAUSE/SOLUTION: The text contained an amount or unit that the RecipeTranslator 
recognized, so it placed it in what it interpreted to be theappropriate fields. 

To force text to remain in the ingredient field, insert a "-" (dash) at the beginning of the ingredient 
field. The importer will ignore all text following the dash.

--------------------------------------------------------

SYMPTOM: "EMPTY" LINE separating groups of ingredients disappeared when importing.



CAUSE/SOLUTION: Do not use lines with only spaces to separate a group of ingredients in 
releases prior to MC 4.0. When a line containing spaces (so it appears "empty") is in the 
ingredients section, it will not be preserved when importing an MXP formatted recipe in MC 
3.0, MC II, or MCMac. To visually separate ingredients, it is best to use any printing 
characters in the ingredients field, rather than spaces. (Ex., "----" or"****")

Ingredient lines with spaces only in the Generic format will be stripped when imported in all 
versions of MC.

NOTE: If you skip a line when adding ingredients to a recipe in a cookbook, MC will 
automatically insert "spaces" for you on that line. So even though the line appears "empty" it 
is not truly a blank line. (See the discussion under "INGREDIENTS ENDED UP IN THE 
DIRECTIONS" earlier in this section.)

--------------------------------------------------------

SYMPTOM: "=20" CHARACTER STRING in recipe
CAUSE/SOLUTION: MS Exchange inserts these characters and all non-MSExchange users 
will experience this problem. The recipes may or may not import, depending on exactly where
the "=20"s are located. And if they do import, you will most likely find "=20" scattered 
throughout your recipe. It is best if you edit the text file and remove every occurrence prior to 
importing.

TIP: If you are a MS Exchange user, you may want to follow the procedure in the Cannot Export 
Recipes Help file to prevent the insertion of these foreign characters.

--------------------------------------------------------

SYMPTOM: "Bullet" is in the Preparation Method Field (MC 3.0 and 4.0ONLY)
NOTE: The "bullet" will appear as a blank rectangle on Windows systems and as a black dot 
on Macintosh systems.

CAUSE/SYMPTOM: The most likely cause is that the amount and unit combination is invalid. 
Typically this will only occur when two amounts and two units are specified for one ingredient,
and one of the units is not a "container."

For example, "1 (15 oz) can tomatoes" is meaningful; the (15 oz) is defining the size of the can. 
Just as "1 (12 oz) package tofu" also makes sense. Both of these will import correctly with the 
measurement descriptor, (15 oz) or (12 oz), being placed in the preparation method field.

However, "1 (32 oz) quart" contains two pre-defined measurements; it is redundant and 
meaningless. This ingredient will be appear in the recipe with a "bullet" in the Preparation Method 
field and the recipe will beplaced in the Import Results window.

NOTE: MC makes every effort to import recipes such that accurate Nutritional Analysis may 
be calculated. Because of this, amount and unit are checked for validity. When they do not 
make sense or are confusing,the ingredient and the recipe are flagged.

--------------------------------------------------------

SYMPTOM: RANGE of AMOUNT didn't import 
CAUSE/SOLUTION: The amount specified was a range (Ex., 4    -6 cups water,or 4 to 6 cups 
water) and only the lower amount was imported.

MasterCook II and MasterCook Mac will not import a range of amounts.So, if a range is specified,
the lower number will be preserved and the upper end of the range will be thrown away.

MasterCook 3.0 and 4.0 will place the lower end of the range in the "Amount" field and put the 
original range in parenthesis in the "Preparation Method" field.TIP: MC cannot do Nutritional 
Analysis on an ingredient unless only one amount is specified. If you want the N/A do to be 
calculated using the upper end of the amount, simply make the change in the Amount field.



--------------------------------------------------------

SYMPTOM:    Don't want those FOREIGN CATEGORIES added to your cookbookwhen you 
import?

CAUSE/SOLUTION for MC 4.0 Users Only: Un-check the "Import Categories" box in the 
Import dialog window.

--------------------------------------------------------

SYMPTOM: NOT ENOUGH RECIPES to import?
CAUSE/SOLUTION: You are having so much success with importing that you need more recipes! 
Subscribe to the MasterCook recipe exchange mailing list. Send an email message to: < mc-
recipe@listserv.sierra.com >. The bod yof your message should read: subscribe mc-recipe end



Resizing and Repositioning Recipe Elements

This Help file details how to change the size and position of recipe elements on the page, giving 
you a level of design control much like that provided by page-layout software. There are no 
guidelines for how to arrange the recipe elements on the page other than your own creativity and 
imagination; once you've learned how to resize and reposition recipe elements, you can create 
recipe designs in endless combinations.

To resize a recipe element:
You can resize a recipe element by dragging the edges of the recipe element. The edges of the 
recipe element are marked by the solid frame which is drawn around the recipe element when it is
selected. To drag the edge of a selected element, move the arrow pointer over the edge until it 
turns into a two-way arrow, then hold down the mouse button while dragging.

Dragging the left or right edge of the recipe element changes the width of the recipe element. 
Dragging the top or bottom edge of the recipe element changes the height of the recipe element.   
Dragging a corner of the recipe element changes the overall size of the recipe element. 
MasterCook for Windows "stretches" the recipe element to fill the resized area.

To reposition a recipe element:
In addition to changing the appearance and sizing of recipe elements, you can reposition the 
recipe elements on the page in any order you choose.    With MasterCook for Windows, simply 
click on the recipe element you wish to move, hold down the mouse button, and drag the recipe 
element to the desired position. 



Sending Recipes as an Attachment
If your e-mail program supports sending "attached documents", you may send the text file that 
contains exported recipes as an "attached document" to an e-mail message. Simply export the 
recipes you wish to send into a text file and then "attach" that text file to your e-mail message.

Alternatively, you may send an entire cookbook as an attachment. In thiscase, you tell the e-mail 
program to attach the cookbook by providing the cookbook filename and its location.

If the attached files are large, you may want to compress or "zip" them before sending.

NOTE: A MasterCook cookbook file is NOT a text file, so the recipient must have MasterCook
in order to view the recipes. Cookbooks are fully portable; that is, they may be exchanged 
and opened with any version of MasterCook on both Windows and Macintosh systems.

TIP: It is not advisable to send attached documents to mailing lists or newsgroups because 
many users will not be able to receive the attachments. Confirm with the recipient that their e-
mail program can handle attached documents prior to sending recipes this way.



Sending Recipes via E-mail
There are basically two ways in which you can send recipes via e-mail.You can use the 
MasterCook Recipe Mailer (MC 3.0 and 4.0 users ONLY) or you can "export" the recipes to a text 
file and then embed the recipes in your e-mail message.

For detailed procedures on how to use the MasterCook Recipe Mailer, see e-mailing recipes. The
primary advantage of using the Recipe Mailer is that it reduces the steps necessary to send 
recipes via e-mail. Note that you can even enter your e-mail message (that is not part of a recipe) 
in the Recipe Mailer window.

If you are a MasterCook II or MasterCook Mac user, you must first export the recipes to a text file,
using the standard "export" procedures. Then open the text file that contains the exported recipes
and do a "Select All". Do a "copy" and then go to the e-mail message you wish to send. Do a 
"paste" and the formatted recipes will be inserted into the body of the e-mail message. Send the 
e-mail message following your normal procedures.

NOTE: Many e-mail programs automatically append your e-mail signature at the end of every
e-mail message. Because in some cases, your trailing signature may be imported as part of 
the recipe, it is recommended that you turn off the automatic signature when e-mailing 
recipes. If you wish to include your signature, then put it BEFORE the beginning of the first 
recipe.

NOTE: You may exchange recipes from MasterCook via e-mail with both MC and non-MC 
users. Exported recipes are simply text files that any user can view and, optionally, edit. MC 
users will be able to directly import your recipes, adding them to cookbooks in their own 
collection.

TIP: Want to post recipes on a newsgroup directly from MasterCook? You can do so by using 
a "mail to news" gateway.There are a number of public servers that provide this service and 
some of them may be found at http://students.cs.byu.edu/~don/mail2news.html 

Here are a few currently known to be working:

group.name@news.cs.dal.ca
group.name@news.demon.co.uk
group.name@dispatch.demon.co.uk
group.name@magus.dgsys.com 
group.name@berlioz.crs4.it
group.name@brushtail.hna.com.au
group.name@news.uni-stuttgart.de 
Example of how to use these gateways:

To post recipes on "rec.food.recipes" using the first server, send an e-mail message 
containing the recipes to<rec.food.recipes@news.cs.dal.ca> .

(You may create the e-mail message with the recipes either by using theMasterCook Recipe 
Mailer or by exporting and then copying and pasting the recipes into an e-mail message.)



Supported Recipe Formats and Text Types

You received formatted recipes from the Internet and you want to import them into MasterCook?    
First, give it a try!    In most cases the MasterCook importer will successfully import recipes, even 
if they contain the wrong end-of-line delimiters. But if the recipes cannot be imported or they do 
not imported "cleanly", you may be trying to import recipes that are a combination of format and 
text type that MasterCook does not import.

Check the following chart for the version of MasterCook you are running and locate the exact 
RECIPE FORMAT and TEXT TYPE you are trying to import. (See "HOW TO IDENTIFY RECIPE 
FORMAT" and "HOW TO IDENTIFY TEXT TYPE" below.)

If the box says "NO", then you will need to edit the recipes so they are in an acceptable 
combination of both format and text type. 

TIP: It will generally be easier to change the text type than the recipe format. (See "HOW TO 
CORRECT TEXT TYPE" below.) Of course, if a recipe format is not supported by your 
version of MasterCook, then you must change the recipe format to one that is acceptable.

If the box says "YES", then the format and text type are NOT the roblem. Even if the recipes 
contain EOL delimiters that are invalid foryour system, MasterCook will be able to read the 
recipes and it will convert the EOL delimiters as it imports. See the What Went Wrong? Help files 
for other possible problems and solutions.

TIP: If the text type is incorrect, the recipes were most likely downloaded and a text file was 
downloaded as raw data (binary) file type so text translation did not occur. Instead of 
changing the text type yourself, you may wish to download the recipes again, this time 
specifying "text" as the file type. Your downloading program will, in most cases, do the text 
translation for you.

IN SUMMARY:

-- MasterCook 3.0 and 4.0 can import ALL formats with either DOS or Mac EOL delimiters.

-- Unix delimiters (line feeds only) can NOT be successfully imported by any version of 
MasterCook, regardless of format. See "HOW TO CORRECTTEXT TYPE" below.

-- MasterCook II can import MXP formats ONLY with DOS EOL delimiters and Mac formats ONLY
with Mac EOL delimiters

-- MasterCook Mac can import MXP formats with either DOS or Mac EOL delimiters. MasterCook 
Mac can also import Mac formats with either DOS or Mac delimiters.

HOW TO IDENTIFY RECIPE FORMAT:

View the recipes in the text file with any editor or word processing program.

-- MXP formatted recipes will begin with:    *    Exported from    MasterCook    *

-- Mac formatted recipes will begin with: { Exported from MasterCook Mac }

 -- Generic formatted recipes will begin with: @@@@@

HOW TO IDENTIFY TEXT TYPE:

The following systems use these end-of-line (EOL) delimiters:



DOS:    Carriage Return, Line Feed

Mac:    Carriage Return

Unix: Line Feed

HINTS on how to determine the text type: 

How did you receive the recipes? 

-- via EMAIL: The text type will match YOUR system type regardless of the system it came from. 
The email program translates the text type when a message is received. For example, if you use 
a DOS system, all of your email will be converted to contain DOS EOL delimiters.

 -- via ATTACHED DOCUMENTS or DOWNLOADED: View the recipes with a text editor (such as 
Simple Text or Notepad):    If the recipes look correct, then the text type matches YOUR system 
type. For example, if you are a Macintosh user, then the recipes will    contain Mac EOL 
delimiters.If the lines appear to be run-on and/or contain non-text characters such as "black 
rectangles" or "blank squares", then they contain EOL delimiters that your system does not 
recognize. For example, you are a DOS user and      the file came from either a Macintosh or Unix 
system.

TIP: Some editors (such as BBedit on a Macintosh system and Editmaster on DOS) will show
you what type text a file contains. An editor with this capability is an invaluable tool if you do a
lot oftext file exchange outside of e-mail.

TIP: Files on the Internet are often stored on Unix systems. Because of this, there is a likely 
chance that recipes you download will contain Unix EOL delimiters. If you specify "text" as the
file type when you download, your downloading program should do the translation for you.

HOW TO CORRECT TEXT TYPE
Once you have determined that a file's text type is preventing recipes from importing, you will 
need to convert the EOL delimiters. Following are several methods that you may use to correct 
the text type.

1) Download the file again, specifying "text" as the file type.

2) Use an editor or word processing program to automatically convert the text type.

TIP: Some editors (such as BBedit on a Macintosh system and Editmaster on DOS) will show
you what type text a file contains. If you have such an editor, it will also convert the file to 
contain the correct EOL delimiters for you.

TIP: Many word processing programs will translate the text type for display when you open 
the file.(MicroSoft Word, WordPad, Word Perfect,and ClarisWorks are some examples.) After 
opening the text file, do a "save as" and specify a file type of "Text". The "pure text" format will
be preserved and the file will be stored with the correct EOL delimiters. 

An alternative to saving the file as text, is to do a "select all" and "copy" the file. Then simply do a 
paste into a text file. This willeffectively convert the text type for you. To verify that the file was 
converted, open it with NotePad or SimpleText and make sure the text looks OK. If not, then you 
will need toconvert the text manually.

3) Manually change the end-of-line delimiters on each logical line.

WINDOWS USERS:

Required EOL Delimiters:

Carriage Return AND Line Feed

Symptoms of wrong EOL delimiters:

-- Lines all run together across the page with one black rectangle appearing after each logical 



line. This text contains either carriage returns only (Mac EOL delimiters) OR line feeds only (Unix 
EOLdelimiters) at the end of each line.    A carriage return AND line feed need to be at the end of 
each logical line. (Note that a black rectangle with no text before it indicates a blank line that must
be inserted.)

Procedure to Correct the Text Type:
TIP: Some editors (such as Editmaster) will automatically convert the EOL delimiter for you. If
you have such an editor, simply select the text type and save the file.

TIP: Many word processing programs will translate the text type for display when you open 
the file.(MicroSoft Word, WordPad,and Word Perfect are some examples.) After opening the 
text file, do a "save" and it will be stored with the converted end-of-line delimiters. (To verify 
that the file was converted, open it with NotePad and make sure the text looks OK.) If not, 
then you will need to manually convert the text.

To manually correct the text type:

 -- Select the foreign character (black rectangle) at the end of each logical line.

 -- Delete the character using the delete key. If two or more rectangles appear together, delete 
each of them.

 -- Press the "Return" key. Make sure you press "Return" once for each    rectangle you delete. 
This will add the correct carriage return and    line feed.

 -- Repeat this process for every foreign (non-text) character you see.

 -- Save the file. Import it into MasterCook.



Uploading Complete Cookbooks
If you are sharing recipes with another MasterCook user, you may wish to send a complete 
cookbook as opposed to first exporting the recipes to a text file. When a user receives a complete
MC cookbook, they need only to open it from within MasterCook in order to view the recipes.

You may either send a complete cookbook to an individual user, a group of users, or to an 
Internet site where it is available to others for downloading. There are a number of network 
transfer programs available that you may use to send or "upload" your cookbooks. Popular 
programs include Netscape, Fetch, Mosaic, or Gopher.

TIP: MasterCook cookbooks are in raw data (binary) format and should not be sent as text 
files. If the transferring program attempts to transfer them as text, translation may occur, 
rendering the cookbook unreadable.



************************************************************************
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*
************************************************************************

This guide describes, in detail, how to import and export MasterCook
recipes so that you may easily share them with others. And because
recipe exchanges occur frequently via the Internet, this guide also
includes information on exchanging recipes electronically.

If you encounter problems importing, locate the symptom in "Part 4: What
Went Wrong?" and you will find the associated cause and suggested
solutions.

The following MasterCook versions are covered in this document:

 MasterCook 4.0 (including a special section on what's new)
 MasterCook 3.0
 MasterCook II 
 MasterCook Mac
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0.1    WHAT'S NEW IN MASTERCOOK 4.0

************************************************************************

Many significant new features were added to make importing recipes into
MasterCook 4.0 easier and more accurate than ever! A summary of the most
exciting new features follows.

*** End-of-Recipe Delimiter: "_____"    (5 underscores) ***

Now there is a definitive way to tell the Recipe Translator where the



end of the recipe text is! Simply insert "_____" (5 underscores) at the
beginning of the line immediately following the end of the recipe text.
When the Recipe Translator encounters this control string, it will cease
importing the current recipe and begin looking for the next
beginning-of-recipe header.

You now have precise control over where the recipe text ends, so you no
longer have to bother removing e-mail headers and trailers from your text
files prior to importing. No more surprise text in the "Notes" section!

*** Exclude Categories When Importing (optional) ***

Hate all those foreign categories that get added to your cookbook
everytime you import a recipe? Now you can simply turn off the import of
all categories by un-checking the "Include Categories" box in the Import
dialog window.

But you want to include categories, at least some of the time? No
problem! The include/exclude option can be set on each import.

*** End-of-Section Delimiter: "|" (vertical bar) ***

Have you had difficulty with those troublesome BLANK lines that are
required in the "Generic" import formats? Well, no need to fret anymore.
Instead of ensuring those required lines are truly BLANK, simply insert
a "|" (vertical bar) at the beginning of each separator line. This
indicates to the Recipe Translator that it has encountered the end of
that recipe section.

You can, of course, continue to use BLANK lines as end-of-section
indicators. Just beware that if the line contains even one "space", the
recipe will not import correctly. When you use the "|" control
character, you need not worry if the line is blank.

*** Paste Text As Ingredients ***

Now you can copy text from any file (such as an e-mail message) and paste
it into the ingredient section of a MasterCook recipe! Simply copy the



text and then select the "Paste As Ingredient" option under the Edit
Menu. The copied text will be translated and placed in the appropriate
amount, unit, ingredient, and preparation method fields, just as they
are when you "import" a formatted text recipe.

You don't want to format a text recipe and then import it? Then try
adding it to your cookbook by using copy and paste. First copy and then
paste the ingredients using "Paste Text as Ingredients". Then copy and
paste the title, author, and/or the directions.

This function is also very useful for those occasions when the
ingredients erroneously imported into the directions section. Now,
clean-up is easy. Just copy (or cut) the ingredients and then "Paste
Text As Ingredients".

*** Ingredient Lines With All Spaces (or Tabs) Will be Preserved ***

You may now use lines with only spaces or tabs in the Ingredient
section to separate groups of ingredients!

In past releases, if you did not include at least one displayable
character in an ingredient line, the line was stripped when the recipe
was imported. In Version 4, these lines (which appear to be "blank")
will be kept in the ingredient section.

(Note that this applies only recipes imported in the MXP format.
Ingredient lines with all spaces or tabs in the "generic" format will be
stripped when imported.)

***    "Notes" Line No Longer Required in Generic Import Format    ***

In MasterCook Version 3, Mac users were required to have the one line of
"Notes" in the generic import format. This has been changed, so if you
don't want to use the "Notes" section of the recipe, you no longer have
to! The generic format may now include just the title, ingredients, and
directions, and, of course, the required format controls. (See APPENDIX
C: GENERIC FORMAT for details.)

*** Improvements in Importing MealMaster Recipes ***



MealMaster recipes that contain two-columns of ingredients and dividers
can now be successfully imported into MasterCook!

In addition, recipes with MealMaster dividers are now imported with a
divider that looks good in MasterCook.

Example of a part of a MealMaster, 2-column recipe with dividers:

---------------------------------ICE CREAM------------------------------
            1 qt Vanilla ice cream                                      1 c    Heath bars; chopped

-------------------------------CARAMEL SAUCE----------------------------
    1 1/3 c    Whipping cream                                            2 tb Unsalted butter; cut into
            1 c    Sugar                                                                        - 4 pieces
            3 tb Water

************************************************************************

PART ONE: BASICS OF FILE TRANSFER ON THE INTERNET

************************************************************************

If you are planning on exchanging recipes via the Internet, it is
important that you understand the basics of electronic file transfer.
This will be helpful to you in getting started, and this understanding
will be particularly valuable when "things go wrong".

Details on how to exchange MasterCook recipes via the Internet will be
covered in "Part Two: Importing Recipes" and in "Part Three: Exporting
Recipes".If you are an experienced user of e-mail and file transfers on
the Internet, you may wish to skip to the MasterCook specific 
discussions.

________________________________________________________________________ 

1.1    BASICS OF FILE TRANSFER ON THE INTERNET:    TYPES OF FILES
________________________________________________________________________



There are two types of data files that you will encounter on the
Internet: "TEXT" and "RAW DATA" (also called "BINARY") files.

-- TEXT files are "readable" by you; that is, they are in a language
that people    understand (i.e., English, Spanish, German, etc.). You can
open them, view them, and edit them via any number of text editors (ie,
Notepad, Simple Text, etc.) or word processing programs (ie, MicroSoft
Word or Word Perfect). e-mail messages are always "text" files. Likewise,
recipes that are "EXPORTED" from cooking programs are also text files.

However, not all text files are alike. Different computer operating
systems expect different controls signalling the "end of line" (EOL) in
text files. Thus, you will encounter three different "end of line"
indicators:

                DOS systems:                    Carriage Return AND Line Feed
                Macintosh systems:        Carriage Return 
                Unix systems:                  Line Feed
                
If a text file contains the incorrect "end of line" indicator for your
system, you most likely will not be able to view the file correctly with
a text editor; it will appear "garbled". You will typically see the text
lines all run together, and/or a foreign character (such as a black
rectangle or blank square) at the logical end or beginning of each line.

TIP: Incorrect EOL delimiters are not typically a problem in e-mail
because your e-mail program will do whatever translation is necessary for
your system. However, if you receive text files outside of e-mail (ie,
downloaded or attached documents), they may contain the incorrect
control characters and you will need to convert them.

TIP: Incorrect EOL delimiters are not typically a problem for MasterCook
3.0 and 4.0 users, because, in most cases, the Recipe Translator can
import the recipes correctly even if they contain invalid EOL delimiters
for your system. (For more on this subject, see "APPENDIX D: SUPPORTED
FORMATS AND TEXT TYPES".

------------------------------------------

-- RAW DATA files look like "garbage" if you attempt to view them via a



text editor. They are often executable files (such as applications or
execs), or they are in a format very specific to a program and can only
be viewed via that program. An example of a "raw data" file is a
complete MasterCook cookbook. You can exchange complete cookbooks with
others; you need only open the cookbook from within MasterCook.

NOTE: MasterCook cookbooks are completely compatible across all versions
of MasterCook and all platforms. This means that all MC Windows and Mac
users, regardless of their MC version, can exchange complete cookbooks,
with absolutely no conversion required!

TIP: Both text and raw data files may be "compressed" to reduce their
size before being transferred on the Internet.    A compressed or "zipped"
file must be expanded or "unzipped" before it can be processed. There
are many different commonly used compression/expansion schemes and
utility programs (such as "PKZIP" and "StuffIt Expander").

Sometimes a compressed file is "self-extracting" meaning that it
contains the information necessary to be expanded without your having
the expansion software. If a compressed file is NOT self-extracting,
then you must have a software program that can read and expand the file.

TIP: Recipes in MasterCook cookbooks will be automatically stored in a
compressed format if you select that option under "Preferences" (under
the "Tools" menu option). This option will significantly reduce the
amount of disk space required by your cookbooks. Because of the
incompatibility among file compression programs, you may avoid many file
exchange problems if you do not further compress a cookbook prior to
sending it electronically.

________________________________________________________________________

1.2    BASICS OF FILE TRANSFER ON THE INTERNET:    TRANSFERRING FILES
________________________________________________________________________

You can send and receive files on the Internet via three basic ways:

1) e-mail

e-mail messages are always "text" files and are sent and received using
an e-mail program such as Eudora, Microsoft Exchange, etc.



When you receive a file, your e-mail program will perform whatever
"translation" is required for you to be able to read the text. (For
example, if the text originated on a DOS system and was received on a
Macintosh system, the "line feeds" are stripped.) This is why you can
read messages sent from systems different than yours.

The primary and simplest method for exchanging recipes via the Internet
is through e-mail. Typically, recipes you send and receive will be
embedded in the body of an e-mail message. By using e-mail, you will
ensure that in most cases your recipes can be read and vice versa. There
will often be commentary and a signature surrounding the actual recipe,
but that will not impact MC's ability to import. (For details on how to
"process" these recipes, see "Importing Recipes From e-mail" later in
this document.)

2) "ATTACHED FILES" (to e-mail messages)

Occasionally someone will "attach" a file to an e-mail message. These
files may be either text or raw data files. Some e-mail programs (ie,
Eudora) support sending and receiving "attachments". If your e-mail
program does support attached files, you tell it where you would like
attached files to be stored. When an attached file is received, you will
see a message in your "In" box informing you of receipt and file name.

Sending attached files is a very convenient method of transferring large
text files or raw data files directly to other users. Note that attached
files are not an "e-mail" message, thus, they are not subject to the same
e-mail message size limitations. (There may be a file size limitation
imposed by your service provider, but it will be significantly larger
than an e-mail size limit.) Raw data files sent as attachments will not
translated to text.

It is not recommended that you send recipes as "attachments" to mailing
lists or newsgroups, because many e-mail programs do not recognize and
support attached documents. (Indeed, sending attached files to news
groups and mailing lists is considered to be a "breech" of Internet
etiquette.) Furthermore, there is no one standard on how attachments are
handled. Before sending an attached document, you should confirm that
the recipient can handle it.



3) UPLOADING/DOWNLOADING

When you request a copy of a file be electronically sent from a site on
the Internet to your computer, you are "downloading". These files may be
either text or raw data files and there is a variety of software
programs that enable this transmission. (Examples of these programs are:
Netscape, Fetch, Gopher, Mosaic, or your Internet service provider may
provide their own.)

If you send a file from your system to be stored on another system, that
is called "uploading". Once a file is "uploaded", it may be available
for others to "download".

You will typically be downloading either files containing recipes (text
files) or complete MasterCook cookbooks (raw data files) from the
Internet.

************************************************************************

PART TWO:    IMPORTING RECIPES

************************************************************************

________________________________________________________________________

2.1    IMPORTING RECIPES: ADDING RECIPES TO MASTERCOOK
________________________________________________________________________

There are three ways in which you can increase your MasterCook recipe
collection.

--> 1) TYPE, or manually "enter" by keying, recipes into a MasterCook
"New Recipe" window

This method is typically used for recipes that are not currently
available in electronic form. (I.E., they exist only on paper in
cookbooks, magazines, newspapers, old recipe cards, etc.)

MasterCook's "fast fill" feature significantly minimizes the number of
key strokes required to enter a recipe's ingredients. (For more



information, see "Recipes, entering" in your MasterCook User's Guide.)

--> 2) IMPORT recipes from "TEXT" files that are in a supported format

Recipes in electronic format as "text" files are typically those that
you received in e-mail messages, scanned in from magazines or newspapers,
downloaded from the Internet, or are entered into another cooking
program.

A recipe MUST be in a FORMAT that MasterCook recognizes before it can be
"imported" (electronically added) to a MasterCook cookbook. (See
"MasterCook Import Formats" in this document for descriptions of
acceptable formats.) Text files that are not in a supported format can
NOT be imported.

This document focuses primarily on importing.

--> 3) ADD a complete MasterCook cookbook
 
You may add a complete cookbook to your collection simply by copying the
cookbook to your system and opening it with MasterCook. Typically you
will receive or download an entire cookbook from the Internet (for
example, from the MasterCook Web page at      http://www.sierra.com    ).

These files are not text files, but rather are in "raw data" or "binary"
format. A complete cookbook does not contain "exported" recipes, and,
therefore, does not need to be "imported". To view the recipes, the
cookbook must be opened from within MasterCook.

_______________________________________________________________________

2.2    IMPORTING RECIPES: MASTERCOOK IMPORT FORMATS
________________________________________________________________________

A recipe MUST be in a format that MasterCook recognizes before it can be
imported into a MC cookbook. The MC "Recipe Translator" (or "importer")
is very flexible and supports many different formats, including export
formats from many popular commercial and shareware cooking programs.
However, if a recipe is not in one of the accepted formats which contain
specific delimiters that MC recognizes, it can not be imported.



MasterCook will successfully import, or convert, text files containing
recipes that were exported from the following programs:

MasterCook programs:

                MasterCook 4.0 ("MXP", "Mac", or "Generic" formats)
                MasterCook 3.0 ("MXP", "Mac", or "Generic" formats)
                MasterCook II    ("MXP" format)
                MasterCook Mac ("MXP" or "Mac" formats)

Other cooking programs:

                Cookbook USA
                Cooking Companion 1.x
                Cooking Light Cookware 1.x (Windows & Mac)
                From Scratch 3.x
                Key Home Gourmet
                Meal-Master 7.x and 8.x
                    (Note: MC 4.0 supports MM    2-column recipes with dividers)
                Micro Cookbook 1.x (Mac)
                Micro Cookbook 3.x (Windows or DOS)
                Micro Cookbook 4.x and 5.x
                MicroKitchen Companion 2.x and 3.x

If a recipe was exported from any of the above formats, in most cases,
you will not need to edit it prior to importing. It is ready to be
imported into a MC cookbook as is. However, if the recipes are not in an
acceptable format, they must be edited prior to importing. MasterCook
can NOT import unformatted recipes.

TIP: To determine if recipes in your text file are formatted, look for
"Beginning-of-Recipe" headers such as the following. If none exist, then
the recipes are not acceptable for importing.

                                            *    Exported from    MasterCook    *

                                                        ------OR------

MMMMM----- Recipe via Meal-Master (tm) v8.02



                                                      ------OR------

@@@@@

TIP: If a file appears to be in an acceptable format,    try importing it
and see if MC recognizes any or all of the recipes. The recipes that can
be imported will be presented to you in the "import selection" window.
Recipes that are not included in this list are not in a format that MC
recognizes and need to be edited before they can be imported.

 
TIP: Many formats include an End-of-Recipe delimiter, such as "MMMMM" or
"_____". Any text outside of the recipe "beginning-of-recipe header" or
"end-of-recipe trailer" will NOT be imported. This means that there is
no need for you to expend the effort to delete comments, e-mail headers,
or e-mail signature lines. MC will take care of that for you.

________________________________________________________________________

2.2.0 IMPORTING RECIPES: HANDLING UNFORMATTED TEXT FILES
                    FOR MASTERCOOK MAC and MASTERCOOK II USERS
________________________________________________________________________

To successfully import recipes with MC Mac or MC II, text recipes MUST
be in the MasterCook "MXP" or "Mac" import formats, or in a format from
one of the programs listed above. If the recipes are unformatted (for
example, they were not exported from one of the above programs), they
must be edited to agree with one of these formats before they will
successfully import.

A text file may contain one or many recipes; however, all recipes must
be in the same format to import. If there is more than one format within
the file, the Recipe Translator will recognize recipes in ONLY ONE
format. Likewise, if the file contains unformatted recipes, they will
not be recognized for importing.

If you have recipes in several different formats (such as in a mailing
list digest), you should create a file for each format (i.e., all
recipes exported from MM in one file, all recipes exported from MC in
another file).



NOTE: This does NOT apply to MasterCook 3.0 or 4.0. In MC 3.0 and 4.0,
all recipes in a valid format will be imported, regardless of the 
mixture or order of the formats within one file.
------------------------------------------------------------------------

-- MASTERCOOK II (WINDOWS) USERS ONLY: You must put your unformatted
recipes into the "MXP" format (See the Appendix A for details of this
format). You may, of course, make these format changes manually with any
text editor of your choice. However, the following shareware program is
available to assist you in readying your unformatted recipes for import:

                  Txt-to-MasterCook 
(Information available on the MasterCook Web Page:
 http://www.sierra.com )
                

------------------------------------------
EXAMPLE of a recipe in "MXP" format:

                                            *    Exported from    MasterCook    *
                                                                        
                                                Grilled Tossed Vegetables

Recipe By          : Jo Anne Merrill
Serving Size    : 4        Preparation Time :0:40
Categories        : Grill/Camping Recipes                        Vegetables
                                Healthwise

    Amount    Measure              Ingredient -- Preparation Method
--------    ------------    --------------------------------
      6            cups                    eggplant -- peeled and cubed
      1            medium                green bell pepper -- chopped
      1            large                  onion -- chopped
      1            tablespoon        margarine
          1/4    teaspoon            basil
      2                                        tomatoes
                                                salt -- to taste
                                                pepper -- to taste



1. Peel and cube eggplant to make about 6 cups. Mix with the chopped 
      green pepper and chopped onion.
2. Cut 3 pieces of heavy-duty foil about 12 x 18 inches. Divide the
      eggplant mixture evenly on foil. Place 1 teaspoon margarine on 
      mixture; sprinkle with basil, or if preferred use chopped fresh 
      basil. Close foil tightly. 
3. Place foil packs on grill 3-4 inches from heat; cook for about 35
      minutes. 
4. Chop tomato and place on another piece of foil. Close foil and 
      place on grill the last 15 minutes of eggplant cooking time.
5. Remove vegetables from foil; blend together in large bowl. Season 
      to taste with salt and black pepper.

                                      - - - - - - - - - - - - - - - - - - 

NOTES : Serve with meat or poultry. Good vegetarian dish also.
_____

------------------------------------------------------------------------

-- MASTERCOOK MAC USERS ONLY: You may put the unformatted recipes into
either the "MXP" format (see example above and "APPENDIX A" for details)
or the "Mac" format (see example below and "APPENDIX B" for details).
The "Mac" format is generally an easier format to manipulate manually
because the fields are delimited by "tabs" and are not column dependent.

NOTE: In the following example, "<tab>" indicates where the actual tab 
character should be. 
 
------------------------------------------
EXAMPLE of a recipe in "Mac" format:

{    Exported from MasterCook Mac } 

Grilled Tossed Vegetables

Recipe By:                Jo Anne Merrill
Serving Size:          4
Preparation Time: 0:40



Categories:              Grill/Camping Recipes<tab>Vegetables<tab>Healthwise     

Amount      Measure    Ingredient                Preparation Method
6<tab>cups<tab>eggplant<tab>peeled and cubed
1<tab>green bell<tab>pepper<tab>chopped
1<tab>large onion<tab>chopped
1<tab>tablespoon<tab>margarine                  
1/4<tab>teaspoon basil        
2<tab>tomatoes 
<tab>salt<tab>to taste
<tab>pepper<tab>to taste

1. Peel and cube eggplant to make about 6 cups. Mix with the chopped 
      green pepper and chopped onion.
2. Cut 3 pieces of heavy-duty foil about 12 x 18 inches. Divide the
      eggplant mixture evenly on foil. Place 1 teaspoon margarine on 
      mixture; sprinkle with basil, or if preferred use chopped fresh 
      basil. Close foil tightly. 
3. Place foil packs on grill 3-4 inches from heat; cook for about 35 
      minutes.
4. Chop tomato and place on another piece of foil. Close foil and place
      on grill the last 15 minutes of eggplant cooking time.
5. Remove vegetables from foil; blend together in large bowl. Season to
      taste with salt and black pepper.
                  -----        
Serving Ideas:        Serve with meat or poultry. Good vegetarian dish also.

_____

------------------------------------------
TIP: You always have the option of entering, or keying, your unformatted
recipes directly into MasterCook. Without the use of one of a
"converters", readying your recipes for importing may, in some
case, be more laborious than simply keying them. 

Entering recipes manually is surprisingly fast and efficient. You need
key in only the ingredients (taking advantage of MasterCook's fast-fill
feature) and then "copy and paste" the directions section.

------------------------------------------
TIP: No time to key in the ingredients? For a "quick and dirty"



approach, you might try copying and pasting the entire unformatted
recipe into the directions section of a MC new recipe window. Name the
recipe and, optionally, assign categories. You won't be able to do a
nutritional analysis or search by ingredient on recipes saved this way,
but you will at least have an electronic search by recipe name. When you
have the time, you can return to these recipes and properly enter the
ingredients.

________________________________________________________________________

2.2.1    IMPORTING RECIPES: HANDLING UNFORMATTED TEXT FILES 
            FOR MASTERCOOK 3.0 and 4.0 USERS ONLY (WINDOWS and 
MACINTOSH)
________________________________________________________________________            

In addition to importing recipes that are in either the MXP or Mac
formats, discussed above, MasterCook 3.0 and 4.0 will also import
recipes in the "Generic Import Format". This format provides a very
simple method of preparing unformatted text recipes for import.

------------------------------------------------------------------------              

GENERIC IMPORT FORMAT

Following is the EXACT format that MasterCook expects when using the
"generic import" feature. You will find that it takes very little time
and effort to put most unformatted text recipes into this format.

NOTE: The descriptive comments appearing inside the bracket signs, 
"[ ]", are NOT a part of the format and appear here only for 
clarification.

1st line: @@@@@    [that's 5 "at" signs] 
2nd line: TITLE of the recipe 
3rd line: BLANK [this MUST be BLANK, not spaces!]

-- OR MC 4.0 ONLY --
3rd line: | [ (vertical bar) This eliminates the need for a BLANK line]

4th line: NOTES -- ONE line of text. [Optional]
5th line: BLANK [again, no spaces or non-display characters! Optional if



                                  no Notes line]

-- OR MC 4.0 ONLY --
5th line: | [ (vertical bar) This eliminates the need for a BLANK line]
 
6th line: amount unit ingredient preparation method
      .
      . [amount, unit, prep method are optional]
      .
Last INGREDIENT    [up to 100 ingredients] 
BLANK    [once again, no spaces!]

-- OR MC 4.0 ONLY --
5th line: | [ (vertical bar) This eliminates the need for a BLANK line]

DIRECTIONS and any "free form" text you wish to include. These lines are
optional.
Last line: _____ [end-or-recipe indicator, MC 4.0 ONLY]

NOTE: Everything until the "_____" (MC 4.0 ONLY) or the next "@@@@@"
will be put in the direction section. You can add the "recipe by",
"serving size", and "categories" once the recipes have been imported.

NOTE: The "Notes" line is REQUIRED for MC 3.0 Mac users. You may insert
any one or more text characters to fulfill this requirement, including a
"space".

TIP: Hate the tedium of deleting all those preceding spaces on each line
of your recipe? Well, there's no need to! With the exception of the
"@@@@@", the lines in the generic format do NOT have to be left
justified. Each text line may be preceded by non-printing characters,
such as spaces.

TIP: The easiest way to force the "preparation method" into the
"preparation method field" is to place either a comma or a semi-colon
after the ingredient. (Ex., 1 small onion, chopped --OR-- 1 small onion;
chopped)

TIP:    A BLANK line MUST truly be BLANK. (Or in the case of MC 4.0, the
control character "|" (vertical bar) may begin the line.) The import
will not work correctly if any non-displayable characters, such as



spaces, are contained in a "blank" line. If you are experiencing
difficulty importing a recipe, it may be helpful to view the recipe with
an editor (ex., WordPerfect, MS Word, Notepad, BBedit, etc.) that will
display non-printable characters. Only the end-of-line delimiters
(carriage returns,line feeds, etc) should be in a blank line.

TIP: If a recipe is not left justified in an e-mail message, what appears
to be blank lines are most likely lines with spaces. So, if the original
recipe is indented, be sure to delete and replace every blank line. Or,
if using MC 4.0, insert a "| (vertical bar) at the beginning of each
separator line.

TIP: Make sure that where a blank line is required, there is only ONE
blank line. If more than one blank is encountered, the importer may not
store the recipe properly.

TIP: MC 3.0 does not recognize an end-of-recipe delimiter, so EVERYTHING
following the first direction line until the next "@@@@@" is encountered
will be imported as directions. Therefore, you need to delete any
extraneous text (such as e-mail signatures) that you do not want stored
as part of your recipe. When using the generic format, MC will not strip
out trailing text that is not part of your recipe.

TIP: Recipes are posted on the Internet in a very wide variety of styles
and formats. Sometimes the ingredients are embedded within sentences and
it may be difficult to ready the recipe for importing. In these
instances, you may find it easier to manually enter the recipe using MC
fast-fill feature and doing a copy and paste of the directions.

------------------------------------------
EXAMPLE of a recipe in the "generic" format:

@@@@@
Grilled Tossed Vegetables

Serve with meat or poultry. Good vegetarian dish also.

6 cups eggplant,peeled and cubed
1 medium green bell pepper;chopped
1 large onion,chopped



1 tablespoon margarine    
1/4 teaspoon basil            
2 tomatoes            
salt        to taste
pepper    to taste

1. Peel and cube eggplant to make about 6 cups. Mix with the chopped 
      green pepper and chopped onion.
2. Cut 3 pieces of heavy-duty foil about 12 x 18 inches. Divide the 
      eggplant mixture evenly on foil. Place 1 teaspoon margarine on 
      mixture; sprinkle with basil, or if preferred use chopped fresh 
      basil. Close foil tightly.
3. Place foil packs on grill 3-4 inches from heat; cook for about 35 
      minutes.
4. Chop tomato and place on another piece of foil. Close foil and place
      on grill the last 15 minutes of eggplant cooking time.
5. Remove vegetables from foil; blend together in large bowl. Season to
      taste with salt and black pepper.

Recipe By: Jo Anne Merrill in from the MasterCook cookbook, "Kitchen 
Classics".
_____
------------------------------------------

If you prefer, instead of using the "generic format", you may put your
recipes into the "MXP" format. MC 3.0 and 4.0 removed the column and
position dependency of the MXP format, making it significantly more
flexible. It is now quite easy to create a keyword template for MXP and
simply insert the appropriate recipe sections. (See "APPENDIX A" for
details of this format.)

MC 3.0 WINDOWS USERS: There is a shareware "converter" available for the
MXP format:

                  Txt-to-MasterCook    (DOS only)
                  (Information available on the MasterCook Web Page 
                  (      http://www.sierra.com      )
                
Macintosh users also have the option of using the "Mac format". (See 
"APPENDIX B" for a description of this format.)



A text file may contain one or many recipes and they do not need to be
in the same format. For example, a mailing list digest may contain
recipes that were exported from MealMaster, others that were exported
from MasterCook, and even some that are in the generic format. As long
as each recipe is preceded with a recognizable header, MasterCook will
add the recipe to the import selection list. Only the unformatted
recipes will be overlooked.

________________________________________________________________________            

2.2.1    IMPORTING RECIPES: HANDLING UNFORMATTED TEXT FILES 
            FOR MASTERCOOK 3.0 and 4.0 USERS ONLY (WINDOWS and 
MACINTOSH)
________________________________________________________________________            

In addition to importing recipes that are in either the MXP or Mac
formats, discussed above, MasterCook 3.0 and 4.0 will also import
recipes in the "Generic Import Format". This format provides a very
simple method of preparing unformatted text recipes for import.

------------------------------------------------------------------------              

GENERIC IMPORT FORMAT

Following is the EXACT format that MasterCook expects when using the
"generic import" feature. You will find that it takes very little time
and effort to put most unformatted text recipes into this format.

NOTE: The descriptive comments appearing inside the bracket signs, 
"[ ]", are NOT a part of the format and appear here only for 
clarification.

1st line: @@@@@    [that's 5 "at" signs] 
2nd line: TITLE of the recipe 
3rd line: BLANK [this MUST be BLANK, not spaces!]

-- OR MC 4.0 ONLY --
3rd line: | [ (vertical bar) This eliminates the need for a BLANK line]

4th line: NOTES -- ONE line of text. [Optional]
5th line: BLANK [again, no spaces or non-display characters! Optional if



                                  no Notes line]

-- OR MC 4.0 ONLY --
5th line: | [ (vertical bar) This eliminates the need for a BLANK line]
 
6th line: amount unit ingredient preparation method
      .
      . [amount, unit, prep method are optional]
      .
Last INGREDIENT    [up to 100 ingredients] 
BLANK    [once again, no spaces!]

-- OR MC 4.0 ONLY --
5th line: | [ (vertical bar) This eliminates the need for a BLANK line]

DIRECTIONS and any "free form" text you wish to include. These lines are
optional.
Last line: _____ [end-or-recipe indicator, MC 4.0 ONLY]

NOTE: Everything until the "_____" (MC 4.0 ONLY) or the next "@@@@@"
will be put in the direction section. You can add the "recipe by",
"serving size", and "categories" once the recipes have been imported.

NOTE: The "Notes" line is REQUIRED for MC 3.0 Mac users. You may insert
any one or more text characters to fulfill this requirement, including a
"space".

TIP: Hate the tedium of deleting all those preceding spaces on each line
of your recipe? Well, there's no need to! With the exception of the
"@@@@@", the lines in the generic format do NOT have to be left
justified. Each text line may be preceded by non-printing characters,
such as spaces.

TIP: The easiest way to force the "preparation method" into the
"preparation method field" is to place either a comma or a semi-colon
after the ingredient. (Ex., 1 small onion, chopped --OR-- 1 small onion;
chopped)

TIP:    A BLANK line MUST truly be BLANK. (Or in the case of MC 4.0, the
control character "|" (vertical bar) may begin the line.) The import
will not work correctly if any non-displayable characters, such as



spaces, are contained in a "blank" line. If you are experiencing
difficulty importing a recipe, it may be helpful to view the recipe with
an editor (ex., WordPerfect, MS Word, Notepad, BBedit, etc.) that will
display non-printable characters. Only the end-of-line delimiters
(carriage returns,line feeds, etc) should be in a blank line.

TIP: If a recipe is not left justified in an e-mail message, what appears
to be blank lines are most likely lines with spaces. So, if the original
recipe is indented, be sure to delete and replace every blank line. Or,
if using MC 4.0, insert a "| (vertical bar) at the beginning of each
separator line.

TIP: Make sure that where a blank line is required, there is only ONE
blank line. If more than one blank is encountered, the importer may not
store the recipe properly.

TIP: MC 3.0 does not recognize an end-of-recipe delimiter, so EVERYTHING
following the first direction line until the next "@@@@@" is encountered
will be imported as directions. Therefore, you need to delete any
extraneous text (such as e-mail signatures) that you do not want stored
as part of your recipe. When using the generic format, MC will not strip
out trailing text that is not part of your recipe.

TIP: Recipes are posted on the Internet in a very wide variety of styles
and formats. Sometimes the ingredients are embedded within sentences and
it may be difficult to ready the recipe for importing. In these
instances, you may find it easier to manually enter the recipe using MC
fast-fill feature and doing a copy and paste of the directions.

------------------------------------------
EXAMPLE of a recipe in the "generic" format:

@@@@@
Grilled Tossed Vegetables

Serve with meat or poultry. Good vegetarian dish also.

6 cups eggplant,peeled and cubed
1 medium green bell pepper;chopped
1 large onion,chopped



1 tablespoon margarine    
1/4 teaspoon basil            
2 tomatoes            
salt        to taste
pepper    to taste

1. Peel and cube eggplant to make about 6 cups. Mix with the chopped 
      green pepper and chopped onion.
2. Cut 3 pieces of heavy-duty foil about 12 x 18 inches. Divide the 
      eggplant mixture evenly on foil. Place 1 teaspoon margarine on 
      mixture; sprinkle with basil, or if preferred use chopped fresh 
      basil. Close foil tightly.
3. Place foil packs on grill 3-4 inches from heat; cook for about 35 
      minutes.
4. Chop tomato and place on another piece of foil. Close foil and place
      on grill the last 15 minutes of eggplant cooking time.
5. Remove vegetables from foil; blend together in large bowl. Season to
      taste with salt and black pepper.

Recipe By: Jo Anne Merrill in from the MasterCook cookbook, "Kitchen 
Classics".
_____
------------------------------------------

If you prefer, instead of using the "generic format", you may put your
recipes into the "MXP" format. MC 3.0 and 4.0 removed the column and
position dependency of the MXP format, making it significantly more
flexible. It is now quite easy to create a keyword template for MXP and
simply insert the appropriate recipe sections. (See "APPENDIX A" for
details of this format.)

MC 3.0 WINDOWS USERS: There is a shareware "converter" available for the
MXP format:

                  Txt-to-MasterCook    (DOS only)
                  (Information available on the MasterCook Web Page 
                  (      http://www.sierra.com      )
                
Macintosh users also have the option of using the "Mac format". (See 
"APPENDIX B" for a description of this format.)



A text file may contain one or many recipes and they do not need to be
in the same format. For example, a mailing list digest may contain
recipes that were exported from MealMaster, others that were exported
from MasterCook, and even some that are in the generic format. As long
as each recipe is preceded with a recognizable header, MasterCook will
add the recipe to the import selection list. Only the unformatted
recipes will be overlooked.
2.2.1    IMPORTING RECIPES: HANDLING UNFORMATTED TEXT FILES 
            FOR MASTERCOOK 3.0 and 4.0 USERS ONLY (WINDOWS and 
MACINTOSH)
________________________________________________________________________            

In addition to importing recipes that are in either the MXP or Mac
formats, discussed above, MasterCook 3.0 and 4.0 will also import
recipes in the "Generic Import Format". This format provides a very
simple method of preparing unformatted text recipes for import.

------------------------------------------------------------------------              

GENERIC IMPORT FORMAT

Following is the EXACT format that MasterCook expects when using the
"generic import" feature. You will find that it takes very little time
and effort to put most unformatted text recipes into this format.

NOTE: The descriptive comments appearing inside the bracket signs, 
"[ ]", are NOT a part of the format and appear here only for 
clarification.

1st line: @@@@@    [that's 5 "at" signs] 
2nd line: TITLE of the recipe 
3rd line: BLANK [this MUST be BLANK, not spaces!]

-- OR MC 4.0 ONLY --
3rd line: | [ (vertical bar) This eliminates the need for a BLANK line]

4th line: NOTES -- ONE line of text. [Optional]
5th line: BLANK [again, no spaces or non-display characters! Optional if
                                  no Notes line]

-- OR MC 4.0 ONLY --



5th line: | [ (vertical bar) This eliminates the need for a BLANK line]
 
6th line: amount unit ingredient preparation method
      .
      . [amount, unit, prep method are optional]
      .
Last INGREDIENT    [up to 100 ingredients] 
BLANK    [once again, no spaces!]

-- OR MC 4.0 ONLY --
5th line: | [ (vertical bar) This eliminates the need for a BLANK line]

DIRECTIONS and any "free form" text you wish to include. These lines are
optional.
Last line: _____ [end-or-recipe indicator, MC 4.0 ONLY]

NOTE: Everything until the "_____" (MC 4.0 ONLY) or the next "@@@@@"
will be put in the direction section. You can add the "recipe by",
"serving size", and "categories" once the recipes have been imported.

NOTE: The "Notes" line is REQUIRED for MC 3.0 Mac users. You may insert
any one or more text characters to fulfill this requirement, including a
"space".

TIP: Hate the tedium of deleting all those preceding spaces on each line
of your recipe? Well, there's no need to! With the exception of the
"@@@@@", the lines in the generic format do NOT have to be left
justified. Each text line may be preceded by non-printing characters,
such as spaces.

TIP: The easiest way to force the "preparation method" into the
"preparation method field" is to place either a comma or a semi-colon
after the ingredient. (Ex., 1 small onion, chopped --OR-- 1 small onion;
chopped)

TIP:    A BLANK line MUST truly be BLANK. (Or in the case of MC 4.0, the
control character "|" (vertical bar) may begin the line.) The import
will not work correctly if any non-displayable characters, such as
spaces, are contained in a "blank" line. If you are experiencing
difficulty importing a recipe, it may be helpful to view the recipe with
an editor (ex., WordPerfect, MS Word, Notepad, BBedit, etc.) that will



display non-printable characters. Only the end-of-line delimiters
(carriage returns,line feeds, etc) should be in a blank line.

TIP: If a recipe is not left justified in an e-mail message, what appears
to be blank lines are most likely lines with spaces. So, if the original
recipe is indented, be sure to delete and replace every blank line. Or,
if using MC 4.0, insert a "| (vertical bar) at the beginning of each
separator line.

TIP: Make sure that where a blank line is required, there is only ONE
blank line. If more than one blank is encountered, the importer may not
store the recipe properly.

TIP: MC 3.0 does not recognize an end-of-recipe delimiter, so EVERYTHING
following the first direction line until the next "@@@@@" is encountered
will be imported as directions. Therefore, you need to delete any
extraneous text (such as e-mail signatures) that you do not want stored
as part of your recipe. When using the generic format, MC will not strip
out trailing text that is not part of your recipe.

TIP: Recipes are posted on the Internet in a very wide variety of styles
and formats. Sometimes the ingredients are embedded within sentences and
it may be difficult to ready the recipe for importing. In these
instances, you may find it easier to manually enter the recipe using MC
fast-fill feature and doing a copy and paste of the directions.

------------------------------------------
EXAMPLE of a recipe in the "generic" format:

@@@@@
Grilled Tossed Vegetables

Serve with meat or poultry. Good vegetarian dish also.

6 cups eggplant,peeled and cubed
1 medium green bell pepper;chopped
1 large onion,chopped
1 tablespoon margarine    
1/4 teaspoon basil            
2 tomatoes            



salt        to taste
pepper    to taste

1. Peel and cube eggplant to make about 6 cups. Mix with the chopped 
      green pepper and chopped onion.
2. Cut 3 pieces of heavy-duty foil about 12 x 18 inches. Divide the 
      eggplant mixture evenly on foil. Place 1 teaspoon margarine on 
      mixture; sprinkle with basil, or if preferred use chopped fresh 
      basil. Close foil tightly.
3. Place foil packs on grill 3-4 inches from heat; cook for about 35 
      minutes.
4. Chop tomato and place on another piece of foil. Close foil and place
      on grill the last 15 minutes of eggplant cooking time.
5. Remove vegetables from foil; blend together in large bowl. Season to
      taste with salt and black pepper.

Recipe By: Jo Anne Merrill in from the MasterCook cookbook, "Kitchen 
Classics".
_____
------------------------------------------

If you prefer, instead of using the "generic format", you may put your
recipes into the "MXP" format. MC 3.0 and 4.0 removed the column and
position dependency of the MXP format, making it significantly more
flexible. It is now quite easy to create a keyword template for MXP and
simply insert the appropriate recipe sections. (See "APPENDIX A" for
details of this format.)

MC 3.0 WINDOWS USERS: There is a shareware "converter" available for the
MXP format:

                  Txt-to-MasterCook    (DOS only)
                  (Information available on the MasterCook Web Page 
                  (      http://www.sierra.com      )
                
Macintosh users also have the option of using the "Mac format". (See 
"APPENDIX B" for a description of this format.)

A text file may contain one or many recipes and they do not need to be
in the same format. For example, a mailing list digest may contain
recipes that were exported from MealMaster, others that were exported



from MasterCook, and even some that are in the generic format. As long
as each recipe is preceded with a recognizable header, MasterCook will
add the recipe to the import selection list. Only the unformatted
recipes will be overlooked.

________________________________________________________________________

2.4    IMPORTING RECIPES: IMPORTING RECIPES from e-mail
________________________________________________________________________

The majority of recipes you will receive will be embedded in e-mail
messages. An e-mail message may contain one or many recipes and you 
may
import any or all of these recipes. Of course, each recipe must be in an
import format that MasterCook recognizes (see "2.2    Importing
Recipes: MasterCook Import Formats"). If it is not, then you
will need to edit the recipe and put it in an acceptable format prior to
importing.

When recipes are embedded in an e-mail message and surrounded by other
text (which is common in e-mail messages and mailing list digests), there
is often no need to first edit the file to strip out the extraneous
text. The MasterCook importer will begin importing from the
"beginning-of-recipe" header and will stop when it comes to the
beginning of the next recipe, the end-of-file indicator, or to an
end-of-recipe delimiter. Any other text, such as e-mail headers,
signature lines, or even comments that are not a part of the recipe will
not be imported.

EXCEPTIONS: MC 3.0, MC II, and MC Mac users:

In the following circumstances, you will need to delete all extraneous
text that follows a recipe (ie, e-mail signatures) prior to importing. If
you do not, then the trailing text will be imported as part of your
recipe.

-- When a recipe is in the "Generic" format.

-- When a recipe in the standard "MXP" format contains a "Notes"
section.



-- When a recipe in the standard "MXP" format contains a "Serving Ideas"
section.

-- When a recipe in the standard "MXP" format contains a "Suggested
Wine" section.

NOTE: There are occasions when an e-mail message will contain extraneous
characters within the body of the recipe. For example, if the recipe was
"forwarded" or "replied to", it will probably contain ">" symbols at the
beginning of each line. In cases such as this, the recipe will NOT
import as is. You must first edit the recipe to remove all unwanted
characters.

TIP: If there are changes that you would like to make to the recipe
itself (such as changing categories), it is typically easier to make the
changes from within MasterCook, AFTER the recipe is imported. Likewise,
if unwanted text was imported as part of the recipe (ie, e-mail
signatures), it can be easily removed by editing the recipe within MC.

------------------------------------------------------------------------

There are two ways that recipes may be imported from e-mail messages.
Depending on your particular e-mail program, you may be able to use 
one or both methods.

------------------------------------------
1) SAVE THE e-mail message containing the recipes you wish to import as 
a text file. Then you follow the normal MasterCook importing procedures,
pointing the MC importer to the saved text file.

TIP: When you save an e-mail message as a text file, make sure that you
do NOT select options such as "Guess Paragraphs" or "Wrap". These
options may alter the format of the recipe, preventing successful
importing.

It does not matter if the e-mail header information is stored with the
recipe; MasterCook will strip that when it imports.

TIP: Many e-mail programs will allow you to save multiple e-mail messages
in one text file. The advantage in doing this is that you can import
many recipes by invoking the import operation only once. Be careful,



however, if you are not a MC 3.0 and 4.0 user that every recipe in one
file is in the same format (ex., they all are from MM or all in MC MXP
format).

TIP: Many e-mail programs will separate a large e-mail message into
multiple parts, typically appended with a numeric suffix. This may very
happen when someone posts many recipes in one e-mail message. When 
you 
do the "Save", make sure that you save all parts of the message in the
same file.

TIP: Often users will preface the formatted recipe with interesting
comments that you might like to save with your recipe. In this case, you
should edit the e-mail message and copy and paste the extra comments into
the recipe. In order to prevent altering the recipe format (if you do
change it, it may not import), the safest place to insert these
additional comments is either at the beginning or the end of the
"directions" section.

------------------------------------------
2) IMPORT DIRECTLY from an e-mail mailbox. Some e-mail programs (such as
Eudora) maintain the mailboxes as text files that can be opened and
viewed as normal text files from other programs. If this is the case
with your e-mail program, then you may simply point the MasterCook



************************************************************************
*                                                                                                                                            *
*                                                                                                                                            *
*                                        EXCHANGING MASTERCOOK RECIPES                                          
*
*                                                                                                                                            *
*            A GUIDE TO IMPORTING AND EXPORTING RECIPES WITH MASTERCOOK 
* 
*                                                                                                                                            *                 
*                                                      Version 2.0                                                                *
*                                                                                                                                            * 
*                                          (Includes MasterCook 4.0)                                                *             
*
************************************************************************

This guide describes, in detail, how to import and export MasterCook
recipes so that you may easily share them with others. And because
recipe exchanges occur frequently via the Internet, this guide also
includes information on exchanging recipes electronically.

If you encounter problems importing, locate the symptom in "Part 4: What
Went Wrong?" and you will find the associated cause and suggested
solutions.

The following MasterCook versions are covered in this document:

 MasterCook 4.0 (including a special section on what's new)
 MasterCook 3.0
 MasterCook II 
 MasterCook Mac
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0.1    WHAT'S NEW IN MASTERCOOK 4.0

************************************************************************

Many significant new features were added to make importing recipes into
MasterCook 4.0 easier and more accurate than ever! A summary of the most
exciting new features follows.

*** End-of-Recipe Delimiter: "_____"    (5 underscores) ***

Now there is a definitive way to tell the Recipe Translator where the



end of the recipe text is! Simply insert "_____" (5 underscores) at the
beginning of the line immediately following the end of the recipe text.
When the Recipe Translator encounters this control string, it will cease
importing the current recipe and begin looking for the next
beginning-of-recipe header.

You now have precise control over where the recipe text ends, so you no
longer have to bother removing e-mail headers and trailers from your text
files prior to importing. No more surprise text in the "Notes" section!

*** Exclude Categories When Importing (optional) ***

Hate all those foreign categories that get added to your cookbook
everytime you import a recipe? Now you can simply turn off the import of
all categories by un-checking the "Include Categories" box in the Import
dialog window.

But you want to include categories, at least some of the time? No
problem! The include/exclude option can be set on each import.

*** End-of-Section Delimiter: "|" (vertical bar) ***

Have you had difficulty with those troublesome BLANK lines that are
required in the "Generic" import formats? Well, no need to fret anymore.
Instead of ensuring those required lines are truly BLANK, simply insert
a "|" (vertical bar) at the beginning of each separator line. This
indicates to the Recipe Translator that it has encountered the end of
that recipe section.

You can, of course, continue to use BLANK lines as end-of-section
indicators. Just beware that if the line contains even one "space", the
recipe will not import correctly. When you use the "|" control
character, you need not worry if the line is blank.

*** Paste Text As Ingredients ***

Now you can copy text from any file (such as an e-mail message) and paste
it into the ingredient section of a MasterCook recipe! Simply copy the



text and then select the "Paste As Ingredient" option under the Edit
Menu. The copied text will be translated and placed in the appropriate
amount, unit, ingredient, and preparation method fields, just as they
are when you "import" a formatted text recipe.

You don't want to format a text recipe and then import it? Then try
adding it to your cookbook by using copy and paste. First copy and then
paste the ingredients using "Paste Text as Ingredients". Then copy and
paste the title, author, and/or the directions.

This function is also very useful for those occasions when the
ingredients erroneously imported into the directions section. Now,
clean-up is easy. Just copy (or cut) the ingredients and then "Paste
Text As Ingredients".

*** Ingredient Lines With All Spaces (or Tabs) Will be Preserved ***

You may now use lines with only spaces or tabs in the Ingredient
section to separate groups of ingredients!

In past releases, if you did not include at least one displayable
character in an ingredient line, the line was stripped when the recipe
was imported. In Version 4, these lines (which appear to be "blank")
will be kept in the ingredient section.

(Note that this applies only recipes imported in the MXP format.
Ingredient lines with all spaces or tabs in the "generic" format will be
stripped when imported.)

***    "Notes" Line No Longer Required in Generic Import Format    ***

In MasterCook Version 3, Mac users were required to have the one line of
"Notes" in the generic import format. This has been changed, so if you
don't want to use the "Notes" section of the recipe, you no longer have
to! The generic format may now include just the title, ingredients, and
directions, and, of course, the required format controls. (See APPENDIX
C: GENERIC FORMAT for details.)

*** Improvements in Importing MealMaster Recipes ***



MealMaster recipes that contain two-columns of ingredients and dividers
can now be successfully imported into MasterCook!

In addition, recipes with MealMaster dividers are now imported with a
divider that looks good in MasterCook.

Example of a part of a MealMaster, 2-column recipe with dividers:

---------------------------------ICE CREAM------------------------------
            1 qt Vanilla ice cream                                      1 c    Heath bars; chopped

-------------------------------CARAMEL SAUCE----------------------------
    1 1/3 c    Whipping cream                                            2 tb Unsalted butter; cut into
            1 c    Sugar                                                                        - 4 pieces
            3 tb Water

************************************************************************

PART ONE: BASICS OF FILE TRANSFER ON THE INTERNET

************************************************************************

If you are planning on exchanging recipes via the Internet, it is
important that you understand the basics of electronic file transfer.
This will be helpful to you in getting started, and this understanding
will be particularly valuable when "things go wrong".

Details on how to exchange MasterCook recipes via the Internet will be
covered in "Part Two: Importing Recipes" and in "Part Three: Exporting
Recipes".If you are an experienced user of e-mail and file transfers on
the Internet, you may wish to skip to the MasterCook specific 
discussions.

________________________________________________________________________ 

1.1    BASICS OF FILE TRANSFER ON THE INTERNET:    TYPES OF FILES
________________________________________________________________________



There are two types of data files that you will encounter on the
Internet: "TEXT" and "RAW DATA" (also called "BINARY") files.

-- TEXT files are "readable" by you; that is, they are in a language
that people    understand (i.e., English, Spanish, German, etc.). You can
open them, view them, and edit them via any number of text editors (ie,
Notepad, Simple Text, etc.) or word processing programs (ie, MicroSoft
Word or Word Perfect). e-mail messages are always "text" files. Likewise,
recipes that are "EXPORTED" from cooking programs are also text files.

However, not all text files are alike. Different computer operating
systems expect different controls signalling the "end of line" (EOL) in
text files. Thus, you will encounter three different "end of line"
indicators:

                DOS systems:                    Carriage Return AND Line Feed
                Macintosh systems:        Carriage Return 
                Unix systems:                  Line Feed
                
If a text file contains the incorrect "end of line" indicator for your
system, you most likely will not be able to view the file correctly with
a text editor; it will appear "garbled". You will typically see the text
lines all run together, and/or a foreign character (such as a black
rectangle or blank square) at the logical end or beginning of each line.

TIP: Incorrect EOL delimiters are not typically a problem in e-mail
because your e-mail program will do whatever translation is necessary for
your system. However, if you receive text files outside of e-mail (ie,
downloaded or attached documents), they may contain the incorrect
control characters and you will need to convert them.

TIP: Incorrect EOL delimiters are not typically a problem for MasterCook
3.0 and 4.0 users, because, in most cases, the Recipe Translator can
import the recipes correctly even if they contain invalid EOL delimiters
for your system. (For more on this subject, see "APPENDIX D: SUPPORTED
FORMATS AND TEXT TYPES".

------------------------------------------

-- RAW DATA files look like "garbage" if you attempt to view them via a



text editor. They are often executable files (such as applications or
execs), or they are in a format very specific to a program and can only
be viewed via that program. An example of a "raw data" file is a
complete MasterCook cookbook. You can exchange complete cookbooks with
others; you need only open the cookbook from within MasterCook.

NOTE: MasterCook cookbooks are completely compatible across all versions
of MasterCook and all platforms. This means that all MC Windows and Mac
users, regardless of their MC version, can exchange complete cookbooks,
with absolutely no conversion required!

TIP: Both text and raw data files may be "compressed" to reduce their
size before being transferred on the Internet.    A compressed or "zipped"
file must be expanded or "unzipped" before it can be processed. There
are many different commonly used compression/expansion schemes and
utility programs (such as "PKZIP" and "StuffIt Expander").

Sometimes a compressed file is "self-extracting" meaning that it
contains the information necessary to be expanded without your having
the expansion software. If a compressed file is NOT self-extracting,
then you must have a software program that can read and expand the file.

TIP: Recipes in MasterCook cookbooks will be automatically stored in a
compressed format if you select that option under "Preferences" (under
the "Tools" menu option). This option will significantly reduce the
amount of disk space required by your cookbooks. Because of the
incompatibility among file compression programs, you may avoid many file
exchange problems if you do not further compress a cookbook prior to
sending it electronically.

________________________________________________________________________

1.2    BASICS OF FILE TRANSFER ON THE INTERNET:    TRANSFERRING FILES
________________________________________________________________________

You can send and receive files on the Internet via three basic ways:

1) e-mail

e-mail messages are always "text" files and are sent and received using
an e-mail program such as Eudora, Microsoft Exchange, etc.



When you receive a file, your e-mail program will perform whatever
"translation" is required for you to be able to read the text. (For
example, if the text originated on a DOS system and was received on a
Macintosh system, the "line feeds" are stripped.) This is why you can
read messages sent from systems different than yours.

The primary and simplest method for exchanging recipes via the Internet
is through e-mail. Typically, recipes you send and receive will be
embedded in the body of an e-mail message. By using e-mail, you will
ensure that in most cases your recipes can be read and vice versa. There
will often be commentary and a signature surrounding the actual recipe,
but that will not impact MC's ability to import. (For details on how to
"process" these recipes, see "Importing Recipes From e-mail" later in
this document.)

2) "ATTACHED FILES" (to e-mail messages)

Occasionally someone will "attach" a file to an e-mail message. These
files may be either text or raw data files. Some e-mail programs (ie,
Eudora) support sending and receiving "attachments". If your e-mail
program does support attached files, you tell it where you would like
attached files to be stored. When an attached file is received, you will
see a message in your "In" box informing you of receipt and file name.

Sending attached files is a very convenient method of transferring large
text files or raw data files directly to other users. Note that attached
files are not an "e-mail" message, thus, they are not subject to the same
e-mail message size limitations. (There may be a file size limitation
imposed by your service provider, but it will be significantly larger
than an e-mail size limit.) Raw data files sent as attachments will not
translated to text.

It is not recommended that you send recipes as "attachments" to mailing
lists or newsgroups, because many e-mail programs do not recognize and
support attached documents. (Indeed, sending attached files to news
groups and mailing lists is considered to be a "breech" of Internet
etiquette.) Furthermore, there is no one standard on how attachments are
handled. Before sending an attached document, you should confirm that
the recipient can handle it.



3) UPLOADING/DOWNLOADING

When you request a copy of a file be electronically sent from a site on
the Internet to your computer, you are "downloading". These files may be
either text or raw data files and there is a variety of software
programs that enable this transmission. (Examples of these programs are:
Netscape, Fetch, Gopher, Mosaic, or your Internet service provider may
provide their own.)

If you send a file from your system to be stored on another system, that
is called "uploading". Once a file is "uploaded", it may be available
for others to "download".

You will typically be downloading either files containing recipes (text
files) or complete MasterCook cookbooks (raw data files) from the
Internet.

************************************************************************

PART TWO:    IMPORTING RECIPES

************************************************************************

________________________________________________________________________

2.1    IMPORTING RECIPES: ADDING RECIPES TO MASTERCOOK
________________________________________________________________________

There are three ways in which you can increase your MasterCook recipe
collection.

--> 1) TYPE, or manually "enter" by keying, recipes into a MasterCook
"New Recipe" window

This method is typically used for recipes that are not currently
available in electronic form. (I.E., they exist only on paper in
cookbooks, magazines, newspapers, old recipe cards, etc.)

MasterCook's "fast fill" feature significantly minimizes the number of
key strokes required to enter a recipe's ingredients. (For more



information, see "Recipes, entering" in your MasterCook User's Guide.)

--> 2) IMPORT recipes from "TEXT" files that are in a supported format

Recipes in electronic format as "text" files are typically those that
you received in e-mail messages, scanned in from magazines or newspapers,
downloaded from the Internet, or are entered into another cooking
program.

A recipe MUST be in a FORMAT that MasterCook recognizes before it can be
"imported" (electronically added) to a MasterCook cookbook. (See
"MasterCook Import Formats" in this document for descriptions of
acceptable formats.) Text files that are not in a supported format can
NOT be imported.

This document focuses primarily on importing.

--> 3) ADD a complete MasterCook cookbook
 
You may add a complete cookbook to your collection simply by copying the
cookbook to your system and opening it with MasterCook. Typically you
will receive or download an entire cookbook from the Internet (for
example, from the MasterCook Web page at      http://www.sierra.com    ).

These files are not text files, but rather are in "raw data" or "binary"
format. A complete cookbook does not contain "exported" recipes, and,
therefore, does not need to be "imported". To view the recipes, the
cookbook must be opened from within MasterCook.

_______________________________________________________________________

2.2    IMPORTING RECIPES: MASTERCOOK IMPORT FORMATS
________________________________________________________________________

A recipe MUST be in a format that MasterCook recognizes before it can be
imported into a MC cookbook. The MC "Recipe Translator" (or "importer")
is very flexible and supports many different formats, including export
formats from many popular commercial and shareware cooking programs.
However, if a recipe is not in one of the accepted formats which contain
specific delimiters that MC recognizes, it can not be imported.



MasterCook will successfully import, or convert, text files containing
recipes that were exported from the following programs:

MasterCook programs:

                MasterCook 4.0 ("MXP", "Mac", or "Generic" formats)
                MasterCook 3.0 ("MXP", "Mac", or "Generic" formats)
                MasterCook II    ("MXP" format)
                MasterCook Mac ("MXP" or "Mac" formats)

Other cooking programs:

                Cookbook USA
                Cooking Companion 1.x
                Cooking Light Cookware 1.x (Windows & Mac)
                From Scratch 3.x
                Key Home Gourmet
                Meal-Master 7.x and 8.x
                    (Note: MC 4.0 supports MM    2-column recipes with dividers)
                Micro Cookbook 1.x (Mac)
                Micro Cookbook 3.x (Windows or DOS)
                Micro Cookbook 4.x and 5.x
                MicroKitchen Companion 2.x and 3.x

If a recipe was exported from any of the above formats, in most cases,
you will not need to edit it prior to importing. It is ready to be
imported into a MC cookbook as is. However, if the recipes are not in an
acceptable format, they must be edited prior to importing. MasterCook
can NOT import unformatted recipes.

TIP: To determine if recipes in your text file are formatted, look for
"Beginning-of-Recipe" headers such as the following. If none exist, then
the recipes are not acceptable for importing.

                                            *    Exported from    MasterCook    *

                                                        ------OR------

MMMMM----- Recipe via Meal-Master (tm) v8.02



                                                      ------OR------

@@@@@

TIP: If a file appears to be in an acceptable format,    try importing it
and see if MC recognizes any or all of the recipes. The recipes that can
be imported will be presented to you in the "import selection" window.
Recipes that are not included in this list are not in a format that MC
recognizes and need to be edited before they can be imported.

 
TIP: Many formats include an End-of-Recipe delimiter, such as "MMMMM" or
"_____". Any text outside of the recipe "beginning-of-recipe header" or
"end-of-recipe trailer" will NOT be imported. This means that there is
no need for you to expend the effort to delete comments, e-mail headers,
or e-mail signature lines. MC will take care of that for you.

________________________________________________________________________

2.2.0 IMPORTING RECIPES: HANDLING UNFORMATTED TEXT FILES
                    FOR MASTERCOOK MAC and MASTERCOOK II USERS
________________________________________________________________________

To successfully import recipes with MC Mac or MC II, text recipes MUST
be in the MasterCook "MXP" or "Mac" import formats, or in a format from
one of the programs listed above. If the recipes are unformatted (for
example, they were not exported from one of the above programs), they
must be edited to agree with one of these formats before they will
successfully import.

A text file may contain one or many recipes; however, all recipes must
be in the same format to import. If there is more than one format within
the file, the Recipe Translator will recognize recipes in ONLY ONE
format. Likewise, if the file contains unformatted recipes, they will
not be recognized for importing.

If you have recipes in several different formats (such as in a mailing
list digest), you should create a file for each format (i.e., all
recipes exported from MM in one file, all recipes exported from MC in
another file).



NOTE: This does NOT apply to MasterCook 3.0 or 4.0. In MC 3.0 and 4.0,
all recipes in a valid format will be imported, regardless of the 
mixture or order of the formats within one file.
------------------------------------------------------------------------

-- MASTERCOOK II (WINDOWS) USERS ONLY: You must put your unformatted
recipes into the "MXP" format (See the Appendix A for details of this
format). You may, of course, make these format changes manually with any
text editor of your choice. However, the following shareware program is
available to assist you in readying your unformatted recipes for import:

                  Txt-to-MasterCook 
(Information available on the MasterCook Web Page:
 http://www.sierra.com )
                

------------------------------------------
EXAMPLE of a recipe in "MXP" format:

                                            *    Exported from    MasterCook    *
                                                                        
                                                Grilled Tossed Vegetables

Recipe By          : Jo Anne Merrill
Serving Size    : 4        Preparation Time :0:40
Categories        : Grill/Camping Recipes                        Vegetables
                                Healthwise

    Amount    Measure              Ingredient -- Preparation Method
--------    ------------    --------------------------------
      6            cups                    eggplant -- peeled and cubed
      1            medium                green bell pepper -- chopped
      1            large                  onion -- chopped
      1            tablespoon        margarine
          1/4    teaspoon            basil
      2                                        tomatoes
                                                salt -- to taste
                                                pepper -- to taste



1. Peel and cube eggplant to make about 6 cups. Mix with the chopped 
      green pepper and chopped onion.
2. Cut 3 pieces of heavy-duty foil about 12 x 18 inches. Divide the
      eggplant mixture evenly on foil. Place 1 teaspoon margarine on 
      mixture; sprinkle with basil, or if preferred use chopped fresh 
      basil. Close foil tightly. 
3. Place foil packs on grill 3-4 inches from heat; cook for about 35
      minutes. 
4. Chop tomato and place on another piece of foil. Close foil and 
      place on grill the last 15 minutes of eggplant cooking time.
5. Remove vegetables from foil; blend together in large bowl. Season 
      to taste with salt and black pepper.

                                      - - - - - - - - - - - - - - - - - - 

NOTES : Serve with meat or poultry. Good vegetarian dish also.
_____

------------------------------------------------------------------------

-- MASTERCOOK MAC USERS ONLY: You may put the unformatted recipes into
either the "MXP" format (see example above and "APPENDIX A" for details)
or the "Mac" format (see example below and "APPENDIX B" for details).
The "Mac" format is generally an easier format to manipulate manually
because the fields are delimited by "tabs" and are not column dependent.

NOTE: In the following example, "<tab>" indicates where the actual tab 
character should be. 
 
------------------------------------------
EXAMPLE of a recipe in "Mac" format:

{    Exported from MasterCook Mac } 

Grilled Tossed Vegetables

Recipe By:                Jo Anne Merrill
Serving Size:          4
Preparation Time: 0:40



Categories:              Grill/Camping Recipes<tab>Vegetables<tab>Healthwise     

Amount      Measure    Ingredient                Preparation Method
6<tab>cups<tab>eggplant<tab>peeled and cubed
1<tab>green bell<tab>pepper<tab>chopped
1<tab>large onion<tab>chopped
1<tab>tablespoon<tab>margarine                  
1/4<tab>teaspoon basil        
2<tab>tomatoes 
<tab>salt<tab>to taste
<tab>pepper<tab>to taste

1. Peel and cube eggplant to make about 6 cups. Mix with the chopped 
      green pepper and chopped onion.
2. Cut 3 pieces of heavy-duty foil about 12 x 18 inches. Divide the
      eggplant mixture evenly on foil. Place 1 teaspoon margarine on 
      mixture; sprinkle with basil, or if preferred use chopped fresh 
      basil. Close foil tightly. 
3. Place foil packs on grill 3-4 inches from heat; cook for about 35 
      minutes.
4. Chop tomato and place on another piece of foil. Close foil and place
      on grill the last 15 minutes of eggplant cooking time.
5. Remove vegetables from foil; blend together in large bowl. Season to
      taste with salt and black pepper.
                  -----        
Serving Ideas:        Serve with meat or poultry. Good vegetarian dish also.

_____

------------------------------------------
TIP: You always have the option of entering, or keying, your unformatted
recipes directly into MasterCook. Without the use of one of a
"converters", readying your recipes for importing may, in some
case, be more laborious than simply keying them. 

Entering recipes manually is surprisingly fast and efficient. You need
key in only the ingredients (taking advantage of MasterCook's fast-fill
feature) and then "copy and paste" the directions section.

------------------------------------------
TIP: No time to key in the ingredients? For a "quick and dirty"



approach, you might try copying and pasting the entire unformatted
recipe into the directions section of a MC new recipe window. Name the
recipe and, optionally, assign categories. You won't be able to do a
nutritional analysis or search by ingredient on recipes saved this way,
but you will at least have an electronic search by recipe name. When you
have the time, you can return to these recipes and properly enter the
ingredients.

________________________________________________________________________

2.2.1    IMPORTING RECIPES: HANDLING UNFORMATTED TEXT FILES 
            FOR MASTERCOOK 3.0 and 4.0 USERS ONLY (WINDOWS and 
MACINTOSH)
________________________________________________________________________            

In addition to importing recipes that are in either the MXP or Mac
formats, discussed above, MasterCook 3.0 and 4.0 will also import
recipes in the "Generic Import Format". This format provides a very
simple method of preparing unformatted text recipes for import.

------------------------------------------------------------------------              

GENERIC IMPORT FORMAT

Following is the EXACT format that MasterCook expects when using the
"generic import" feature. You will find that it takes very little time
and effort to put most unformatted text recipes into this format.

NOTE: The descriptive comments appearing inside the bracket signs, 
"[ ]", are NOT a part of the format and appear here only for 
clarification.

1st line: @@@@@    [that's 5 "at" signs] 
2nd line: TITLE of the recipe 
3rd line: BLANK [this MUST be BLANK, not spaces!]

-- OR MC 4.0 ONLY --
3rd line: | [ (vertical bar) This eliminates the need for a BLANK line]

4th line: NOTES -- ONE line of text. [Optional]
5th line: BLANK [again, no spaces or non-display characters! Optional if



                                  no Notes line]

-- OR MC 4.0 ONLY --
5th line: | [ (vertical bar) This eliminates the need for a BLANK line]
 
6th line: amount unit ingredient preparation method
      .
      . [amount, unit, prep method are optional]
      .
Last INGREDIENT    [up to 100 ingredients] 
BLANK    [once again, no spaces!]

-- OR MC 4.0 ONLY --
5th line: | [ (vertical bar) This eliminates the need for a BLANK line]

DIRECTIONS and any "free form" text you wish to include. These lines are
optional.
Last line: _____ [end-or-recipe indicator, MC 4.0 ONLY]

NOTE: Everything until the "_____" (MC 4.0 ONLY) or the next "@@@@@"
will be put in the direction section. You can add the "recipe by",
"serving size", and "categories" once the recipes have been imported.

NOTE: The "Notes" line is REQUIRED for MC 3.0 Mac users. You may insert
any one or more text characters to fulfill this requirement, including a
"space".

TIP: Hate the tedium of deleting all those preceding spaces on each line
of your recipe? Well, there's no need to! With the exception of the
"@@@@@", the lines in the generic format do NOT have to be left
justified. Each text line may be preceded by non-printing characters,
such as spaces.

TIP: The easiest way to force the "preparation method" into the
"preparation method field" is to place either a comma or a semi-colon
after the ingredient. (Ex., 1 small onion, chopped --OR-- 1 small onion;
chopped)

TIP:    A BLANK line MUST truly be BLANK. (Or in the case of MC 4.0, the
control character "|" (vertical bar) may begin the line.) The import
will not work correctly if any non-displayable characters, such as



spaces, are contained in a "blank" line. If you are experiencing
difficulty importing a recipe, it may be helpful to view the recipe with
an editor (ex., WordPerfect, MS Word, Notepad, BBedit, etc.) that will
display non-printable characters. Only the end-of-line delimiters
(carriage returns,line feeds, etc) should be in a blank line.

TIP: If a recipe is not left justified in an e-mail message, what appears
to be blank lines are most likely lines with spaces. So, if the original
recipe is indented, be sure to delete and replace every blank line. Or,
if using MC 4.0, insert a "| (vertical bar) at the beginning of each
separator line.

TIP: Make sure that where a blank line is required, there is only ONE
blank line. If more than one blank is encountered, the importer may not
store the recipe properly.

TIP: MC 3.0 does not recognize an end-of-recipe delimiter, so EVERYTHING
following the first direction line until the next "@@@@@" is encountered
will be imported as directions. Therefore, you need to delete any
extraneous text (such as e-mail signatures) that you do not want stored
as part of your recipe. When using the generic format, MC will not strip
out trailing text that is not part of your recipe.

TIP: Recipes are posted on the Internet in a very wide variety of styles
and formats. Sometimes the ingredients are embedded within sentences and
it may be difficult to ready the recipe for importing. In these
instances, you may find it easier to manually enter the recipe using MC
fast-fill feature and doing a copy and paste of the directions.

------------------------------------------
EXAMPLE of a recipe in the "generic" format:

@@@@@
Grilled Tossed Vegetables

Serve with meat or poultry. Good vegetarian dish also.

6 cups eggplant,peeled and cubed
1 medium green bell pepper;chopped
1 large onion,chopped



1 tablespoon margarine    
1/4 teaspoon basil            
2 tomatoes            
salt        to taste
pepper    to taste

1. Peel and cube eggplant to make about 6 cups. Mix with the chopped 
      green pepper and chopped onion.
2. Cut 3 pieces of heavy-duty foil about 12 x 18 inches. Divide the 
      eggplant mixture evenly on foil. Place 1 teaspoon margarine on 
      mixture; sprinkle with basil, or if preferred use chopped fresh 
      basil. Close foil tightly.
3. Place foil packs on grill 3-4 inches from heat; cook for about 35 
      minutes.
4. Chop tomato and place on another piece of foil. Close foil and place
      on grill the last 15 minutes of eggplant cooking time.
5. Remove vegetables from foil; blend together in large bowl. Season to
      taste with salt and black pepper.

Recipe By: Jo Anne Merrill in from the MasterCook cookbook, "Kitchen 
Classics".
_____
------------------------------------------

If you prefer, instead of using the "generic format", you may put your
recipes into the "MXP" format. MC 3.0 and 4.0 removed the column and
position dependency of the MXP format, making it significantly more
flexible. It is now quite easy to create a keyword template for MXP and
simply insert the appropriate recipe sections. (See "APPENDIX A" for
details of this format.)

MC 3.0 WINDOWS USERS: There is a shareware "converter" available for the
MXP format:

                  Txt-to-MasterCook    (DOS only)
                  (Information available on the MasterCook Web Page 
                  (      http://www.sierra.com      )
                
Macintosh users also have the option of using the "Mac format". (See 
"APPENDIX B" for a description of this format.)



A text file may contain one or many recipes and they do not need to be
in the same format. For example, a mailing list digest may contain
recipes that were exported from MealMaster, others that were exported
from MasterCook, and even some that are in the generic format. As long
as each recipe is preceded with a recognizable header, MasterCook will
add the recipe to the import selection list. Only the unformatted
recipes will be overlooked.

________________________________________________________________________            

2.2.1    IMPORTING RECIPES: HANDLING UNFORMATTED TEXT FILES 
            FOR MASTERCOOK 3.0 and 4.0 USERS ONLY (WINDOWS and 
MACINTOSH)
________________________________________________________________________            

In addition to importing recipes that are in either the MXP or Mac
formats, discussed above, MasterCook 3.0 and 4.0 will also import
recipes in the "Generic Import Format". This format provides a very
simple method of preparing unformatted text recipes for import.

------------------------------------------------------------------------              

GENERIC IMPORT FORMAT

Following is the EXACT format that MasterCook expects when using the
"generic import" feature. You will find that it takes very little time
and effort to put most unformatted text recipes into this format.

NOTE: The descriptive comments appearing inside the bracket signs, 
"[ ]", are NOT a part of the format and appear here only for 
clarification.

1st line: @@@@@    [that's 5 "at" signs] 
2nd line: TITLE of the recipe 
3rd line: BLANK [this MUST be BLANK, not spaces!]

-- OR MC 4.0 ONLY --
3rd line: | [ (vertical bar) This eliminates the need for a BLANK line]

4th line: NOTES -- ONE line of text. [Optional]
5th line: BLANK [again, no spaces or non-display characters! Optional if



                                  no Notes line]

-- OR MC 4.0 ONLY --
5th line: | [ (vertical bar) This eliminates the need for a BLANK line]
 
6th line: amount unit ingredient preparation method
      .
      . [amount, unit, prep method are optional]
      .
Last INGREDIENT    [up to 100 ingredients] 
BLANK    [once again, no spaces!]

-- OR MC 4.0 ONLY --
5th line: | [ (vertical bar) This eliminates the need for a BLANK line]

DIRECTIONS and any "free form" text you wish to include. These lines are
optional.
Last line: _____ [end-or-recipe indicator, MC 4.0 ONLY]

NOTE: Everything until the "_____" (MC 4.0 ONLY) or the next "@@@@@"
will be put in the direction section. You can add the "recipe by",
"serving size", and "categories" once the recipes have been imported.

NOTE: The "Notes" line is REQUIRED for MC 3.0 Mac users. You may insert
any one or more text characters to fulfill this requirement, including a
"space".

TIP: Hate the tedium of deleting all those preceding spaces on each line
of your recipe? Well, there's no need to! With the exception of the
"@@@@@", the lines in the generic format do NOT have to be left
justified. Each text line may be preceded by non-printing characters,
such as spaces.

TIP: The easiest way to force the "preparation method" into the
"preparation method field" is to place either a comma or a semi-colon
after the ingredient. (Ex., 1 small onion, chopped --OR-- 1 small onion;
chopped)

TIP:    A BLANK line MUST truly be BLANK. (Or in the case of MC 4.0, the
control character "|" (vertical bar) may begin the line.) The import
will not work correctly if any non-displayable characters, such as



spaces, are contained in a "blank" line. If you are experiencing
difficulty importing a recipe, it may be helpful to view the recipe with
an editor (ex., WordPerfect, MS Word, Notepad, BBedit, etc.) that will
display non-printable characters. Only the end-of-line delimiters
(carriage returns,line feeds, etc) should be in a blank line.

TIP: If a recipe is not left justified in an e-mail message, what appears
to be blank lines are most likely lines with spaces. So, if the original
recipe is indented, be sure to delete and replace every blank line. Or,
if using MC 4.0, insert a "| (vertical bar) at the beginning of each
separator line.

TIP: Make sure that where a blank line is required, there is only ONE
blank line. If more than one blank is encountered, the importer may not
store the recipe properly.

TIP: MC 3.0 does not recognize an end-of-recipe delimiter, so EVERYTHING
following the first direction line until the next "@@@@@" is encountered
will be imported as directions. Therefore, you need to delete any
extraneous text (such as e-mail signatures) that you do not want stored
as part of your recipe. When using the generic format, MC will not strip
out trailing text that is not part of your recipe.

TIP: Recipes are posted on the Internet in a very wide variety of styles
and formats. Sometimes the ingredients are embedded within sentences and
it may be difficult to ready the recipe for importing. In these
instances, you may find it easier to manually enter the recipe using MC
fast-fill feature and doing a copy and paste of the directions.

------------------------------------------
EXAMPLE of a recipe in the "generic" format:

@@@@@
Grilled Tossed Vegetables

Serve with meat or poultry. Good vegetarian dish also.

6 cups eggplant,peeled and cubed
1 medium green bell pepper;chopped
1 large onion,chopped



1 tablespoon margarine    
1/4 teaspoon basil            
2 tomatoes            
salt        to taste
pepper    to taste

1. Peel and cube eggplant to make about 6 cups. Mix with the chopped 
      green pepper and chopped onion.
2. Cut 3 pieces of heavy-duty foil about 12 x 18 inches. Divide the 
      eggplant mixture evenly on foil. Place 1 teaspoon margarine on 
      mixture; sprinkle with basil, or if preferred use chopped fresh 
      basil. Close foil tightly.
3. Place foil packs on grill 3-4 inches from heat; cook for about 35 
      minutes.
4. Chop tomato and place on another piece of foil. Close foil and place
      on grill the last 15 minutes of eggplant cooking time.
5. Remove vegetables from foil; blend together in large bowl. Season to
      taste with salt and black pepper.

Recipe By: Jo Anne Merrill in from the MasterCook cookbook, "Kitchen 
Classics".
_____
------------------------------------------

If you prefer, instead of using the "generic format", you may put your
recipes into the "MXP" format. MC 3.0 and 4.0 removed the column and
position dependency of the MXP format, making it significantly more
flexible. It is now quite easy to create a keyword template for MXP and
simply insert the appropriate recipe sections. (See "APPENDIX A" for
details of this format.)

MC 3.0 WINDOWS USERS: There is a shareware "converter" available for the
MXP format:

                  Txt-to-MasterCook    (DOS only)
                  (Information available on the MasterCook Web Page 
                  (      http://www.sierra.com      )
                
Macintosh users also have the option of using the "Mac format". (See 
"APPENDIX B" for a description of this format.)



A text file may contain one or many recipes and they do not need to be
in the same format. For example, a mailing list digest may contain
recipes that were exported from MealMaster, others that were exported
from MasterCook, and even some that are in the generic format. As long
as each recipe is preceded with a recognizable header, MasterCook will
add the recipe to the import selection list. Only the unformatted
recipes will be overlooked.
2.2.1    IMPORTING RECIPES: HANDLING UNFORMATTED TEXT FILES 
            FOR MASTERCOOK 3.0 and 4.0 USERS ONLY (WINDOWS and 
MACINTOSH)
________________________________________________________________________            

In addition to importing recipes that are in either the MXP or Mac
formats, discussed above, MasterCook 3.0 and 4.0 will also import
recipes in the "Generic Import Format". This format provides a very
simple method of preparing unformatted text recipes for import.

------------------------------------------------------------------------              

GENERIC IMPORT FORMAT

Following is the EXACT format that MasterCook expects when using the
"generic import" feature. You will find that it takes very little time
and effort to put most unformatted text recipes into this format.

NOTE: The descriptive comments appearing inside the bracket signs, 
"[ ]", are NOT a part of the format and appear here only for 
clarification.

1st line: @@@@@    [that's 5 "at" signs] 
2nd line: TITLE of the recipe 
3rd line: BLANK [this MUST be BLANK, not spaces!]

-- OR MC 4.0 ONLY --
3rd line: | [ (vertical bar) This eliminates the need for a BLANK line]

4th line: NOTES -- ONE line of text. [Optional]
5th line: BLANK [again, no spaces or non-display characters! Optional if
                                  no Notes line]

-- OR MC 4.0 ONLY --



5th line: | [ (vertical bar) This eliminates the need for a BLANK line]
 
6th line: amount unit ingredient preparation method
      .
      . [amount, unit, prep method are optional]
      .
Last INGREDIENT    [up to 100 ingredients] 
BLANK    [once again, no spaces!]

-- OR MC 4.0 ONLY --
5th line: | [ (vertical bar) This eliminates the need for a BLANK line]

DIRECTIONS and any "free form" text you wish to include. These lines are
optional.
Last line: _____ [end-or-recipe indicator, MC 4.0 ONLY]

NOTE: Everything until the "_____" (MC 4.0 ONLY) or the next "@@@@@"
will be put in the direction section. You can add the "recipe by",
"serving size", and "categories" once the recipes have been imported.

NOTE: The "Notes" line is REQUIRED for MC 3.0 Mac users. You may insert
any one or more text characters to fulfill this requirement, including a
"space".

TIP: Hate the tedium of deleting all those preceding spaces on each line
of your recipe? Well, there's no need to! With the exception of the
"@@@@@", the lines in the generic format do NOT have to be left
justified. Each text line may be preceded by non-printing characters,
such as spaces.

TIP: The easiest way to force the "preparation method" into the
"preparation method field" is to place either a comma or a semi-colon
after the ingredient. (Ex., 1 small onion, chopped --OR-- 1 small onion;
chopped)

TIP:    A BLANK line MUST truly be BLANK. (Or in the case of MC 4.0, the
control character "|" (vertical bar) may begin the line.) The import
will not work correctly if any non-displayable characters, such as
spaces, are contained in a "blank" line. If you are experiencing
difficulty importing a recipe, it may be helpful to view the recipe with
an editor (ex., WordPerfect, MS Word, Notepad, BBedit, etc.) that will



display non-printable characters. Only the end-of-line delimiters
(carriage returns,line feeds, etc) should be in a blank line.

TIP: If a recipe is not left justified in an e-mail message, what appears
to be blank lines are most likely lines with spaces. So, if the original
recipe is indented, be sure to delete and replace every blank line. Or,
if using MC 4.0, insert a "| (vertical bar) at the beginning of each
separator line.

TIP: Make sure that where a blank line is required, there is only ONE
blank line. If more than one blank is encountered, the importer may not
store the recipe properly.

TIP: MC 3.0 does not recognize an end-of-recipe delimiter, so EVERYTHING
following the first direction line until the next "@@@@@" is encountered
will be imported as directions. Therefore, you need to delete any
extraneous text (such as e-mail signatures) that you do not want stored
as part of your recipe. When using the generic format, MC will not strip
out trailing text that is not part of your recipe.

TIP: Recipes are posted on the Internet in a very wide variety of styles
and formats. Sometimes the ingredients are embedded within sentences and
it may be difficult to ready the recipe for importing. In these
instances, you may find it easier to manually enter the recipe using MC
fast-fill feature and doing a copy and paste of the directions.

------------------------------------------
EXAMPLE of a recipe in the "generic" format:

@@@@@
Grilled Tossed Vegetables

Serve with meat or poultry. Good vegetarian dish also.

6 cups eggplant,peeled and cubed
1 medium green bell pepper;chopped
1 large onion,chopped
1 tablespoon margarine    
1/4 teaspoon basil            
2 tomatoes            



salt        to taste
pepper    to taste

1. Peel and cube eggplant to make about 6 cups. Mix with the chopped 
      green pepper and chopped onion.
2. Cut 3 pieces of heavy-duty foil about 12 x 18 inches. Divide the 
      eggplant mixture evenly on foil. Place 1 teaspoon margarine on 
      mixture; sprinkle with basil, or if preferred use chopped fresh 
      basil. Close foil tightly.
3. Place foil packs on grill 3-4 inches from heat; cook for about 35 
      minutes.
4. Chop tomato and place on another piece of foil. Close foil and place
      on grill the last 15 minutes of eggplant cooking time.
5. Remove vegetables from foil; blend together in large bowl. Season to
      taste with salt and black pepper.

Recipe By: Jo Anne Merrill in from the MasterCook cookbook, "Kitchen 
Classics".
_____
------------------------------------------

If you prefer, instead of using the "generic format", you may put your
recipes into the "MXP" format. MC 3.0 and 4.0 removed the column and
position dependency of the MXP format, making it significantly more
flexible. It is now quite easy to create a keyword template for MXP and
simply insert the appropriate recipe sections. (See "APPENDIX A" for
details of this format.)

MC 3.0 WINDOWS USERS: There is a shareware "converter" available for the
MXP format:

                  Txt-to-MasterCook    (DOS only)
                  (Information available on the MasterCook Web Page 
                  (      http://www.sierra.com      )
                
Macintosh users also have the option of using the "Mac format". (See 
"APPENDIX B" for a description of this format.)

A text file may contain one or many recipes and they do not need to be
in the same format. For example, a mailing list digest may contain
recipes that were exported from MealMaster, others that were exported



from MasterCook, and even some that are in the generic format. As long
as each recipe is preceded with a recognizable header, MasterCook will
add the recipe to the import selection list. Only the unformatted
recipes will be overlooked.

________________________________________________________________________

2.4    IMPORTING RECIPES: IMPORTING RECIPES from e-mail
________________________________________________________________________

The majority of recipes you will receive will be embedded in e-mail
messages. An e-mail message may contain one or many recipes and you 
may
import any or all of these recipes. Of course, each recipe must be in an
import format that MasterCook recognizes (see "2.2    Importing
Recipes: MasterCook Import Formats"). If it is not, then you
will need to edit the recipe and put it in an acceptable format prior to
importing.

When recipes are embedded in an e-mail message and surrounded by other
text (which is common in e-mail messages and mailing list digests), there
is often no need to first edit the file to strip out the extraneous
text. The MasterCook importer will begin importing from the
"beginning-of-recipe" header and will stop when it comes to the
beginning of the next recipe, the end-of-file indicator, or to an
end-of-recipe delimiter. Any other text, such as e-mail headers,
signature lines, or even comments that are not a part of the recipe will
not be imported.

EXCEPTIONS: MC 3.0, MC II, and MC Mac users:

In the following circumstances, you will need to delete all extraneous
text that follows a recipe (ie, e-mail signatures) prior to importing. If
you do not, then the trailing text will be imported as part of your
recipe.

-- When a recipe is in the "Generic" format.

-- When a recipe in the standard "MXP" format contains a "Notes"
section.



-- When a recipe in the standard "MXP" format contains a "Serving Ideas"
section.

-- When a recipe in the standard "MXP" format contains a "Suggested
Wine" section.

NOTE: There are occasions when an e-mail message will contain extraneous
characters within the body of the recipe. For example, if the recipe was
"forwarded" or "replied to", it will probably contain ">" symbols at the
beginning of each line. In cases such as this, the recipe will NOT
import as is. You must first edit the recipe to remove all unwanted
characters.

TIP: If there are changes that you would like to make to the recipe
itself (such as changing categories), it is typically easier to make the
changes from within MasterCook, AFTER the recipe is imported. Likewise,
if unwanted text was imported as part of the recipe (ie, e-mail
signatures), it can be easily removed by editing the recipe within MC.

------------------------------------------------------------------------

There are two ways that recipes may be imported from e-mail messages.
Depending on your particular e-mail program, you may be able to use 
one or both methods.

------------------------------------------
1) SAVE THE e-mail message containing the recipes you wish to import as 
a text file. Then you follow the normal MasterCook importing procedures,
pointing the MC importer to the saved text file.

TIP: When you save an e-mail message as a text file, make sure that you
do NOT select options such as "Guess Paragraphs" or "Wrap". These
options may alter the format of the recipe, preventing successful
importing.

It does not matter if the e-mail header information is stored with the
recipe; MasterCook will strip that when it imports.

TIP: Many e-mail programs will allow you to save multiple e-mail messages
in one text file. The advantage in doing this is that you can import
many recipes by invoking the import operation only once. Be careful,



however, if you are not a MC 3.0 and 4.0 user that every recipe in one
file is in the same format (ex., they all are from MM or all in MC MXP
format).

TIP: Many e-mail programs will separate a large e-mail message into
multiple parts, typically appended with a numeric suffix. This may very
happen when someone posts many recipes in one e-mail message. When 
you 
do the "Save", make sure that you save all parts of the message in the
same file.

TIP: Often users will preface the formatted recipe with interesting
comments that you might like to save with your recipe. In this case, you
should edit the e-mail message and copy and paste the extra comments into
the recipe. In order to prevent altering the recipe format (if you do
change it, it may not import), the safest place to insert these
additional comments is either at the beginning or the end of the
"directions" section.

------------------------------------------
2) IMPORT DIRECTLY from an e-mail mailbox. Some e-mail programs (such as
Eudora) maintain the mailboxes as text files that can be opened and
viewed as normal text files from other programs. If this is the case
with your e-mail program, then you may simply point the MasterCook



Active Window
The window in which you're currently working. The active window's title bar is a different color or 
intensity to distinguish it from other, inactive windows. The active window always appears in the 
foreground and cannot be covered by any other window, which means it may overlap inactive 
windows.

To close this pop-up window, click the left mouse button once anywhere outside of it.



Adding Recipes to MasterCook



Basic Shopping List
MasterCook lets you create and maintain a shopping list of staple grocery items that you 
purchase on almost every trip to the store. You can add these items to other shopping lists you 
create for recipes, menus and meal plans.

Creating a Basic Shopping List

Editing the Basic Shopping List

Edit items in Basic Shopping List

Remove items from Basic Shopping List

Cut items from Basic Shopping List

Copy Basic Shopping List items to Clipboard

Paste items into Basic Shopping List

Adding Basic Shopping List Items to a Shopping List

Excluding Basic Shopping List Items

Including Basic Shopping List Items

Print Basic Shopping List

To create a Basic Shopping List:
1. Choose Edit Basic Shopping List from the Shopping List menu to open the Basic Shopping 

List dialog box.

2. To add an item to the Basic Shopping List, type the amount and name of each item, pressing 
TAB or RETURN to move between the columns.

3. To exclude items so that they won't be included when you choose the Add Basic Shopping 
List command, click the check box that precedes the item.

4. Type any comments or notes in the Recipe/Notes column.

5. When you're finished adding items, choose Save Shopping List from the File menu.

6. Click the Close button to exit the Basic Shopping List.

To edit items in the Basic Shopping List:
1. Choose Edit Basic Shopping List from the Shopping List menu.

2. Edit the items you want to change, and then choose Save Shopping List from the File menu.

To remove items from the Basic Shopping List:
1. In the Basic Shopping List window, click on the number buttons for the items you want to 

remove.

2. Choose Clear Row(s) from the Edit menu.

To cut items from Basic Shopping List:
1. In the Basic Shopping List window, click on the number buttons for the items you want to cut 

and place on the Clipboard.

2. Choose Cut Row(s) from the Edit menu.



To copy Basic Shopping List items to the Clipboard:
1. In the Basic Shopping List window, click on the number buttons for the items you want to copy

and place on the Clipboard.

2. Choose Copy Row(s) from the Edit menu.

To paste items into the Basic Shopping List:
1. Click on the line where you wish to paste the contents of the Clipboard.

2. Choose Paste Row(s) from the Edit menu.

To add items on the Basic Shopping List to a shopping list:
1. Open the shopping list to which you want to add Basic Shopping List information.

2. Choose Add Basic Shopping List from the Shopping List menu.

To exclude Basic Shopping List items:
With the Basic Shopping List open, click the check box that precedes the item(s) you want to 
exclude.

To include Basic Shopping List items:
With the Basic Shopping List open, click the check boxes marked with an "X" for each item 
you want to include in the shopping list.

To Print the Basic Shopping List:
1. Open the Basic Shopping List and choose Print Shopping List from the File menu or click

 on the Control Bar.

A dialog box is displayed indicating the shopping list is being sent to the printer. Before you print 
the list, you can specify printer options by choosing either Page Setup or Printer Setup from the File 
menu.

See Also
Shopping List Menu

File Menu

Edit Menu



Basic Shopping List
MasterCook lets you maintain a list of foods and non-food items that you regularly purchase at 
the grocery store. The items on this list can be added to the shopping lists you create for recipes, 
meal plans and menus.

See Also
Basic Shopping List

To close this pop-up window, click the left mouse button once anywhere outside of it.



Basics of File Transfer
If you are planning on exchanging recipes via the Internet, it is important that you understand the 
basics of electronic file transfer.    This will be helpful to you in getting started, and this 
understanding will be particularly valuable when "things go wrong."

The following Help files describe the Basics of File Transfer on the Internet:

Types of Files

Transferring Files

Details on how to exchange MasterCook recipes via the Internet will be covered in the Importing 
Recipes and Exporting Recipes Help files.    If you are an experienced user of e-mail and file 
transfers on the Internet, you may wish to skip to these MasterCook-specific discussions.



Book View
The Book View of a cookbook window is designed to resemble an actual, paper-bound cookbook. 
In this "electronic cookbook," MasterCook allows you to flip through pages one at a time, refer to 
an index for a specific recipe, and even place bookmarks on recipes as you browse through them,
allowing you to return to them easily with the click of a button. Specify whether to display both 
pages of the cookbook or the right page only by choosing from the View menu.

The simplest way to browse through Book View is to use the page-turning icon, which looks like a
pointing hand. To make the page-turning icon appear, move the arrow pointer towards the left, 
right, or bottom edge of the book. As the arrow pointer nears the edge of the book, it will turn into 
the page-turning icon. Clicking with the page-turning icon on the right edge of the book turns one 
page forward; clicking on the left edge of the book turns one page back.

To close this pop-up window, click the left mouse button once anywhere outside of it.



Bookmarks
Bookmarks keep track of recipes in a cookbook open to Book View.    To place a bookmark, move 
the arrow pointer toward the outer top corner of the page you wish to mark.    The arrow pointer 
turns into the bookmark placement icon, which looks like a paper clip.    When you click the mouse
button, a bookmark is added to the page.    You can also add a bookmark by choosing Add 
Bookmark from the Go menu on the menu bar.

See also
Bookmarks Card

To close this pop-up window, click the left mouse button once anywhere outside of it.



Bookmarks Card
The Bookmarks Card appears when viewing a cookbook in Book View. When you click on the tab
labeled Bookmarks near the top edge of the book, the Bookmarks Card appears. The Bookmarks 
Card contains a list box which shows the titles of all the recipes which you have bookmarked. To 
view a recipe which you have bookmarked, double-click on the name of the recipe.

See also
Bookmarks 



Bookshelf
The Bookshelf contains several cookbooks. The titles of the cookbooks are printed sideways on 
their spines.    When you start MasterCook for the first time, the Bookshelf contains only the 
cookbooks which come pre-loaded with MasterCook.    Later, after you've learned to create your 
own cookbooks, the Bookshelf will contain both the preloaded cookbooks and any other 
cookbooks you have created and chosen to add to the Bookshelf.

To open a cookbook from the bookshelf:
Double-click on the spine of the cookbook you wish to open. The cookbook opens, and its 
contents appear in a cookbook window. The Bookshelf remains open. 

To close this pop-up window, click the left mouse button once anywhere outside of it.



Cannot Import Recipes
You want to import some recipes, but they just won't import?    Perhaps MasterCook can't find any
recipes in your source file, or perhaps you can't locate the file that contains your recipes? Locate 
the symptom you are experiencing in the following and you may very well find the solution to your 
import problem. 

--------------------------------------------------------

SYMPTOM: INVALID FILE FORMAT or NO RECIPES WERE FOUND to import 
You received a message stating that the text file did not contain anything MC could import or that 
it did not recognize the format. Or perhaps you were presented with a blank "Import Selection" 
window. 

CAUSES/SOLUTIONS: The recipes in the file were not in a format that the MC importer could
recognize. Or MC cannot process the file type.Examine the file closely and make the 
necessary changes so the recipes comply with one of the supported formats or file types.See 
"A-I" below for specific causes and fixes.

------------------------------------------

A. The most likely cause is that the text is unformatted. EACH recipe must be in a MC supported 
format before it can be successfully imported.See the Import Formats Help file for details.

.------------------------------------------

B. Perhaps you received recipes to import that were indeed formatted, but the "beginning-of-
recipe" indicator was missing. Each recipe title MUST be proceeded by a header such as 
"Exported from MasterCook", "@@@@@", or "Exported from MealMaster". If headers are 
missing, copy one from a recipe that imported successfully, and paste it in front of every recipe 
title.

------------------------------------------

C. The recipes were embedded in an e-mail message that had been "forwarded" or "replied to". 
This caused the e-mail program to automatically insert a character or characters (such as ">" ) at 
the beginning of each line. Edit the file and remove all extraneous characters from each line. (The
easiest way to accomplish this is to do a "find" and "replace all" with a text editor or word 
processing program.)

------------------------------------------

D: You edited the recipe text file with a word processing program, such as MS Word, 
WordPerfect, or ClarisWorks and did not specify "TEXT" for the saved file type. By default, word 
processing programs save formatting information with the text, which will prevent MC from 
recognizing the recipes. Open the recipe file with the word processing program, and do a "SAVE 
AS". Specify "TEXT" or "PURE TEXT" as the file type. This will preserve the recipe format and 
you will be able to import successfully.

------------------------------------------

E. Did you receive the recipes in an attached document or were they downloaded from the 
Internet? Then the recipe text file may contain the wrong end-of-line (EOL) delimiters for your 
system. View the file with atext editor (such as Notepad or Simple Text). Do the lines appear to 
be"run on" and/or are there foreign characters, such as "black rectangles" or "blank squares"? If 
this is the case, then you must correct the "text type." For adetailed description of this problem 
and how to fix the recipes, see the Recipe Formats/Text Types Help file.

TIP: You will not encounter this situation with recipes that were embedded in e-mail 
messages because your email program will do the correct EOL translation when it receives 
the message.

TIP: Although this can occur with attached documents, you are morelikely to encounter this 



problem with downloaded files. Typically,attached text files will be translated (like e-mail 
messages are) so the ywill contain valid EOL delimiters.

------------------------------------------

F: The recipes in an email message are in MC Mac format. It is verylikely that the delimiting "tab" 
character used by this format wasconverted by either an Internet service provider or an email 
program.You can edit the file and insert "tabs" between every field.

TIP: If you are a MC II user you cannot normally import MC Mac recipes received in email 
messages. However, with an editor such as "Editmaster" that will enable you to specify the 
file's text type, you can translatethe text type to Mac EOL delimiters. You will then be able to 
importthese recipes. (See the Recipe Formats/Text Types Help file.)

------------------------------------------

G: You may have received an attached document or downloaded a text file that is "compressed." 
View the file with any text editor, such as Notepad or Simple Text. If the file will not open or looks 
"garbled," itcould be a compressed (or "zipped") file. You must expand or "unzip" a compressed 
file before you can import it. Use the appropriate utility program to expand it, then import as usual.

------------------------------------------

H: You may have received an attached document or downloaded a file in raw data (binary) format.
To determine if this is the case, try viewing the file in any editor, such as Notepad or Simple Text. 
If it does not open or appears "garbled", it may very well be a raw data file. OOPS, you cannot 
import a raw data file. However, the file may actually be a complete MasterCook cookbook. Try 
opening it from within MasterCook.If that doesn't work, then the file may be a text file that was 
sent as raw data. Ask the sender to resend the file as a "text" file, or download the file again, 
specifying "text" as the file type.    Alternatively, you can try altering the file's text type and then tryi
mporting again. For detailed instructions on how to accomplish this, see the Correcting Text Type 
Help file.

------------------------------------------

I. You may have received an incomplete file due to a transmission error.In this case, you most 
likely will not be able to open a text file withan editor or a cookbook file with MC. The file must be 
re-transmittedbefore you can import the recipes.

--------------------------------------------------------

SYMPTOM: CAN'T FIND the RECIPE TEXT FILE for IMPORTING
CAUSES/SOLUTIONS: You thought you had a text file with formatted recipes to import, but 
you don't know where it is. You need to find the file and then point the MC Recipe Translator 
to the directory (folder) and file that you wish to import. See "A-D" below for hints on how to 
find the import source file

.-----------------------------------------

A. You want to import directly from a "mailbox." Your email program must store mailboxes as 
independent text files and you need to know the name of the mailbox file and where that file is 
located. Then simply tell MC the file name and in which directory/folder it resides.

------------------------------------------

B. You did not receive either a text file or complete cookbook file that was sent as an "attached 
document." Then your e-mail program may not be able to handle attachments. Ask the sender to 
resend the recipes to you embedded in an e-mail message

.-----------------------------------------

C: An attached document or downloaded file may be too large for you to receive. Many Internet 
service providers or your host server may have limitations on file size. (Attached documents and 
downloaded files are frequently large.) If the file wasn't compressed, ask the sender to compress 



the file (but make sure that you have the right utility to expand it). If it is still too big, ask for the file
to be split into several smaller files

.------------------------------------------

D. Perhaps there was an error in transmission that prevented you fromreceiving an attached 
document or downloading a file. Ask the sender toresend the file or try downloading the file again.

--------------------------------------------------------

SYMPTOM: NOT ALL of the recipes in the file appeared in the ImportSelection window 

CAUSE/SOLUTION: The recipes not displayed in the "Import selection list"are not properly 
formatted. You must examine the file and make the required changes. "A-G" below offer some
specific problems and solutions

.------------------------------------------

A. Is EACH recipe preceded by a "beginning of recipe" header? If not,copy and paste the header 
from a recipe that you know works. Be sure that you use the correct header for the format. (Ex., 
use the MasterCook MXP header for recipes in the MC MXP format, a MealMaster header for 
recipes in a MM format, etc.)

------------------------------------------

B. If you are using MC Mac or MC II, is there more than one supported format in the same file? 
(For example, the file contains recipes in MXPand MM format.) If so, move recipes of like formats 
to separate files.Only MC 3.0 and 4.0 will recognize multiple formats within the same import file.

------------------------------------------

C. Are the missing recipes really in an acceptable format? Verify that the recipe has a non-blank 
title and a valid beginning-of-recipe header. If the you are suspicious of the header (some require 
very fixed formats), then copy and paste a similar header from a recipe that did import correctly.

 ------------------------------------------

D. You are using the generic format and the "@@@@@" did not begin in "column 1". The 
"@@@@@" MUST be left justified and there may not be any spaces or other non-printing 
characters in front of this header.

TIP: ALL text lines following the header (for example, ingredients or directions) may begin in 
any column so there is no need to force left-justification if those lines are indented.

------------------------------------------

E: Ensure that there is nothing except a blank line between the beginning-of-recipe header and 
the title. There may be more than one blank line, but there may not be any non-blank ones. MC 
assumes that the first character encountered after the header is the recipe title.

TIP: A blank line is not required, but is often used to improve the readability of the text.

------------------------------------------

F. Do lines that must be blank contain invisible characters, such as spaces or tabs? Try deleting 
the line to eliminate any invisible characters that might be present. Use an editor or text processor
that will display "non-printing characters" (such as Editmaster, BBedit, MSWord, WordPerfect) to 
help you find the extraneous characters.

------------------------------------------

G. Were the recipes received in an e-mail file that was separated into more than one part? In this 
case, you must concatenate all parts of the message (for example, by saving all parts in one file) 
before you try to import. E-mail programs do not break large programs at logical points, so 
recipes may be split between two parts.



Category List
With Category List, you can browse the contents of a cookbook "at a glance." Category List is 
particularly helpful when you are familiar with the recipes in a cookbook and want to print or edit 
selected recipes quickly. You will also probably use Category List when using MasterCook's more 
complex features, like copying and deleting recipes; creating shopping lists, menus, and meal 
plans; and sending recipes via electronic mail. 

When you select Category List to display a cookbook (by choosing As Category List from the 
View menu), a divided window opens. The name of the cookbook appears in the title bar. The 
names of the cookbook's categories are displayed alphabetically on the left side of the cookbook 
window like the chapter titles in a cookbook's table of contents. 

When you click on a category name, a list of that category's recipes appears on the right side of 
the cookbook window and a checkmark appears in the category's indicator icon. To select more 
than one category, hold down the CTRL    key as you click on each category. As each new 
category is selected, its recipes are added, alphabetically, to the list of recipes on the right side of 
the cookbook window. Click on All Recipes at the top of the cookbook window to display a list of 
all recipes in the cookbook. 

Once you've compiled a list of recipes in Category List, you can either send the recipes to the 
Recipe Clipboard or open them for viewing. If you've selected only one recipe for viewing, just 
double-click on the name of the recipe, and a recipe window appears. If you wish to view more 
than one recipe from your compiled list, select them the same way you selected the recipe 
categories, holding down the CTRL key while clicking on the recipes you wish to view. To view the
selected recipes, click the Open button in the upper right corner of the window. The recipe 
windows for the recipes you selected will open on top of each other, in the order in which they 
were selected. 

To close this pop-up window, click the left mouse button once anywhere outside of it.



Check Spelling

New to the latest version of MasterCook is its spell checker, which you can use to check the 
spelling both of individual recipes and entire cookbooks. This feature is especially helpful when 
you import recipes from other sources, such as other recipe programs, online services, and World
Wide Web pages. Correct spelling is also important to ensure accurate nutritional and cost 
analyses.

NOTE: If you choose to spell check an entire cookbook, the spell checker will start with the 
first recipe in the cookbook and proceed alphabetically through every recipe in the cookbook. 
This can take a long time and is probably only practical in certain situations, such as checking
a newly created cookbook (especially one comprised primarily of recipes imported in non-
MasterCook formats). Most of the time you will probably use the spell checker to check 
specific recipes and selected sets of recipes.

Selecting a Cookbook or Recipe(s) to Spell Check
You must select either the cookbook or recipe(s) that you would like to spell check.

To select a cookbook
Open the cookbook window of the cookbook you wish to spell check to either Book View or 
Category List, then choose Check Cookbook Spelling from the Tools menu.

The spell check dialog box appears.

To select a recipe
If you are in Category List. click on the names of the recipes you wish to spell check on the 
right side of the cookbook window (to choose more than one recipe, hold down the CTRL key 
in Windows while clicking on each recipe name).    

Choose Check Selected Recipe(s) from the Tools menu. 

The spell check dialog box appears.

If you are in Book View and wish to check only the spelling of the open recipe, choose Check 
Displayed Recipe from the Tools menu. If more than one recipe appears on the open pages, 
MasterCook will ask you which page (left, right, or both) contains the recipe you wish to check.    
To check more than one recipe while in Book View, you can select a set of recipes from either the 



Index, Bookmark, or History card and then choose Check Selected Recipe(s) from the Tools 
menu. The spell check dialog box appears.

Using the Spell Check Dialog Box
The Word box near the top of the spell checker dialog box displays the first of any misspelled 
words which the spell checker finds in the cookbook or recipe. When MasterCook finds a 
misspelled word, it usually offers several alternative words in the Suggestions box below the 
misspelled word. If MasterCook cannot find an alternative to the misspelled word, the 
message "no suggestions" appears in the Suggestions box.

When the spell checker identifies a misspelled word, you have two options:

If the correct word appears in the Suggestions box, you can click on it once. If you click on the
correct word once, it appears in the Word box at the top of the window; you can then replace 
that single instance of the misspelling by clicking the Replace button, or replace every    
instance of that misspelling by clicking the button labeled Replace All. 

If the "no suggestions" message appears in the Suggestions box but you recognize the 
misspelling, highlight the misspelled word, type the correct spelling in the Word box, and click 
either Replace or Replace All.

When the spell checker incorrectly identifies a word as misspelled, it is likely because the word is 
not included in MasterCook's dictionary. The dictionary will also not recognize most proper 
names. 

When the spell checker incorrectly identifies a word as misspelled, you have two options: 

You can have the spell-checker ignore the word and move on to the next misspelled word by 
clicking the Ignore button; clicking the Ignore All button causes the spell checker to ignore 
every further instance of the word in the cookbook or recipe. 

You can also have the spell checker "learn" a word incorrectly identified as misspelled by 
adding the word to the User Dictionary; once the spell checker learns a word, it won't identify 
the word as misspelled in the future. To add a word to the User Dictionary, click the Add 
button when the word appears in the Word box.    

Once you have Replaced, Ignored, or added a word to the User Dictionary, MasterCook 
continues searching the recipe(s) or cookbook for other misspelled words. Click the Skip to 
"Recipe by" or Skip to Next Recipe buttons if you wish to bypass certain recipes in the 
selection or cookbook.    You can also speed up the spell checking process by using Spell 
Check Options.
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Contiguous Selection
You can select a group of items groups together by holding down the SHIFT key and then clicking
each item you want.

See Also
Non-contiguous Selection

To close this pop-up window, click the left mouse button once anywhere outside of it.



Control Bar
The Control Bar is a strip of icon-buttons that let you perform the most common MasterCook 
functions (such as printing, exporting, deleting and mailing recipes) with a single button click.

You can hide the Control Bar by selecting Hide Control Bar from the Window menu.
To close this pop-up window, click the left mouse button once anywhere outside of it.



Cookbook Looks
With Cookbook Looks you can control the appearance of a cookbook window displayed in Book 
View. You can change the color and pattern of the cookbook's cover, the color and texture of its 
pages, and the way recipes are laid out on the pages of the cookbook. You can also change the 
type of bookmark placed when using the Bookmarks feature, and the color of the Index Card, 
Bookmarks Card, and History Card.

In order to use Cookbook Looks, the cookbook window must be displayed in Book View; to switch
from Category List to Book View, choose As Book from the View menu. Choosing Cookbook 
Looks from the Edit menu while in Book View makes a dialog box appear. You can also switch 
from Book View to Category List and vice versa by clicking on the toggle button on the Control 
Bar.

At the left hand side of the dialog box is a list of Recipe Design options. At the right side of the 
Cookbook Looks dialog box are several graphics scrollboxes displaying appearance options for 
the cookbook window. To view the appearance options for the cookbook's Cover, Paper, 
Bookmarks, Index Card, Bookmarks Card, or History Card, click on the scroll bar next to the 
appropriate display box. Clicking on a recipe design from the list on the left side of the Cookbook 
Looks window changes the way recipes are laid out on the page in Book View on the page. 
Different recipe designs use different fonts, spacing, and margins.

To accept the cookbook's new appearance, click the Change button at the bottom of the dialog 
box. To keep your previous appearance options, click the Cancel button.

TIPS: When creating Cookbook Looks, solid colors work the best for the tabs. Lighter 
colors work best for the paper. If you place clip art in a design and it contains a white 
background, the background is not transparent so you probably want to use white paper. 
You could also put a border around your art, but don’t do it in MasterCook because if you 
crop the art close to the image (as you should in order to minimize the file size) the 
borders are placed right on the edge of the bitmap so you won’t have any breathing room 
around the art. Edit your clip art in a paint program such as Photoshop or Paintshop Pro.

See also
Cookbook Recipe Design

Page Setup



Cookbook Recipe Design

With MasterCook's Cookbook Recipe Design Editor, you have full control over how recipes 
appear on the page in Book View. You can decide what elements of recipes are displayed and in 
what order, what fonts are used and their sizes, the alignment of and spacing between various 
elements, and so on. A recipe design can be applied to all of the recipes in a cookbook by 
selecting it from the Cookbook Looks dialog box. You can also select a recipe design as your 
default print setting when you get ready to print a cookbook or selected recipes (see Page Setup).

The following Help file explains most of the features of the Cookbook Recipe Design Editor 
accessible through the menu bar at the top of the Cookbook Recipe Design dialog box. Other 
features are covered in separate Help files:

Saving a Recipe Design

Importing a Picture to a Recipe Design

        Resizing and Repositioning Recipe Elements  

Basic Recipe Design for Windows
1. Make sure you have opened a cookbook window to Book View

2. Choose Cookbook Recipe Design from the Edit menu.The Recipe Design dialog box 
appears, displaying the same recipe which appears in the cookbook's open window.

3. Choose a recipe design to modify from the Design Menu.

MasterCook applies the recipe design to the displayed recipe.

4. From the Show menu at the top of the dialog box, choose which recipe elements you would 
like to appear on each page in Book View when the recipe design is applied. Choose an 
element by holding down the mouse button and dragging the arrow-pointer over the element 
you wish to select, then release the mouse button. A checkmark appears next to each chosen
recipe element. Choosing an already-checked element deselects that element. Any recipe 
elements you select, including the recipe title, text blocks, and any graphical elements, are 
displayed on the recipe shown in the Recipe Design dialog box. The recipe elements are 
divided into separate blocks by dotted lines.

5. Move the arrow pointer over the recipe shown in the Recipe Design dialog box and click on 
the recipe element you wish to modify.MasterCook draws a solid frame around the element to
indicate your selection.

6. Modify the recipe element by choosing from the Properties menu at the top of the dialog box.

Horizontal Alignment

Choose from this submenu to align text or a graphical element horizontally within the recipe 
element.

Vertical Alignment

Choose from this submenu to align a graphical element vertically within the recipe element.

Columns

Choose from this submenu to select the number of columns you wish to place within the 
recipe element. MasterCook automatically "flows" text within the recipe element from one 
column to the next.

TIPS: 1 or 2 columns work best on screen instead of 3 because of the limited screen 
size. If you are going to view your recipes on-screen more often than on a printed copy, 



you will get a better idea of how they will look on paper if you view your book in Right 
Page only view. Otherwise, find a happy medium between on screen and the printed 
version when using columns. 

It is best to leave some space between objects in the layout view so that your recipe 
pages won’t appear crowded. When you are creating custom columns instead of using 
the columns option on the menu, you have greater freedom and creativity. When planning
columns, however, keep in mind that if the recipe you are viewing in the Recipe Design 
dialog doesn’t have, for example, a photo, and other recipes in your book contain photos, 
you need to plan for it in your design. The same thing applies to clip art that you may 
insert into a layout. See "Start of Row," below, for more information.

Font

When you select Font from the Properties menu, the Font dialog box appears. Choose the 
font, style, and size from the scrollboxes and click the OK button to accept. Modifications 
you make in the Font dialog box are applied to all of the text in the selected recipe 
element.

TIPS: If you are creating a layout to be viewed primarily on-screen instead of on a printed
copy, you will probably want to use a type size that is comfortable for you to view, such as
9 or 10 point. Limit your use of fonts to 1 or 2 for a more professional look. Lighter font 
colors work well on-screen but    don’t print well, even in color, on the average home 
printer. 

Borders

Choose Borders from the Properties menu to draw a solid line on any side of the recipe 
element block. In the Borders dialog box, enter the thickness of the lines (measured in 
points) in the small boxes and click OK to accept. To create a box around a recipe 
element, simply enter the same number in each of the four boxes.

Labels

Choose Labels to add a running prefix or suffix to the text within a selected recipe element. 
MasterCook's labels are much like the headers and footers in many word processing 
programs; once you define the text of a running prefix or suffix, it will appear at the 
beginning or end of the selected recipe element in every recipe, thereby labeling the 
element. For example, you may want the label "Author:" to appear in front of the name of 
the author or source in the Author recipe element.

When you choose Labels from the Properties menu, a dialog box appears. In the appropriate 
text boxes, type the prefix and/or suffix you would like to include in the selected recipe 
element. Click the OK button. If you typed in a prefix, it appears at the beginning of the 
selected recipe element in every recipe; if you typed in a suffix, it appears at the end of 
the selected recipe element in every recipe.

Start of Row

Not every recipe in a cookbook will contain all elements selected from the Show menu. For 
example, a recipe might not include a recipe picture, even though the recipe design in 
which it is displayed includes a recipe picture marker in its layout. When MasterCook 
displays such a recipe, it automatically compensates for the "missing" recipe element by 
moving the surrounding recipe elements into the empty space.

When you choose Start of Row from the Properties menu, MasterCook does not move the 
surrounding recipe elements into the empty space, but instead "holds" the surrounding 
recipe elements in their corresponding position.

7. To accept any modifications you have made to the recipe design in the Recipe Design dialog 
box, click the Change button at the bottom left corner of the dialog box.

Any modifications you have made to the recipe design are applied to every recipe in the open



cookbook.



Cookbooks
MasterCook cookbooks are the files MasterCook uses to store your recipes. MasterCook 
cookbook files can be given any name you like as many as 80 characters.    Each cookbook can 
contain up to 8,000 recipes.

Creating New Cookbooks

Opening Cookbooks

Closing a Cookbook

Renaming a Cookbook

Copying a Cookbook

Backing Up a Cookbook

Deleting a Cookbook

Editing Cookbook Categories

Exporting Recipes from a Cookbook

Importing Recipes into a Cookbook

Copying Recipes to Another Cookbook

Choosing a Page Size and Recipe Design

Printing a Cookbook

Printing the Recipe Clipboard

To create a new cookbook:
1. Choose New Cookbook from the File menu.    The New Cookbook dialog box appears.

2. Type a name for the cookbook and then click the Create button.

The cookbook window for the new cookbook appears. The Categories dialog box is also 
displayed, which is where you'll create the categories for the cookbook.

3. For each category that you wish to add to the cookbook, type the category name and then 
click the Add button.

As you add a category, it appears in alphabetical order in the list box.

4. Click the OK button when you've finished adding categories. The cookbook window displays 
the new categories.

To open a cookbook:

1. Choose Open from the File menu or click  from the Control Bar.

2. In the Open dialog box, click the file name for the cookbook you want to open.
The file extension for MasterCook cookbooks is .mcf.

3. Click the Open button or double-click the cookbook file name to open it.

To close a cookbook:
1. Choose Close Cookbook from the File menu or click the cookbook window's close box.



To rename, make a copy of, or backup a cookbook:
1. Choose Save Cookbook As from the File menu.

2. Type a new name for the cookbook in the dialog box, and then click the Save button.

To delete a cookbook:
1. Make a cookbook window the active window.

If you have any recipes selected, click on the left (Categories) side of the cookbook window to
deselect them.

2. Choose Delete from the File Menu.

3. From the Delete dialog box, choose the directory and/or disk drive in which the cookbook is 
located.

4. Click the cookbook's file name and then click the Delete button.

A dialog box appears, asking you to confirm your choice to delete the cookbook.

5. Click the Delete button to confirm the permanent deletion.

Editing a Cookbook's Categories
To add a category to an existing cookbook:
1. Open the cookbook to which you want to add categories.

2. Choose Edit Categories from the File menu.

The Edit Categories dialog opens.

3. For each category you wish to add, type the category name and then click the Add button.

The categories appear alphabetically in the list box.

To remove a category from a cookbook:
1. Open the cookbook from which you want to remove categories.

2. Choose Edit Categories from the File menu.

3. In the Edit Categories dialog box, click the category name in the list.

4. Click the Delete button.    The category is deleted from the list.

To rename a category:
1. Open the cookbook containing the category or categories you want to rename, and choose 

Categories from the File menu.

2. Click the category you want to rename in the Categories dialog box.

3. Click the Rename button.

4. Type a new name for the category and click the OK button.

To save a cookbook's categories as a template for future cookbooks:
1. Open the cookbook containing the category or categories you want to use as a template, and 

choose Edit Categories from the File menu.

2. Click the Save as Template button.



A dialog box appears, asking you to confirm your choice.

3. Click the Yes button.

To use the Category Template with new cookbooks:
1. Create a new cookbook with the New Cookbook command.

2. When the Categories dialog box appears, click the Use Template button.

3. Add new categories or remove categories until you have the categories you wish to use and 
then click the OK button.

To import recipes into a cookbook:
1. With a cookbook open, choose Import Recipes from the File menu.

2. In the dialog box, choose the directory and/or disk drive where the export text file is located (if
it isn't already displayed).

3. Click the name of the export text file containing the recipes that you wish to import and then 
click the Import button, or double-click the name of the file.

4. Click the names of the recipes you want to import or click the Select All button to import all 
recipes in the file.

5. Click OK to import the selected recipes.

See Importing and Exporting Guide for more information.

To copy recipes to another cookbook:
1. With two cookbooks open and their cookbook windows visible, first make sure each cookbook

windows is opened in Category List. Then select the recipes you want to copy by clicking on 
their names.

2. Drag the selection of recipes to the cookbook window of the cookbook you wish to copy to.

3. Release the mouse button to finish copying the recipes.

NOTE: You can also copy recipes between cookbooks using the standard Cut and Paste 
commands under the Edit menu.

To print a cookbook:
1. Choose Print Cookbook from the File menu.

From the dialog box, you can choose to print a selection of recipes or the entire cookbook. To 
select a category (or group of categories) for printing, click the category name(s) in the 
Categories list on the left side of the dialog box. All of the recipes in the select categories are 
displayed in the list on the right. Click on the specific recipes you want to print or click the 
Select All button to print all of the recipes.

2. Click the Setup button to specify printing options.

3. Click the Print button.

See Page Setup for more information on printing recipes and cookcooks.

To print the Recipe Clipboard:
1. Click on the Recipe Clipboard window to make it active, or choose Recipe Clipboard from the 

Window menu.



2. To print all recipes on the Recipe Clipboard, choose Select All Recipes from the Edit menu; to
print only a selection of recipes on the clipboard, click on the names of those recipes you 
want to print.

3. Choose Print Selected Recipes from the File menu or click  on the Control Bar.

4. Choose the printing options you wish to use.
5. Click the Print Preview button to view how the recipes will look.
6. Click the Print button.



Cookbooks
MasterCook cookbooks are the files MasterCook uses to store your recipes. MasterCook 
cookbook files can be given any name you like up to 80 characters.    Each cookbook can contain 
up to 8,000 recipes.

See Also
Cookbooks

To close this pop-up window, click the left mouse button once anywhere outside of it.



Edgetabs
Edgetabs appear    along the edge of every page of a cookbook in Book View, much as they do in 
real cookbooks and other paper-bound reference books, like dictionaries. MasterCookÕs 
edgetabs look like small black rectangles staggered along the edges of the "closed" pages of a 
cookbook in Book View; each rectangle of edgetabs corresponds to a category in that cookbook's
index. One way to quickly browse the categories of a cookbook in Book View is to move the 
arrow-pointer over the edgetabs of the cookbook. When the pointer rests on a set of edgetabs, 
the name of the category appears in a small balloon next to the pointer. 

When you click on a set of edgetabs, the cookbook opens to the first recipe in that category.
To close this pop-up window, click the left mouse button once anywhere outside of it.



Edit Menu
The Edit menu contains the standard Windows Edit menu commands for text editing: Undo, Cut, 
Copy, Paste and Clear.

These commands -- also known as the Clipboard commands, because they store text on the 
Windows Clipboard --are used in MasterCook to edit text that you type while modifying recipes 
and menus.

In addition to the basic text editing commands, MasterCook also includes editing commands for 
ingredient rows in recipes and even for entire recipes. For more information, see the MasterCook 
User's Manual.

The Edit menu also provides access to MasterCook's Cookbook Recipe Design, with which you 
can create recipe designs as distinctive as your own cooking style.

The following is the list of functions under the Edit Menu and their respective keyboard 
commands where applicable:

See Also 
Recipe Menu

Keyboard Shortcuts

Commands

Command Keyboard
Undo Ctrl+Z

Redo Ctrl +Y

Copy Ctrl+C

Cut Ctrl+X

Paste Ctrl+V

Clear Ctrl+Del

Select All Recipes Ctrl+A

Copy Recipe Ctrl+C

Cut Recipe Ctrl+X

Paste Recipe Ctrl+V

Insert Blank Row Ctrl+I

Delete Row(s) Ctrl+D

Link with Ingredient  .  Ctrl+L

Shift Meal Plan Dates

Go to Meal Plan Date

Cookbook Looks
Cookbook Recipe Design



Edit User Dictionary

Once you have added a word to the User Dictionary, MasterCook remembers the word and 
considers all future appearances of the word to be correctly spelled. You will probably want to add
the proper names of recipes and the names of special ingredients to the User Dictionary. In 
addition to adding words to the User Dictionary while spell checking, you can add, delete, and edit
words in the User Dictionary by choosing Edit User Dictionary from the Tools menu. The Edit 
Dictionary dialog box appears.

A list of the words in the User Dictionary appears on the left in the dialog box. 

To add a new word to the User Dictionary, type the word in the text box above the word list 
and click the Add button.    

To delete a word from the User Dictionary, highlight the word by clicking it and then click the 
Delete key. 

To edit a word already in the User Dictionary, double-click on the word. The word appears in 
the text box above the word list. After editing the word, click the Add button. The original word 
remains in the User Dictionary until you delete it.

Importing and Exporting Word Lists
You can add as many words as you like to the User Dictionary by saving word lists or other 
documents as text files and importing them into MasterCook. This can be helpful when preparing 
entire cookbooks comprised of unusual dishes with many unique or exotic recipes and 
ingredients. Also, you may find it more convenient to view the contents of the User Dictionary as a
text file than as a scroll-menu list; by using the Export command, you can export the contents of 
the User Dictionary to a word-processing program for viewing and modification.

To import a word list to the User Dictionary:
1. Click the Import button in the Edit Dictionary dialog box.A dialog box appears, asking you to 

select a document to import to the User Dictionary. The document must have been saved as 
a text file. You can import a document of any length to the User Dictionary; remember, 
though, that every word that appears in the document will be added to the User Dictionary.

 NOTE: When you import a word list or other document, MasterCook ignores 
duplicate words and adds only new words to the User Dictionary.

2. Click the Open button; MasterCook automatically adds the new words in the document to the 
User Dictionary. 

To export the User Dictionary as a readable text file:
1. Click the Export button in the Edit Dictionary dialog box.A dialog box appears, asking you to 

select a directory (folder) and/or disk to save the document in.

2.    Type a name for your text document in the text box provided and click the Save button.After 
you've saved your User Dictionary as a text file, you can open it in a word-processing or text-
editing program for viewing or editing. After you've made any additions or changes to the 
document, you can import it back into the User Dictionary in the manner described above.



Equivalents
Cross reference of measurement units.



Exporting Recipes
To export a recipe to a text file:
1. Make sure the recipe you want to export is the current active window.

2. Choose Export Recipe from the Recipe menu or click  on the Control Bar.

A dialog box opens asking you to specify the file to which you want to export the recipe.
3. To export the recipe to a file in a different directory or on a different disk-drive, select the 
appropriate directory or folder name in the Directories list box.
4. Type a file name and then click the Export button.

The recipe is saved in the specified file. Or, if you wish to append the recipe to an existing 
export file, click on the name of the file in the list and then click Export.

To export a group of recipes to a text file:
1. In the cookbook window, select the recipes that you want to export.

2. Choose Export Selected Recipes from the Recipe menu or click  on the Control Bar.

A dialog box opens asking you to specify the file to which you want to export the recipe.
3. To export the recipes to a file in a different directory or on a different disk-drive, select the 
appropriate directory or folder name in the Directories list box.
4. Type a file name for the recipes and then click the Export button.

Or, if you wish to append the recipe to an existing export file, click on the name of the file in 
the list and then click Export.



File Menu
      

Command Control 
Bar

Description

New Cookbook... Creates a new cookbook

New Menu Creates a new menu.

New Meal Plan Creates a new meal plan.

New Shopping List Creates a new shopping list

Open Opens any MasterCook file:

cookbooks (.mcf), meal plans (.mp), menus 
(.mu), shopping lists (.sl), export files (.mxp), 
and text files (.txt).

Close Cookbook Closes the currently open cookbook

Save Saves the recipe, cookbook, shopping list, 
menu or meal plan for which you have created 
or changed

Save Cookbook As... Saves the current cookbook with a different 
name or to a different disk-drive or directory

Delete Deletes any MasterCook file

Edit Categories Retrieves the Categories dialog box so that you
can add, edit or remove categories within a 
cookbook

Import Recipes Import recipes(s) from a text file

Color Retrieves the color palette so that you can 
define or add custom colors to cookbook 
windows

Printer Setup Lets you change the current printer settings

Page Setup Allows you to specify a document's font, page 
size, margins and paper orientation. You can 
also specify the recipe design and paper type 
(3x5 card, booklets, etc.) with which you wish to
print.

Print Selected Recipes Prints currently selected recipes

Print Cookbook Prints the currently open cookbook

Exit Quits MasterCook

See Also
Commands



Find and Replace Text

With MasterCook's Find/Replace feature, you can search for occurrences of a word or phrase 
either in an entire cookbook or in selected recipes. Once you have found a word or phrase, you 
can replace either that single occurrence of the word or phrase with a replacement or every 
occurrence of that word or phrase with a replacement.

To use Find/Replace:
1. Decide whether you are going to find/replace a word or phrase in an entire cookbook or just 

selected recipes.If you are going to use find/replace for an entire cookbook, simply open the 
cookbook you wish to search. You can open the cookbook to either Book View or Category 
List.If you are going to use find/replace for selected recipes, select which recipes you wish to 
search. Select recipes the same way you select them for Spell Check.

2. Choose Find and Replace Text from the Tools menu.The Find/Replace dialog box appears.

3. In the Find text box, type the word or phrase you wish to find. If you want to change the word 
or phrase, type the replacement word or phrase in the Replace With text box.

4. Click either the Cookbook or Selected Recipes radio button.

5. Click the Options button at the right of the dialog box. The Find/Replace Options dialog box 
appears.Like Spell Check, Find/Replace gives you the option of choosing which parts of 
recipes you wish to search; click the boxes next to the recipe parts you wish to check. Select 
whether to find the whole word only, or the word when it is part of another word or phrase also
(for example, "meal" in "mealtime"): click either the Whole Word or Partial Word/Phrase radio 
button.Click the Case-sensitive box when you want MasterCook to search only for the word 
or words which match the capitalization of the text in the Find text box. For example, a case-
sensitive search for "freshwater" will not find "Freshwater."

Click OK.

6. In the Find/Replace dialog box, click the Find button.MasterCook finds the first occurrence of 
the text. The context of the word, the phrase in which the word appears, is displayed in the 
text box at the bottom of the dialog box

7. Click either the Find Next, Replace, or Replace All button.

Find Next finds the next occurrence of the text without changing the occurrence shown in 
the context box

Replace changes the single occurrence shown in the context box to the replacement text 
shown in the Replace With text box.

Replace All changes every occurrence of the text in the Find text box to the replacement 
text shown in the Replace With text box.You can change the word or phrase you wish to 
find/replace at any time by typing the new word or phrase in the Find text box. Click Done
when you are finished.        



Glossary

Use the glossary to search through the list of cooking terms to find a definition.

As you type in the cooking terms edit it will "guess" what you are looking for and display the 
selection in the list box below as well as filling in the remainder of the word in the edit.    You may 
also browse the list box to find the term you are looking for.    After you have selected a term by 
clicking on it in the list box or typing it in, the definition appears in the box to the right.

Also see:

Tools Menu



Help Menu
MasterCook's On-line Help feature provides quick, convenient access to information on using 
MasterCook.

See Also
Commands

How To



History Card
The History Card appears when viewing a cookbook in Book View.    Each time you browse 
through a cookbook in Book View, MasterCook records a list, or "history," of the recipes you have 
viewed. When you click on the tab labeled History near the top edge of the book, the History Card
appears.    

The History Card contains a list box which shows the titles of all the recipes which you have 
viewed since opening the cookbook.    View a recipe from the History menu by double-clicking on 
the name of the recipe.

Unlike the Bookmarks Card, the History Card only "remembers" the recipes from the current 
viewing session. When you close the cookbook, the History menu clears; it records a new list the 
next time you browse the cookbook in Book View.

To close this pop-up window, click the left mouse button once anywhere outside of it.
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Import Results

To view import results when you import a recipe in MasterCook:
1. Choose Import Recipes from the File menu.

The Select Recipes to Import dialog appears.

2. Click on the recipes you want to import or click the Select All button to import all of the 
recipes.

3. Click the OK button.

A dialog box temporarily appears to let you know the files are being imported. If there are no 
errors in the import files, they will be included in the cookbook.

If errors are detected, the Import Results dialog box displays the recipes that have errors.

You can double-click a recipe in the Import Recipes dialog box to view it in a recipe window.

Click the Remove button to remove an error from the dialog box or click the Clear All button to
clear the whole list of errors.

Click the Close button when you're finished viewing import results.

See Also
Window Menu



Importing Recipes
There are three ways in which you can increase your MasterCook recipe collection.

1) TYPE, or manually "enter" by keying, recipes into a MasterCook "New Recipe" window.

This method is typically used for recipes that are not currently available in electronic form. 
(I.E., they exist only on paper in cookbooks, magazines, newspapers, old recipe cards, etc.)

MasterCook's fast-fill feature significantly minimizes the number of key strokes required to 
enter a recipe's ingredients.

2) IMPORT recipes from "TEXT" files that are in a supported format.

Recipes in electronic format as "text" files are typically those that you received in e-mail 
messages, scanned in from magazines or newspapers, downloaded from the Internet, or are 
entered into another cooking program.

A recipe MUST be in a FORMAT that MasterCook recognizes before it can be"imported" 
(electronically added) to a MasterCook cookbook. (See the MasterCook Import Formats Help 
file for descriptions of acceptable formats.) Text files that are not in a supported format can 
NOT be imported.

3) ADD a complete MasterCook cookbook 

You may add a complete cookbook to your collection simply by copying the cookbook to your 
system and opening it with MasterCook. Typically you will receive or download an entire 
cookbook from the Internet (for example, from the MasterCook Web page at 
http://www.sierra.com).

These files are not text files, but rather are in "raw data" or "binary" format. A complete 
cookbook does not contain "exported" recipes, and, therefore, does not need to be 
"imported." To view the recipes, thecookbook must be opened from within MasterCook.



Importing Recipes Recieved as Attachments
Your e-mail program may not accept "attached documents"; thus you may not be able to process 
recipes that are sent this way. This is why it isadvisable to avoid using attached documents 
except on a one-to-one basis and only when you have confirmed that the recipient's system can 
accept them.    You also typically need to know if the attachment is compressed or not. (You will 
not be able to view a compressed file with an editor or word processor until you expand the file.)

An attached document is placed in the pre-defined directory or folder once it is successfully 
received by your e-mail program. You typically will want to first view the file (via an editor or word 
processor) to ensure that it is a text file that contains formatted recipes. If it does not, then you 
need to make the necessary changes to ready the recipes for importing. Once all recipes are in 
an acceptable format, you can import recipes from the file following the normal import procedures.

You may receive complete cookbooks (raw data files) as attached documents. To view the recipes
in the cookbooks, you simply need to open them from within MasterCook. Note that if you do 
receive a complete cookbook, you will not be able to view it with a text editor.

TIP: For ease of operation, you may wish to move the cookbook from the"attachment" 
directory or folder and place it in the directory or folder that contains your other cookbooks. 
Having problems finding or importing recipes in an attachment? See What Went Wrong? for 
trouble-shooting and problem solving hints. 



Importing a Picture to a Recipe Design

Importing a picture to a recipe design differs from placing a picture in a recipe, which is done in 
the Edit View of a recipe window. When you place a picture in a recipe, it appears only on the 
page for that specific recipe; this is the Recipe Picture which can be selected while working in the 
Recipe Design dialog box. 

When you import a picture to a recipe design, on the other hand, it appears in every single recipe 
in the cookbook to which the recipe design is applied. See the Cacti and Eagle recipe designs 
which come with MasterCook for examples of pictures which have been imported into recipe 
designs.

To import a picture to a recipe design
1. In the Recipe Design dialog box, open the recipe design to which you wish to add a picture.

2. Choose Insert Picture from the Recipe menu.

3. Select the picture file you wish to insert (For Windows, .BMP format only) and click the OK 
button.

The selected picture appears as the uppermost recipe element on the page. You can resize or 
reposition it thereafter as you wish.

TIPS: If you are inserting clip art into your recipe designs and your system is only capable
of displaying 256 colors, it is recommended that you index the clip art to the MasterCook 
palette to prevent ‘flashing’ or palette conflicts. If you own Photoshop you can index your 
clipart to the MasterCook palette by making sure you put the palette provided in the 
directory with your Photoshop palettes. Select Mode, Indexed, Custom, locate the palette 
and click OK. Make sure to then select any items you want to be pure white and fill them 
with white, as the MasterCook palette does not have a pure white. Change your image 
back to RGB and save it as something you will remember is a 256 color image. Then go 
into MasterCook Layouts and insert your picture. This will give you the best results with 
clipart containing large areas of flat color. 

If you own Paintshop Pro, you can index an image to the MasterCook palette by selecting
Image, Colors. When the dialog box appears, select the MasterCook Palette. Try using 
the different settings for diffusion or no diffusion to see which yields the better results. 
Remember to fill any areas that you want to be pure white (255,255,255 in the color 
dialog) other wise, the background will show up on white paper. 4



Importing and Exporting Guide
The Importing and Exporting Recipes Help files describe, in detail, how to import and export 
MasterCook recipes so that you may easily share them with others.

What's New in MasterCook 4.0

Basics of File Transfer

Types of Files

Transferring Files

Importing Recipes

        MasterCook Import Formats  

        Importing Recipes: Handling Unformatted Text Files  

        Importing Formatted Text Files  

        Importing Recipes from E-mail  

Importing Recipes Recieved as Attachments

        Importing Downloaded Recipes  

        Downloading Complete Cookbooks  

Exporting Recipes

Sharing MasterCook Recipes

        MasterCook Export Formats  

        How to Export Recipes  

        Sending Recipes via E-mail  

        Sending Recipes as an Attachment  

        Uploading Complete Cookbooks  

What Went Wrong? (Troubleshooting)

Cannot Import Recipes

        Recipes Import, but not Correctly  

        Cannot Export Recipes  

Appendices

MXP Format

        Mac Format  

        Generic Format  

        Supported Recipe Formats and Text Types  



        Import Results Window  

        Exporting from Meal Master  



Index Card
The Index Card appears when viewing a cookbook in Book View. When you click on the tab 
labeled Index near the top edge of the book, the Index Card appears.    The Index Card contains a
list box which shows the titles of all the recipes in the open cookbook.

Sorting a Cookbook's Index
When you open a cookbook in Book View for the first time, its index is sorted alphabetically, by 
recipe name; to find a particular recipe, you must scroll through the entire index until you find the 
desired recipe. To conveniently sort the index according to category or various nutritional criteria, 
first click on the Index Card tab near the top of the cookbook window. The Index Card appears. 
When you click on the narrow white box at the top of the Index Card, a sorting menu appears.    

The sorting menu gives you the choice of organizing the contents of the cookbook by Recipe 
Name [this is the default setting], Recipe Name (Indexed), Category, Calories, or by 
measurements of percent calories from Fat, Sodium, Calcium, Fiber, Carbohydrates, or Protein. 

When you choose to sort a cookbook's index according to:
Recipe Name (Indexed) - MasterCook creates an alphabetical list of the first letters of the 
recipes in the cookbook. The first letters are displayed on the Index Card. Double-clicking a 
first letter displays a list of the recipes with that first letter.

Category - the Index Card displays an alphabetical list of the categories of dishes in that 
cookbook. While some categories are common to many cookbooks, like "Breads" and 
"Beverages," there are other categories which are unique to certain cookbooks, like "Taste of 
New Orleans" in the Cooking Light cookbook, or "Chino-Latino" in the Mission Cafe 
cookbook. Double-clicking a category name displays a list of recipes in that category.

Nutritional Information - MasterCook groups the recipes in sets which correspond to certain 
nutritional ranges. For example, when you choose to sort an index by Calories, recipes are 
grouped in sets like "less than 100 calories," "100 to 199 calories," and so forth. When you 
sort by Percent Calories from Fat, the sets are grouped by the percentage of fat in each one 
of the recipes, such as "From 10 to 15." When you sort by Sodium or Calcium, the sets are 
grouped by the number of milligrams of each mineral in each recipe; when you sort by Fiber, 
Carbohydrates, or Protein, the sets are grouped by the number of grams of each nutrient in 
each recipe.

When you custom-sort the index of a cookbook in Book View, you also change the order of the 
recipes in the cookbook; when you page through the cookbook using the page-turning icon, the 
recipes will appear in the order of whatever sorting method you have chosen. You can also 
observe the rearrangement of recipes by pointing at edgetabs.



Ingredients
Finding and Viewing Ingredient Information

with Ingredients List command

from a recipe window

Adding an Ingredient to the Ingredients List

Editing Ingredient Information
editing an ingredient

copying/renaming an ingredient

removing an ingredient from the Ingredients List

Creating a Nutritional Link

Removing a Nutritional Link

To find and view ingredient information with the Ingredients List command:
1. Choose Ingredients List from the Tools menu.

2. In the Ingredients List dialog box, type the first few letters of the ingredient you want to view.

MasterCook's fast-fill feature will scroll to the ingredient most like the letters you type.

3. Click the Edit button to view the ingredient's information.

4. Click Close to exit the dialog box.

To find and view ingredient information from a recipe window:
1. From a recipe window in Edit view, highlight the name of the ingredient or click the ingredient 

row for which you want to view information.

2. Choose Ingredient Analysis from the Tools menu, which opens the Ingredient Analysis dialog 
box.

3. Click Close to exit the dialog box.

To add an ingredient to the Ingredients List:
1. Choose Ingredients List from the Tools menu.

2. In the Ingredients List dialog box, click the New button.

3. Type the name of the food item in the Ingredient Name text box.

4. Enter the weight, volume amount, cost, store location and nutritional information in the 
appropriate text boxes.

5. If you choose to enter data in the Food Exchanges boxes, enter them as a decimal. 

If you do enter the exchanges as a fraction, MasterCook will convert the number to a decimal.

For example, a Food Exchange of 1 1/2 will be saved as 1.5.

6. When you're finished, click the Save button.

To edit an ingredient:



1. Choose Ingredients List from the Tools menu.

2. In the text box above the ingredients box, type the first few letters of the ingredient you want 
to edit.

3. Click the Edit button.

4. Make the changes to the ingredient's information.

5. Click the Save button.

To copy/rename an ingredient:
1. Choose Ingredients List from the Tools menu.

2. In the text box above the ingredients box, type the first few letters of the ingredient you want 
to copy or rename.

3. Click the Edit button.

4. Give the item a new name.

5. Change ingredient information if you want.

6. Click the Copy button.

To remove an ingredient from the Ingredients List:
1. Choose Ingredients List from the Tools menu.

2. In the text box above the ingredients box, type the first few letters of the ingredient you want 
to copy or rename.

3. Click the Remove button.

4. Click Yes to confirm the deletion.

To create a nutritional link for an ingredient:
1. Make sure the open recipe is displayed in Edit View. In the recipe's Ingredient column, click 

on the name of the ingredient for which you want to create a nutritional link.

2. Choose Link With Ingredient from the Edit menu.

3. Type the name of the food item with which you want to link the ingredient, or click on its name
in the list.

4. Click the Link button.

To remove a nutritional link:
1. Select the ingredient name and choose Link with Ingredient from the Edit menu.

2. Press the BACKSPACE or DELETE key.

3. Click the Link button.

See Also
Edit Menu

Tools Menu



Ingredients List
A list of food items for which MasterCook maintains nutritional, store location and price 
information. This Ingredients List appears in a drop-down list in the recipe window. By choosing 
from this list, you provide MasterCook with the ingredient information that it uses to create 
accurate nutritional profiles, shopping lists and cost analyses.

See Also
Tools Menu

Ingredients
To close this pop-up window, click the left mouse button once anywhere outside of it.



Insertion Point
The flashing vertical bar that appears in a text area to mark the place where text will appear when
you type. As you type, characters always appear to the left of the insertion point. You place the 
insertion point by using the I-beam cursor.

To close this pop-up window, click the left mouse button once anywhere outside of it.



Link
A nutritional link between a user-defined ingredient name and an ingredient name on the 
MasterCook Ingredients List, essentially equating the two ingredients. By linking an unknown, 
user-defined ingredient name with an ingredient on the MasterCook Ingredients List, you define 
the nutritional makeup of the unknown ingredient.

See Also
Ingredients

Edit Menu
To close this pop-up window, click the left mouse button once anywhere outside of it.



List Box
A rectangle within a Windows dialog box containing a list of choices from which you can select a 
single item or a group of items with which    to complete some task. You can scroll through the list 
by clicking on its scroll bar or by using the DIRECTION ARROW keys.

To close this pop-up window, click the left mouse button once anywhere outside of it.



Lookup
To use this command from the Tools menu, first select a word or phrase from a recipe while 
viewing it in Edit View.    Then choose Lookup from the Tools menu.    MasterCook searches its 
files for any relevant references to the word or phrase and displays them accordingly. Such 
references may appear as a part of an ingredients list, Utensils, or Video Tips.



MXP Format

Following is the description of the MXP import/export format. This format uses a combination of 
spaces and keywords rather than tabs as recipe section and field delimiters. If you are planning 
on exchanging recipes via the Internet, this is the format you should use. All MasterCook users, 
regardless of the version they use, will be able to import recipes in this format.

NOTE: The MXP format is position/column dependent ONLY in MasterCook II and 
MasterCook Mac. That is, field position is very specific and they MUST adhere to the format 
EXACTLY as it is shown below.

The Recipe Translator in MasterCook 3.0 and 4.0, does NOT require that fields begin in specific 
columns. The removal of this position dependency introduces great flexibility and eliminates many
possible import errors. Consequently, it is very easy to create a "template" of keywords for this 
format and simply insert the recipe sections where appropriate.

NOTE: In MasterCook 4.0, ingredient lines consisting only of spaces (or tabs) WILL be 
imported and kept in the ingredient section. In prior releases, lines with only spaces (or tabs) 
are stripped during import,so to maintain ingredient separators, you must use at least one 
displayable character in all versions except v4.0.

(Instructional comments appear within brackets, "[ ]",    below a line andare NOT part of the 
format. All lines are REQUIRED unless the commentsindicate otherwise.)

------------------------------------------

                                            *    Exported from    MasterCook    *                                                    

BLANK Line    [Optional and there may be more than one blank line]    

Recipe Title

BLANK Line[Optional]

Recipe By          : name    [Keywords "Recipe By:" are required]

Serving Size    : number        Preparation Time :hours:minutes    [Keywords "Serving Size" and 
"Preparation Time" are required; this line is optional]

Categories        : category1                        category2                              category3    [Keyword 
"Categories:" is required; there may be 10 categories]      these lines are optional

BLANK LINE    [Optional]

Amount              Measure                                    Ingredient -- Preparation Method

-----------------    ------------------------------    --------------------------------

    amt                          unit                                                  ingredient -- preparation method 

[You may repeat this line up to 100 times;there must be NO blank lines      between ingredients.]

BLANK Line [Must be blank and cannot contain spaces or non-display characters]

Directions. Free form text. Blank lines may exist in this section.

BLANK Line [Optional]                                      

- - - - - - - - - - - - - - - - - -      

[Optional End-of-Directions delimiter. This serves as        End-of-Recipe when you do not use 
"Notes" and "Serving Ideas"]

Serving Ideas : text    [Optional]

NOTES : text    [Optional]



_____ 

[Optional End-of-Recipe delimiter]

------------------------------------------

NOTE: The MXP format delimiter to separate ingredient and preparation method is: "space 2 
dashes space" :      1 cup carrots -- chopped 



Introduction to MasterCook
The MasterCook Environment consists of the menu bar, Control Bar, Cookbook window(s), 
Recipe Clipboard, menus, meal plans and shopping lists.

See Also
Commands

How To



MasterCook Environment
When you start MasterCook and open a cookbook, you're working in the MasterCook application 
program environment. In addition to the menu bar and the cookbook window, the MasterCook 
environment contains a variety of other types of windows that let you perform different tasks.

See Also
MasterCook Environment

To close this pop-up window, click the left mouse button once anywhere outside of it.



Meal Plans
MasterCook's Meal Plan feature lets you plan up to four separate meals a day, allowing you to 
plan your family's shopping and nutritional intake weeks or months in advance.

Creating a New Meal Plan

Saving the Current Meal Plan

Opening An Existing Meal Plan

Editing an Existing Meal Plan

Creating a Cost Analysis for a Meal Plan

Creating a Nutritional Analysis for a Meal Plan

Creating a Shopping List for a Meal Plan

Shift Meal Plan Date

Go To Meal Plan Date

Printing a Meal Plan

To create a new meal plan:

1. Choose New Meal Plan from the File Menu or click  from the Control Bar. An empty meal
plan calendar window appears for the current month.

2. Click on the day in the calendar for which you wish to plan meals.
The day box appears highlighted. Click the box in the upper left corner to choose the meal to 

which you want to add items.
3. To expand the size of the day box into its own window, double-click on the date in the upper-left 
corner of the day box.
4. Click in the Serves text field to type the number of people you want the meal to serve.
5. Press TAB or ENTER to move to the first item row and then type the name of the first recipe or 
food item that you want to add to the meal.

The recipe or food item appears in the day window. An icon is displayed to the right of the text
you typed, describing the entry type: recipe (recipe card icon), menu (menu card icon), 
ingredient (measuring cup icon) or text ("T").

If you enter an ingredient, click on the measuring cup icon to display the ingredient amount 
dialog box. Enter the amount and unit, then select the per serving or per meal radio button.

6. Press TAB or ENTER to accept the highlighted recipe or food item.

7. Continue in this manner to add additional recipes and food items.

8. When you're finished, click the meal window's Control menu and choose Close, click the meal
window's Control menu, or click anywhere on the screen outside the meal window.

NOTE: You can also add recipes to meals by dragging them from a cookbook window opened to 
Category List onto the date in the upper-left corner of the day box. A drop-down menu 
appears, listing the day's meal. Drag onto the appropriate meal to "drop" the selected recipes 
on it.

To save the current meal plan:
1. Choose Save Meal Plan from the File menu.

2. In the dialog box, select a new directory (optional) and then type a name for the new meal 
plan.



3. Click the Save button.

To open an existing meal plan:

1. Choose Open form the File menu or click  from the Control Bar.

Meal plan files have the .mp extensions.
2. In the dialog box, select the meal plan you want to open. 

3. Click on the Open button.

To edit an existing meal plan:

1. Click  from the Control Bar.

2. Choose the meal plan you want to edit from the dialog box.
3. Make your changes to the meal plan.    See creating meal plans for more information.

4. Save your changes by choosing Save Meal Plan from the File menu.

To create a cost analysis for a meal plan:
1. With the meal plan open, click the day in the calendar for which you want to create a cost 

analysis.
2. Choose Cost Analysis from the Tools menu.

3. In the Cost Analysis dialog box, click one of the radio buttons for breakfast, lunch, dinner or 
snack to view a cost for a particular day -- or click Full Day to see the cost for the entire day.

4. To see the cost of meals for another day, click the Next Day or Previous Day button.

5. When you're finished, click the Close button to close the dialog box.

To create a nutritional analysis for a meal plan:
1. With a meal plan open, select the day you wish to analyze by clicking the day in the calendar.

The day you clicked is highlighted.

2. Choose Nutritional Analysis from the Tools menu or click  on the Control Bar.

The Nutrition dialog box opens, displaying the recipes in the meal plan and a per-serving analysis
of the selected day.
3. Click the appropriate radio button for Breakfast, Lunch, Dinner, Snack or Full Day to see the 
dietary intake for the entire day.
4. Click the Daily Values button to see the nutritional information displayed as USDA/FDA Daily 
Values.
5. To print a copy of the nutritional analysis, click the Print button.
6. To see an analysis of other days in the meal plan, page through the meal plan clicking    either the
Next Day or Previous Day buttons.

7. When you're finished, click the Close button.

To create a shopping list for a meal plan:
1. With the meal plan open, choose Make Shopping List from the Shopping List menu or 

click  on the Control Bar.

A dialog box is displayed asking whether you want a shopping list for the selected day or the 



entire meal plan.
2. Click one of the radio buttons to choose whether you want a shopping list for the selected day or 
for the entire meal plan, and then click OK.

3. To save the shopping list, choose Save Shopping List from the file menu, type a name for 
your shopping list and then click the Save button.

To shift a meal plan date:
1. If you haven't done so, open an existing Meal Plan by choosing Open (Ctrl+O) from the File 

menu or clicking  on theControl Bar.

The Open dialog box appears.
2. If necessary, change the directory or disk drive, select the specific meal plan file (.mp extension) 
and click the Open button.
3. Choose Shift Meal Plan Dates from the Edit menu.

The Shift Meal Plan Dates dialog box opens.
4. Use the up or down arrow buttons beside the field you want to increment or decrement: Year, 
Month, Week and Day.

You can set one or more fields to create a new date range.    The current and new date ranges 
are displayed at the top of the dialog box.
5. When you have shifted the dates, click the Change Dates button.

Use the left or right arrow buttons at the top of the meal plan window to view the new date on 
which you assigned the meal plan.

To go to a meal plan date:
1. If you haven't done so, open an existing Meal Plan by choosing Open (Ctrl+O) from the File 

menu or clicking on    Control Bar.

The Open dialog box appears.

2. If necessary, change the directory or disk drive, select the specific meal plan file (.mp 
extension) and click the Open button.

3. Choose Go to Meal Plan Date from the Edit menu.

The Go to Meal Plan Date dialog box opens.

4. Use the up or down arrow buttons beside the field you want to increment or decrement: Year, 
Month, Week and Day.

You can change one or more fields to set a new date.    The current date and new date are 
displayed at the top of the dialog box.

5. When you have selected a new date to view, click the Go to Date button.

Use the left or right arrow buttons at the top of the meal plan window to view the new date.

To print a meal plan:

1. If the meal plan isn't already open, choose Open from the File menu or click  on the 
Control Bar.

The Open dialog box appears.
2. Choose the meal plan you want to open (.mp extension) and click the Open button.

3. Click  on the Control Bar or choose Print Meal Plan from the File menu.
Select your print options in the Meal Plan Print Options dialog box.

4. When you're ready to print, click the OK button.





Meal Plan
MasterCook's Meal Plan feature lets you plan up to four separate meals a day, allowing you to 
plan your family's shopping and nutritional intake weeks or months in advance.

See Also
Meal Plans

To close this pop-up window, click the left mouse button once anywhere outside of it.



Menus
MasterCook allows you to create single-meal menus, which are helpful when you're planning a 
meal for a special occasion.

Creating a Single-Meal Menu

Saving a Menu

Opening an Existing Menu

Editing a Menu

Creating a Cost Analysis for a Menu

Creating Nutritional Analysis for a Menu

Creating a Shopping List for a Menu

Printing Menus

To create a new single-meal menu:

1. Choose New Menu from the File Menu, or click  on the Control Bar.

2. Type a name for the menu and press TAB.
3. Type, in the Serves text box, the number of people you want the menu to serve.
4. Press TAB or ENTER to move to the first item row and type the name of the first recipe or food 
item that you want to add to the menu. Use MasterCook's fast-fill feature to add a recipe by typing the first
few letters in the recipe title.
5. Press TAB or ENTER to accept the highlighted recipe or food item.

The recipe or food item appears in the menu window. An icon is displayed to the right of the text 
you typed, describing the entry type: recipe (recipe card icon), ingredient (measuring cup icon) or text 
("T").

If you enter an ingredient, click on the measuring cup icon to display the ingredient amount dialog
box. Enter the amount and unit, then select the per serving or per meal radio button.

6. Continue adding recipes, food items and descriptive text in this manner; press TAB or ENTER
after each item.

7. To add recipes from a cookbook to a menu using drag and drop, first make sure the cookbook
is opened to Category List. Then click on the recipes you want to add to the menu and, while 
holding down the mouse button, drag them onto the menu window.

To save a menu:
1. Choose Save Menu from the File menu.

2. In the dialog box, select a new directory (optional) and then type a name for the new menu.

3. Click the Save button.

To open an existing menu:

1. Choose Open from the File menu or click  from the Control Bar.

2. In the dialog box, select the menu you want to open and click the Open button.
Menu files have the .mu extensions.

To edit an existing menu:



1. Click  from the Control Bar.

2. Choose the menu you want to edit from the dialog box and click the Open button.
3. Make your changes to the menu.

See creating menus for more information.
4. Save your changes by choosing Save Menu from the File menu.

To create a cost analysis for a menu:
1. With a menu open, choose Cost Analysis from the Tools menu .

The cost analysis dialog box appears and displays a list of recipes in your menu along with a 
total cost per serving.

2. Click the OK button when you're done with the cost analysis.

To create a nutritional analysis for a menu:

1. With a menu open, choose Nutritional Analysis from the Tools menu or click  on the 
Control Bar.

2, Click the Daily Values button to view the menu's daily values.
3. Click the Print button to print a copy of the nutritional analysis.

4. When you're finished, click the Close button.

To create a shopping list for a menu:

1. With the menu open, choose Make Shopping List from the Shopping List menu or click  
on the Control Bar.

A shopping list appears with a list of food items from your menu.
2. If you want to save the shopping list, choose Save Shopping List from the File menu, type a name
for the new shopping list and click the Save button.

3. When you're finished, click the Close button.

To print a menu:

1. If the menu isn't already open, choose Open from the File menu or click  on the Control 
Bar.

The Open dialog box appears.
2. Choose the menu you want to open (.mu extension) and click the Open button.

3. Click  on the Control Bar or choose Print Menu from the File menu.
Select your print options in the Menu Print Options dialog box.

4. When you're ready to print, click the OK button.

See Also
File Menu



New Recipes
Creating a New Recipe

Entering Basic Recipe Information

Specifying Recipe Categories

Entering Recipe Ingredients

Entering Recipe Directions

Entering Recipe Options

To create, name and save a new recipe:

1. Choose New Recipe from the Recipe menu or click  from the Control Bar.

A new recipe window appears and is temporarily name "New Recipe 1."
2. Type the name of the recipe in the Recipe Name text box.
3. Click the Save button.

The recipe is saved on disk as part of the current cookbook. The recipe's name is added in 
the cookbook window to each category to which you assign it, and its name appears in the 
recipe window's title bar.

To enter basic recipe information:
1. In the newly created recipe window, press TAB to move to the Recipe By text box and type 

the name of the author.

2. Press TAB to move to the Prep Time text box and type, in hours and minutes, the amount of 
time required to prepare the recipe.

3. Press TAB to move to the Serves text box and type the number of servings the recipe makes.

Remember to use a colon to separate the hours and minutes.

To specify categories for a recipe:
1. Click the Categories tab or press ALT-C to display the names of all the categories in the 

current cookbook.

2. Click the check box beside each appropriate category name.

You can choose up to 10 categories for any one recipe. In the cookbook window, MasterCook
will display the recipe's name under each category you assign it.

To enter ingredients for a recipe:
The area below the recipe name and author is where you'll enter the recipe's ingredients.

1. Press TAB to move to the Amount column and type the amount of the ingredient.

You can type either decimal or fractional amounts.

2. Press TAB to move to the Unit column and type a measurement unit.

As you begin typing, MasterCook's fast-fill feature scrolls to the name most like the letters 
you're typing.

3. Press TAB to move to the Ingredient column and type the name of the ingredient.



If the fast-fill ingredient is not the one you're looking for, click another one on the list or 
continue typing an ingredient name not on the list.

4. Press TAB to move to the Preparation Method column and type any relevant information 
about how the ingredient should be prepared prior to cooking.

To enter recipe directions:
1. Click the Directions tab or press ALT-D to display the Directions text box.

2. Type the recipe's directions as you would in a word processor.

You can type up to 10,000 characters' worth of directions.

To recipe options (Suggested Wine, Serving Ideas, Notes):
1. Press TAB to move to the Suggested Wine text box and then type a wine suggestion.

2. Press TAB to move to the Serving Ideas text box and type the serving ideas such as other 
foods or recipes to serve with the recipe.

3. Click the Notes tab (or press ALT+N) to open the Notes text area and type your notes.

4. When you're finished, save the recipe by clicking the Save button.



Non-contiguous Selection
You can select various items throughout a list by holding the CTRL key and clicking on each item 
with your mouse.

See Also
Contiguous Selection

To close this pop-up window, click the left mouse button once anywhere outside of it.



Page Setup

This command takes you to the Page Setup dialog box, where you choose options for printing 
recipes and cookbooks.

When you are printing individual recipes or groups of selected recipes from MasterCook, you 
need to make three decisions: which recipe(s) to print, which recipe design to apply to the printed 
recipe(s), and which paper and layout to use. It might be helpful, though not necessary, to have a 
basic understanding of recipe design before printing recipes--you can make the same changes to 
recipes before they are printed as you can in the Recipe Design Editor (see Cookbook Recipe 
Design for more information on recipe design).

To print a single recipe or a group of recipes:
1. Select the recipe(s) you wish to print.If you are viewing a cookbook as a Category List, you 

can either open the recipe you wish to print or select a group of recipes from the right side of 
the cookbook window.If you are in Book View of a cookbook window, you can open the 
cookbook to the page which contains the recipe you wish to print. You can also select a group
of recipes to print from the Index, Bookmarks, or History Card.

2. Choose Page Setup from the File menu.

The Page Setup dialog box opens. 

3. Select a recipe design to apply to the printed recipes.

You can choose a recipe design from the list of recipe designs on the Design menu at the top 
of the Page Setup dialog box. You can also use all of the same commands available in the 
Recipe Design dialog box to modify any recipe design. If you modify a recipe design in the 
Page Setup dialog box you can save it just as you would with the Recipe Design Editor; the 
saved recipe design will appear on the Design menu for application to other recipes. For 
detailed information on how to use the recipe design commands available in the Page Setup 
dialog box, see Cookbook Recipe Design.

4. Select the type of layout you wish to apply to the selected paper from the Layout 
menu.MasterCook allows you to print recipes in a variety of layouts: Single sided, Double 
sided, Folded Booklet, and Book.    When you apply a layout in the Print Settings dialog box, 
MasterCook reformats the displayed recipe in the selected layout., which allows you to see 
exactly how the recipe will look when printed. (See pages 141-143 of the User's Guide for 
examples of the different available layouts.)

5. Make your selections from the Start Recipes, Columns, and Scale Text submenus found in 
the Layout menu.

These features of MasterCook allow you to print several recipes on one page, in as many 
columns as you wish; also, you can scale the text of the printed recipes to any percentage of 
the text's original size. These features are best learned through experimentation--remember, 
none of the changes you make to the Page Setup are permanent until you save them as a 
new Recipe Design.

Start Recipes--when you choose One After Another from this submenu, MasterCook prints 
the selected recipes directly after each other, starting the top of each recipe directly after the 
bottom of the preceding recipe on the same page. When you choose On Next Page, each 
recipe starts at the top of a new page. When you choose On Next Column, each recipe is 
printed in the space of the next available column.    When you choose On Next Row, each 
recipe is printed in the space of the next available row.    

Columns--this Columns submenu is different from the Columns submenu under the 
Properties menu (see Cookbook Recipe Design for more information). When you choose a 
number of columns from this submenu, MasterCook prints the recipes in this number of 



columns on the page.

Scale Text--use this feature to scale the text of your recipes to any percentage of its original 
size. This feature can be particularly useful when printing in extremely small areas, such as 
index cards or multiple columns.

6. Click the Change button in the lower right hand corner of the Print Settings dialog box.When 
you click Change, you define the way the currently selected recipe(s) will be printed. 
However, these new settings are not permanent unless you save them as a new Recipe 
Design. To save your settings as a new Recipe Design, choose Save Recipe Design from the 
File menu. You will be asked to choose a file or folder in which to save the new Recipe 
Design, as well as its name. When you name a new Recipe Design, its name is added to the 
Design menu which appears in both the Recipe Design Editor and Print Settings dialog 
boxes.

7. Choose Print Selected Recipes from the File menu.The selected recipes are printed.    

Printing a Cookbook
Printing a cookbook is similar in nearly every way to printing selected recipes, but there are a few 
additional factors you may want to consider before printing an entire cookbook. For example, 
besides making the same choices in the Print Settings dialog box as you do when printing 
selected recipes, you need to decide how you want the cookbook indexed--see Index Card for 
information on indexing a cookbook according to various criteria. Also, remember that a cookbook
is a long document; the layout and size of the selected paper can have a dramatic impact on the 
amount of paper used when printing hundreds of recipes. Printing a cookbook takes a few 
moments of planning, but MasterCook gives you all the tools you need to produce a cookbook as 
uniquely individual as your own kitchen.

To print a cookbook:
1. Open the cookbook you wish to print.

2. Make sure the cookbook is indexed according to the desired criteria.

3. Choose Page Setup from the File menu. The Page Setup dialog box opens. Here you will 
make all the same choices affecting the printing of the cookbook as you would for printing 
selected recipes. When you have modified the Print Settings to your specifications, click the 
Change button.

4. Choose Print Cookbook from the File menu.

The cookbook is printed.



Preferences
To set MasterCook preferences:
1. Choose Preferences from the Tools menu.

2. Click the radio button to choose whether to open recipes in Page View (default) or Edit View.

3. Click the radio button for the measurement system you want to use.

4. Click the appropriate radio button to choose whether to display ingredient amounts as 
Common Fractions (default) or Decimals.

5. Click the appropriate check boxes for the edit and display options.

6. When you're finished, click the OK button.

See Also
Tools Menu



Radio Buttons
Small buttons in a Windows dialog box that are used to prompt a user to choose only one option 
from a group of options. They work like buttons on a car radio, allowing you to make only one 
selection at a time.

To close this pop-up window, click the left mouse button once anywhere outside of it.



Recipe Clipboard
The Recipe Clipboard lets you group together recipes from one or more cookbooks.    You can 
add recipes to the Recipe Clipboard (and remove recipes from it) one at a time or in groups. Use 
the Recipe Clipboard when you want to combine recipes from different cookbooks into a new 
cookbook or when you want a temporary storage place for recipes that you may want to browse.

See Also

Recipes
To close this pop-up window, click the left mouse button once anywhere outside of it.



Recipe Menu
The Recipe menu contains commands that apply to individual recipes. These commands help 
you create new recipes and obtain information from existing ones.

New Recipe... Creates a new recipe in the current cookbook

Open Recipe... Opens a recipe in the current cookbook

Open Selected Recipes Opens recipes selected from a Category List or from 
the Index, Bookmarks, and History Cards in Book 
View.

Add to Recipe Clipboard Adds selected recipes to the Recipe Clipboard

Save Recipe As... Saves the current recipe with a different name

Save As Ingredient... Saves the current recipe as an ingredient in the 
Ingredients List

Delete Current Recipe Removes the current recipe from a cookbook (only 
available in Book View)

Selected Recipes Removes the currently selected recipes

Export Recipe/Selected Recipes... Saves the current recipe or group of recipes as a 
text file

Mail Recipes... Allows you to e-mail a recipe or group of recipes if 
you have a direct connection to the Internet

Categorize... Lets you assign recipes to cookbook categories

Scale Recipe... Changes the serving size of the current recipe from 
the original serving amount to any new whole 
number, automatically adjusting ingredient amounts 
and measurement units

Change Units... Changes measurement units for the current recipe, 
providing English-to-Metric and/or volume-to-weight 
equivalents

Insert Picture... Allows you to insert high-resolution pictures and 
graphics to your recipes

Remove Picture... Lets you remove pictures and graphics from recipes

Search Recipes... Lets you look for recipes in one or more cookbooks 
that match almost any criteria you can think of -- 
such as ingredients, categories, recipe name, source
of recipe, preparation time, cost per serving, and a 
variety of nutrition criteria

See Also
Commands



Recipes
Assigning Categories to a Recipe

Changing a Recipe's Measurement Units

Choosing a Recipe Design

Creating a Cost Analysis

for a single recipe

for a group of recipes

Creating a Nutritional Analysis

for a single recipe

for a group of recipes

Deleting Recipes

Duplicating Recipes

Editing Recipes

E-Mailing Recipes

Exporting Recipes

Inserting Pictures into Recipes

Opening Recipes

Printing Recipes

Removing Pictures from Recipes

Renaming Recipes

Saving a Recipe as an Ingredient

Scaling Recipes

Searching for Recipes

Viewing Recipes

To assign categories to a recipe:
1. Select the recipe in the cookbook window to which you wish to assign categories.

2. Select Categorize from the Recipe menu or press ALT-C.

The Edit Categories dialog box appears.

3. Click the check box beside each category you want to assign to the recipe.

You can assign up to 10 categories for each recipe.

4. Click the Save button to save these changes.

To change a recipe's measurement units:
1. Open the recipe you wish to change.

2. Choose Change Units from the Recipe menu.

The Change Units dialog box appears.



3. To change the measurement unit for a single ingredient, click on the ingredient in the list box 
on the left to select it.

4. Click on the new measurement unit (in the Change To list box) that you wish to use.

5. To change all ingredients in the recipe to one measurement system (Metric or American), 
click either the Change All to American or Change All to Metric button.

6. Click the Change Units button.

To create a cost analysis for a recipe:
1. Open the recipe for which you want a cost analysis.

2. Choose Cost Analysis form the Tools menu.

A dialog box appears, displaying the name of the recipe, the number of servings it makes and
the cost per serving.

3. Click the Close button when you're finished with the cost analysis.

To create a cost analysis for a group of recipes:
1. Click on the cookbook window (or Recipe Clipboard) to make it active.

2. Click on the recipes for which you want to create a cost analysis.

3. Choose Cost Analysis from the Tools menu.

A dialog box appears, displaying the names of the selected recipes, the number of servings 
each recipe makes, and the cost per total serving of the combined recipes.

4. Click the Close button when you're finished with the cost analysis.

To create a nutritional analysis of a recipe:
1. Make the recipe for which you want to create a nutritional analysis the current active window.

2. Choose Nutritional Analysis from the Tools menu or click  on the Control Bar.

The Nutrition dialog box is displayed with the nutritional analysis of the current recipe.
3. Click the Daily Values button to view the daily values for the recipe.

Click the Close button when you're done viewing the daily values.
4. To print a copy of the nutritional analysis, click the Print button.

5. When you're finished, click the Close button to close the dialog box.

To create a nutritional analysis of a group of recipes:
1. Make the cookbook window the current active window.

2. Click on the recipes for which you want to create a nutritional analysis.

3. Choose Nutritional Analysis from the Tools menu or click  on the Control Bar.

The Nutrition dialog box is displayed with the total per-serving nutritional analysis for the 
combined recipes.
4. Click the Daily Values button to view the daily values.

Click the Close button when you're done viewing the daily values.
5. To print a copy of the nutritional analysis, click the Print button.

6. When you're finished, click the Close button to close the dialog box.

To delete a recipe:



1. Open the recipe you want to delete.

2. Choose Delete Selected Recipe(s) from the Recipe menu.

3. Click Yes in the dialog box to confirm the deletion.

The recipe is permanently removed from the cookbook and cannot be restored with the Undo 
command; use this feature with caution.

To duplicate a recipe:
1. Open the recipe you want to duplicate.

2. Choose Save Recipe As from the Recipe menu.

3. Type a new name for the recipe in the dialog box and then click the OK button.

A copy of the recipe is saved with its new name to the current cookbook.

To edit a recipe:
1. Open the recipe from the cookbook window or locate it using the Open Recipe or Search 

Recipes commands.

2. If the recipe is displayed in Page View, click the Edit button.

3. Make your changes to the recipe.    See Creating a New Recipe for more information.

4. Click the Save button to save your changes.

To export a recipe to a text file:
1. Make sure the recipe you want to export is the current active window.

2. Choose Export Recipe from the Recipe menu or click  on the Control Bar.

A dialog box opens asking you to specify the file to which you want to export the recipe.
3. To export the recipe to a file in a different directory or on a different disk-drive, select the 
appropriate directory or folder name in the Directories list box.
4. Type a file name and then click the Export button.

The recipe is saved in the specified file. Or, if you wish to append the recipe to an existing 
export file, click on the name of the file in the list and then click Export.

To export a group of recipes to a text file:
1. In the cookbook window, select the recipes that you want to export.

2. Choose Export Selected Recipes from the Recipe menu or click  on the Control Bar.

A dialog box opens asking you to specify the file to which you want to export the recipe.
3. To export the recipes to a file in a different directory or on a different disk-drive, select the 
appropriate directory or folder name in the Directories list box.
4. Type a file name for the recipes and then click the Export button.

Or, if you wish to append the recipe to an existing export file, click on the name of the file in 
the list and then click Export.

To e-mail a recipe:
1. With a cookbook open, select the name(s) of the recipe(s) you wish to e-mail.

2. Choose Mail Recipes from the Recipe menu.



The Recipe Mailer window opens, containing a list of recipes to be sent. You can then drag 
more recipes into the recipe list in the Recipe Mailer from the cookbook window.

3. If you haven't already done so, click the Setup button. 

Enter the necessary information in the Mail Setup dialog box: your name, e-mail address and 
e-mail server's name. Click OK to save these settings.

If you don't know your server name, contact your Internet provider.

4. In the From text box, type your name or click the From button to choose from your list of e-
mail names.

5. In the To text box, type the Internet e-mail addresses to which you want to send the selected 
recipe(s); press RETURN after each address.

6. In the Subject text box, type a subject.

7. Type a comment or message in the Message text box.

NOTE: You can keep lists for names, subjects, messages and recipes by entering the text in 
the field and then clicking its button to display the Pick From List dialog. The following
dialog appears when you click the From button. To add the name you just typed into 
the From text box, click the Add button in the dialog box.

8. Click the Send button to send the e-mail message.

To insert a picture into a recipe:
1. Open the recipe to which you want to add a picture.

2. Choose Insert Picture from the Recipe menu.

3. Select the picture file you wish to insert (Windows .BMP format only) and click the OK button.

4. Choose the display option from the dialog box that suits your needs and click the OK button.

To open a recipe:
1. Choose Open Recipe from the Recipe menu.

A dialog box appears, displaying a list of all of the recipes for the current cookbook. Click on 
the Include Unopened Cookbooks check box if you want to view these recipes.

2. Select the recipe you want to open and then click the Open button.



To open a recipe from a cookbook window:
1. In the cookbook window, click on the names of the categories containing the recipes you want

to open.

2. In the recipes list on the right, click on the names of the recipes you want to open.

3. Click the Open button or choose Open Selected Recipes from the Recipe menu..

To open a recipe with the Open Recipe command:

1. Choose Open Recipe from the Recipe menu or click  on the Control Bar. The Open 
Recipe dialog box appears.

2. In the text box above the Recipes list, type the name of the recipe you want to open.
3. Click the Open button.

To print a recipe:
1. Open the recipe that you want to print or select a group of recipes in the cookbook window.

2. Choose Print Selected Recipes from the File menu or click  on the Control Bar.

3. Select the options with which to print in the Print Recipe dialog box.
4. Click the Setup button.

The Page Setup dialog box appears. Here you can change the font, size and color; specify a 
page size and paper type; and choose a recipe design from the existing templates.

5. Click the OK button when you're ready to print.

To print selected recipes:
1. From the Cookbook window or the Recipe Clipboard, select the recipes you want to print.

2. Choose Print Selected Recipes from the File menu.

The Print Selected Recipes dialog box appears.

3. Choose the print options.

4. Click the Setup button.

The Page Setup dialog box appears. Here you can change the font, size and color; specify a 
page size and paper type; and choose a recipe design from the existing templates.

5. Click the OK button when you're ready to print.

To remove a picture from a recipe:
With the recipe open, choose Remove Picture from the Recipe menu.

To rename a recipe:
1. Open the recipe you want to rename.

2. Type a new name for the recipe in the Recipe Name text box.

3. Click the Save button to save the recipe with its new name.

To save a recipe as an ingredient:
1. Open the recipe you want to save as an ingredient.



2. Choose Save as Ingredient from the Recipe menu.

The recipe and all of its nutritional information is saved as an ingredient in the Ingredients 
List. You can now use it as an ingredient in your recipes. The recipe is saved on disk in the 
user ingredients file, "USER.ING."

To scale a recipe:
1. Make sure that the recipe you want to scale is the current active window.

2. Choose Scale Recipe from the Recipe menu or click  on the Control Bar.

A dialog box appears, asking you to enter a new number of servings.
3. Type the new serving size and click the OK button.

The ingredient amounts and measurement units are adjusted to accommodate the new 
number of servings.

To scale a picture in a recipe:
1. Open the recipe in which you want to scale a picture.

2. Choose Scale Picture from the Recipe menu. 

The Picture Scaling Options dialog opens.

3. Select the scaling option:    Original Size, Scale to Page, Use Screen Resolution or Custom, 
which lets you specify a size as a percentage of the original picture size.

4. Click the OK button to scale the picture.

To search for recipes:

1. Choose Search Recipes from the Recipe menu or click  on the Control Bar.

The Search Recipes dialog box opens.
2. Click on the part of the recipe to search in the first list box.
3. Click on the type of search you want to perform in the second list box.
4. In the third list box, tell MasterCook what you want to look for. Separate items in the list with 
semicolons, ie: apple; cream sauce; etc.
5. Click the Add Line button to add the search line to the search criteria list at the top of the dialog 
box.
6. Click the appropriate radio button in the Match box: All of these or Any of these.
7. Indicate which cookbooks you want to search in the list labeled "From": All Open Cookbooks, All 
Available Cookbooks, or Selected Cookbooks.

8. Click the appropriate radio button to choose whether you want the list of recipes found during 
your search to be added to the Recipe Clipboard or to replace the Recipe Clipboard.

9. Click the Search button to begin the search.

If recipes are found, the Recipes Clipboard is displayed.

To view a recipe with Page View:
1. Open the recipe to be viewed.

2. Click the Page View button.

The recipe window changes to display the recipe as it will appear when printed, using the 
current Recipe Design.





Saving a Recipe Design
Remember that new recipe designs are created by modifying already-existing recipe designs. 
However, when you click the Change button in the Recipe Design dialog box, you have not yet 
created a new, permanent recipe design; rather, you have so far only applied changes in a recipe 
design to the recipes in the open cookbook. You can tell whether the recipes in a cookbook are 
displayed in a permanent recipe design or in the modifications of a recipe design by pulling down 
the Design menu in the Recipe Design dialog box. The name of the displayed recipe design will 
be marked--if the name is marked with a check, the displayed recipe design is a permanent 
recipe design that can be applied to recipes in other cookbooks.

You can decide to save the modifications to a recipe design as a permanent recipe design at any 
time. For example, let's say that you modify the Classic recipe design, one of the recipe designs 
which come with MasterCook, while you are looking at the Cooking Light cookbook. Even if you 
do not save your modifications as a permanent recipe design, the modifications will remain 
applied to the recipes in the Cooking Light cookbook even after you close the cookbook. Later, if 
you want to apply the same modifications to other cookbooks, just open the Cooking Light 
cookbook, go to the Cookbook Recipe Design Editor, and save the modifications as a Recipe 
Design. Of course, you can save your modifications as a Recipe Design immediately after making
them--MasterCook lets you decide.

To save a modified recipe design:
1. Make sure the modified recipe design you wish to save is displayed in the Recipe Design 

dialog box

.2. Choose Save Recipe Design from the File Menu at the top of the dialog box.A dialog box 
appears, asking you to name your recipe design. Type a name for your design in the text box.
All recipe designs and page layouts should be stored in the Layouts folder, which is located 
inside the MasterCook folder, so open the Layouts folder, if necessary.

3. Click the Save button.Your recipe design is saved on disk and appears on the Design menu 
in both the Recipe Design Editor dialog box and the Page Setup dialog box. It also appears in
the list of recipe designs in the Cookbook Looks dialog box. 

See also
Cookbook Recipe Design

Edit Menu



Scroll Bar
A shaded area of a window, bounded by arrow buttons, that lets you move parts of a document 
into view when the entire document won't fit in the window. A scroll bar also lets you view unseen 
portions of lists and other information too large to fit in the allotted space.

To close this pop-up window, click the left mouse button once anywhere outside of it.



Search Lines
Sentences that you create to tell MasterCook what types of recipes to search for when using the 
Search Recipe command.

See Also
Recipe Menu

To close this pop-up window, click the left mouse button once anywhere outside of it.



Seasonings

Finding Food Items to Use a Specific Seasoning
1. Choose Seasonings from the Tools menu.

2. Click the "Seasoning to Foods" radio button.

3. In the text box above the Seasonings list, type the name of the seasoning for which to view 
suggested foods or click its name in the list.

Suggestions appear in the Foods text box on the right.

4. Click the Close button to exit the dialog box.

Finding a Seasoning for a Food or Dish
1. Choose Seasonings from the Tools menu.

2. Click the "Food to Seasonings" radio button.

3. In the text box above the Foods list box, type the name of the food or dish or click on its name
in the list.

Suggestions appear in the Seasonings list box.

4. Click the Close button to exit the dialog box.

See Also
Tools Menu



Selection Cursor
A graphical indicator showing where you are in a document or window. In text, the selection 
cursor appears as an I-beam; in a list, it appears as a bar highlighting an item, showing its text in 
inverse or on a dark background; in a group of control objects -- such as buttons, check boxes or 
radio buttons -- it appears as a dotted line around the object.

To close this pop-up window, click the left mouse button once anywhere outside of it.



Sharing MasterCook Recipes
There are three ways in which you may share your MasterCook recipes:

1) PRINT Recipes

You may opt to "print" only selected recipes or the entire cookbook.These may be formatted 
in a variety of ways and printed on a variety of paper sizes or recipe cards. (For details, see 
Chapter Eight, "Printing" in your MC User's Guide.)

This is, obviously, not an electronic way to share your recipes.

2) EXPORT Recipes to Formatted Text Files

You may "export" one or many recipes from a MasterCook cookbook to a text file or e-mail 
message. The formatted recipes in the resulting text file may be shared electronically via e-
mail or file transfer. Recipients of these exported recipes do not need MasterCook to view the
recipes; however, MC users will be able to directly import the recipes.

Because exported recipes are simply text files, they may be incorporated into any text 
document or embedded directly in an e-mail message. This is the most common way you will 
be sending recipes over the Internet.

3) COPY a complete cookbook

You may send a copy of a complete cookbook electronically to any location on the Internet. 
The recipient must open the cookbook from within MasterCook in order to view the recipes.

Because MC cookbooks are raw data (binary) files, and not text files,they cannot be 
embedded in an e-mail message. Typically they will be transferred as either attached 
documents or uploaded as raw data (binary) to an Internet site. Of course you may also copy 
a complete cookbook to a floppy disk, a Zip disk or any other media for either sharing or 
backup.



Shopping List Menu
MasterCook allows you to create a shopping list for a single recipe, a group of recipes, for a menu
or an entire meal plan.

Make Shopping List

Command Description
Make Shopping List Allows you to create a shopping list 

for a recipe, group of recipes, menu or
meal plan

Sort by Item Sorts the shopping list alphabetically 
by food item

Sort by Store Location Sorts the items on the shopping list by
store location

Add Basic Shopping List Lets you add Basic Shopping List 
information to a shopping list

Remove Recipe Names Allows you to remove recipe names 
from a shopping list

Edit Basic Shopping List Lets you edit items in the Basic 
Shopping List

See Also
Commands



Shopping Lists
Creating a Shopping List for Single Recipe

Creating a Shopping List for Group of Recipes

Creating a Shopping List for Menu

Creating a Shopping List for Meal Plan

Sorting a Shopping List
By Ingredient

By Store Location

Editing a Shopping List
Adding a New Item

Removing Items

Removing Recipe Names

Hiding Items from the Shopping List

Copying Shopping List Items to the Clipboard

Pasting Items into a Shopping List

Printing a Shopping List

Saving a Shopping List as a Text File

Opening a Shopping List Saved as a Text File

Saving a Shopping List with a Different Name

To create a shopping list for a single recipe:
1. Open the recipe for which you wish to make a shopping list (or click on the recipe name in the

cookbook or Recipe Clipboard window).

2. Choose Make Shopping List from the Shopping List menu or click  from the Control Bar.

The Shopping List window appears, displaying the food items you'll need to purchase to prepare 
the recipe, along with the amount of each item and its store location.

3. Click the shopping list window's Close button when you wish to close the shopping list.

NOTE: When use choose New Shopping List from the File Menu, a blank Shopping List window 
is displayed. You can copy recipes to this window from the Recipe Clipboard or from an 
open cookbook.

To create a shopping list for a group of recipes:
1. In the cookbook window or Recipe Clipboard window, select the name of the recipes that you 

wish to add to the shopping list.

2. Choose Make Shopping List from the Shopping List menu or click  from the Control Bar.

The Shopping List window appears, displaying the food items you'll need to purchase to prepare 
the recipes, as well as the amount of each item, store location and the recipes that call for it.
3. Click the shopping list window's Close button when you wish to close the shopping list.



To create a shopping list for a menu or meal plan:
1. Open the menu or meal plan for which you wish to make a shopping list.

2. Choose Make Shopping List from the Shopping List menu or click  from the Control Bar.

The Shopping List window appears, displaying the food items you'll need to purchase to prepare 
the recipes in the menu or meal plan along with the amount of each item (totaled if the item is used in 
more than one recipe), its store location, and the recipes that use the item.

3. Click the shopping list window's Close button when you wish to close the shopping list.

To sort a shopping list alphabetically by ingredient:
Choose Sort by Item from the Shopping List menu.

To sort a shopping list by store location:
Choose Sort by Store Location from the Shopping List menu.

To add a new item to a shopping list:
1 Click on the item row in the shopping list where you want to place the new item.

2. Choose Insert Blank Row from the Edit menu.

3. Add information for the new item, pressing TAB or RETURN to move between columns.

To remove items from a shopping list:
1. Click on the number button(s) of the item row(s) you wish to delete.

2. Choose Clear Row(s) or Delete Row(s) from the Edit menu.

To remove recipe names from a shopping list:
Choose Remove Recipe Names from the Shopping List menu.

To hide shopping list items:
1. Click the check box at the front of the shopping list item.

The item remains on the shopping list, but will not be printed when you want to print the list.

2. Click the "x" in the check box to include the item in the list again.

To cut items from the shopping list:
1. Click on the number button(s) of the item row(s) you want to cut from the shopping list.

2. Choose Cut Row(s) from the Edit menu.

To copy shopping list items to the Clipboard:
1. Click on the number button(s) of the item row(s) you want to copy.

2. Choose Copy Row(s) from the Edit menu.

To paste items into the shopping list:



1. Click on the place in the shopping list where you want to paste the Clipboard contents.

2. Choose Paste Row(s) from the Edit menu.

To print a shopping list:

In the shopping list window, choose Print Shopping List from the File menu or click  on 
the Control Bar.

A dialog box appears indicating the list is being sent to the printer.

To save a shopping list as a text file:
1. Choose Save Shopping List from the File menu.

If you haven't yet saved the shopping list, a dialog box opens to let you specify where you 
want to save the shopping list and what you want to name it.

Shopping list files are given the .sl file extension.

2. To save the shopping list to a new location, specify the directory and/or disk drive.

3. Type a name for the shopping list.

4. Click the Save button.

To open a shopping list saved as a text file:

1. Choose Open from the File menu or click  from the Control Bar.

2. In the Open dialog box, specify the disk drive or directory in which the shopping list resides.
3. Click on the name of the shopping list and then click the Open button.

To save a shopping list with a different name:
1. Choose Save Shopping List As from the File menu.

2. To save the shopping list to a different location, specify the drive and/or directory in the dialog 
box.

3. Type a new name for the shopping list and then click the Save button.

See Also
Shopping List Menu

Basic Shopping List



Spell Check Options
With Spell Check Options you can choose which parts of recipes will be checked by the spell 
checker. When you click the Options button in the Check Spelling dialog box, the Spell Check 
Options box appears. You can choose to check one or more of the following parts of recipes: 
Recipe Name, Recipe By, Ingredient Units, Ingredient Name, Ingredient Preparation Method, 
Directions, Suggested Wine, Serving Ideas, and Notes.Click on the boxes next to the recipe parts
you wish to check, then click the OK button. 

When MasterCook performs the next spell check, it checks only the parts of recipes which you 
have selected (by choosing fewer parts of recipes, you can check entire cookbooks 
faster).MasterCook remembers the options you choose until you return to Spell Check Options 
and change them.



Substitutions
To find a substitute for an ingredient:
1. Choose Substitutions from the Tools menu.

2. In the text box above the Ingredients list box, type the name of the item for which you need a 
substitute, or click its name in the list.

3. Click the Close button when you're finished.

See Also
Tools Menu



Terms and Definitions
Active window

Basic Shopping List

Book View

Bookmarks

Bookmarks Card

Bookshelf

Category List

Contiguous selection

Control Bar

Cookbooks

Edgetabs

Fast-fill

History Card

Icon

Icon-button

Index Card

Ingredients list

Insertion point

Link

List box

MasterCook Environment

Meal plan

Non-contiguous selection

Radio button

Recipe Clipboard

Scroll bar

Search lines

Selection cursor

User Food Items



The Gallery
To Use the MasterCook Gallery:
1. Choose Gallery from the Tools menu, or click on the Gallery icon on the toolbar.

2. Click on the Utensils tab to display the Utensils graphics.

3. To browse the Utensils graphics, click the arrow buttons in the scroll bar at the bottom of the 
Gallery window.

4. To enlarge a single utensil graphic, double-click anywhere on the graphic.

Click once anywhere on the graphic to put it away..

5. To display video tips, click the Video Tips tab.

6. Browse the videos using the arrow buttons in the center of the lower part of the Gallery 
window.

7. Use the video controls in the lower-left of the Gallery window to play the current video.

8. Click the Close button to exit the Gallery window.

See Also
Tools Menu



Tools Menu
The MasterCook Control Bar and Tools menu offer a variety of special features designed to help 
make managing recipes faster and easier for you.

Comman
d

Description

Nutritional Analysis Creates a nutritional analysis for a recipe, group of 
recipes, menu or meal plan.

Cost Analysis Creates a cost analysis for a recipe, group of recipes, 
menu or meal plan.

Ingredient Analysis Displays nutrient information for a single ingredient from a 
recipe window.

Find and Replace Text Searches for occurrences of specified text and replaces 
text if desired.

Check Spelling Checks and corrects spelling of selected recipes or entire 
cookbooks.

Edit User Dictionary Lets you add, remove, and edit words in the Spell 
Checker's User Dictionary.

Lookup

See Also

Utensils and Video Tips

Hypertext-like reference for obtaining information on words
and phrases you select in recipes.

Ingredients List Displays information on any item in the MasterCook 
Ingredients List. 

Wine List Lets you keep track of your wine collection.

Gallery (Video & Pictures) Provides a convenient way to browse through and 
manage all of your MasterCook graphics and video tips.

Glossary Includes definitions of more than 500 cooking items.

Seasonings Provides suggestions for combining common herbs and 
spices with popular foods.

Substitutions A handy reference of substitutions for a variety of common
recipe ingredients.

Video Tips Allows you to view video for a text selection or a specific 
video in your collection.

Utensils Includes an extensive collection of more than 300 
rendered graphics of utensils, cutlery and kitchen 
equipment.

Yields & Equivalents Provides information on yields    and equivalents

Preferences Allows you to custom-configure MasterCook.

See Also



Commands



Transferring Files
You can send and receive files on the Internet via three basic ways:

1) E-MAIL
E-mail messages are always "text" files and are sent and received using an e-mail program 
such as Eudora, Microsoft Exchange, etc.

When you receive a file, your e-mail program will perform whatever "translation" is required 
for you to be able to read the text. (For example, if the text originated on a DOS system and 
was received on a Macintosh system, the "line feeds" are stripped.) This is why you can read 
messages sent from systems different than yours.

The primary and simplest method for exchanging recipes via the Internet is through e-mail. 
Typically, recipes you send and receive will be embedded in the body of an e-mail message. 
By using e-mail, you will ensure that in most cases your recipes can be read and vice versa.   
There will often be commentary and a signature surrounding the actual recipe, but that will 
not impact MC's ability to import.    (For details on how to"process" these recipes, see 
Importing Recipes From E-mail.)

2) "ATTACHED FILES" (to e-mail messages)
Occasionally someone will "attach" a file to an e-mail message. These files may be either text
or raw data files. Some e-mail programs (ie,Eudora) support sending and receiving 
"attachments".    If your e-mail program does support attached files, you tell it where you 
would like attached files to be stored.    When an attached file is received, you will see a 
message in your "In" box informing you of receipt and file name.

Sending attached files is a very convenient method of transferring large text files or raw data 
files directly to other users. Note that attached files are not an "e-mail" message, thus, they 
are not subject to the same e-mail message size limitations. (There may be a file size 
limitation imposed by your service provider, but it will be significantly larger than an e-mail 
size limit.)    Raw data files sent as attachments will not be translated to text.

It is not recommended that you send recipes as "attachments" to mailing lists or newsgroups, 
because many e-mail programs do not recognize and support attached documents. (Indeed, 
sending attached files to newsgroups and mailing lists is considered to be a breach of 
Internet etiquette.)    Furthermore, there is no one standard on how attachments are handled. 
Before sending an attached document, you should confirm that the recipient can handle it.

3) UPLOADING/DOWNLOADING
When you request a copy of a file be electronically sent from a site on the Internet to your 
computer, you are "downloading."    These files may be either text or raw data files and there 
is a variety of software programs that enable this transmission. (Examples of these programs 
are:Netscape, Fetch, Gopher, Mosaic, or your Internet service provider may provide their 
own.)

If you send a file from your system to be stored on another system, that is called "uploading".  
Once a file is "uploaded", it may be available for others to "download."

You will typically be downloading either files containing recipes (text files) or complete 
MasterCook cookbooks (raw data files) from the Internet.



Types of Files
There are two types of data files that you will encounter on the Internet: "TEXT" and "RAW DATA"
(also called "BINARY") files.

TEXT files are "readable" by you; that is, they are in a language that people    understand (i.e., 
English, Spanish, German, etc.). You can open them, view them, and edit them via any number of
text editors (ie,Notepad, Simple Text, etc.) or word processing programs (ie, MicroSoftWord or 
Word Perfect). e-mail messages are always "text" files. Likewise, recipes that are "EXPORTED" 
from cooking programs are also text files.

However, not all text files are alike.    Different computer operating systems expect different 
controls signalling the "end of line" (EOL) in text files. Thus, you will encounter three different "end
of line"indicators:

DOS systems:                            Carriage Return AND Line Feed

Macintosh systems:            Carriage Return

Unix systems:                              Line Feed

If a text file contains the incorrect "end of line" indicator for your system, you most likely will not be
able to view the file correctly with a text editor; it will appear "garbled." You will typically see the 
text lines all run together, and/or a foreign character (such as a black rectangle or blank square) 
at the logical end or beginning of each line.

TIP: Incorrect EOL delimiters are not typically a problem in e-mail because your e-mail 
program will do whatever translation is necessary for your system. However, if you receive 
text files outside of e-mail (ie,downloaded or attached documents), they may contain the 
incorrect control characters and you will need to convert them.

TIP: Incorrect EOL delimiters are not typically a problem for MasterCook 3.0 and 4.0 users, 
because, in most cases, the Recipe Translator can import the recipes correctly even if they 
contain invalid EOL delimiters for your system. (For more on this subject, see Supported 
Recipe Formats and Text Types.)

RAW DATA files look like "garbage" if you attempt to view them via a text editor. They are often 
executable files (such as applications or execs), or they are in a format very specific to a program 
and can only be viewed via that program.    An example of a "raw data" file is a complete 
MasterCook cookbook.    You can exchange complete cookbooks with others; you need only open
the cookbook from within MasterCook.

NOTE: MasterCook cookbooks are completely compatible across all versions of MasterCook 
and all platforms. This means that all MC Windows and Mac users, regardless of their MC 
version, can exchange complete cookbooks, with absolutely no conversion required!

TIP: Both text and raw data files may be "compressed" to reduce their size before being 
transferred on the Internet.    A compressed or "zipped" file must be expanded or "unzipped" 
before it can be processed. There are many different commonly used compression/expansion
schemes and utility programs (such as "PKZIP" and "StuffIt Expander").

Sometimes a compressed file is "self-extracting," meaning that it contains the information 
necessary to be expanded without your having the expansion software.    If a compressed file is 
NOT self-extracting, then you must have a software program that can read and expand the file.

TIP: Recipes in MasterCook cookbooks will be automatically stored in a compressed format if
you select that option under Preferences (under the Tools menu option). This option will 
significantly reduce the amount of disk space required by your cookbooks. Because of the 
incompatibility among file compression programs, you may avoid many file exchange 
problems if you do not further compress a cookbook prior to sending it electronically.



User Food Items
Food items for which you, the user, provide nutritional information using the Ingredients List 
command on the Tools menu. User food items are saved in the file "User Ingredients."

To close this pop-up window, click the left mouse button once anywhere outside of it.



Utensils
To perform a lookup with the Utensils reference:
1. In a recipe window, select the word or phrase for which you want to display utensil and 

cookware graphics.

2. Choose Utensils from the Tools menu.

3. Click the Done button when you're finished viewing the graphics.

See Also
Tools Menu



Video Tips
To perform a lookup with Video Tips:
1. Select the recipe text for which to want to play a video.

2. Choose Video Tips from the Tools menu.

3. Click the Done button when you're finished.

See Also
Tools Menu



View menu
The commands on the View Menu allow you to modify the way you view a cookbook in its 
cookbook window.

Command Description
as Category List Displays the currently opened cookbook as a 

Category List

as Book Displays the currently opened cookbook in 
Book View

Both Pages Displays the left and right pages of a 
cookbook opened to Book View

Right Page Only Displays the right page only of a cookbook 
opened to Book View



What Went Wrong?
So, you just received some wonderful recipes you want to add to your MasterCook collection!    
But you just can't seem to make "import" work    .Perhaps MasterCook didn't recognize any 
recipes in the file you tried to import. Or perhaps only some of the recipes appeared in the "Import
Selection" window.

Maybe all the recipes did import, but you received a warning message from the importer telling 
you it encountered some difficulty when importing, or you discovered some of the recipes didn't 
look right upon examining them.

Or maybe you just can't figure out how to "export", and you have some great recipes you want to 
share with others on the Internet.

MasterCook uses a number of sophisticated methods to try to import recipes from a variety of 
formats as accurately as possible. And exporting is usually very straightforward. However, 
sometimes things just go wrong. The "What Went Wrong?" Help files contain many of the 
common symptoms, causes, and suggested cures that you may encounter when trying to 
exchange recipes with others.

If you can't resolve the problem you are experiencing with any of the methods listed in the Help 
Files, contact Sierra Technical Support:

email:    support@sierra.com              
voice: (206) 644-4343
fax:      (206) 644 7697                            
BBS:      (206) 644-0112

You may also want to seek help and advice from the large number of MasterCook users on the 
Mastercook Mailing List. To subscribe to this list, send an email message to:                              < mail-
server@listserv.sierra.com > .

The body of the message should read: subscribe mastercook

end 



What's New in MasterCook 4.0
Many significant new features were added to make importing recipes into MasterCook 4.0 easier 
and more accurate than ever!    A summary of the most exciting new features follows.

End-of-Recipe Delimiter: "_____"    (5 underscores)
Now there is a definitive way to tell the Recipe Translator where the end of the recipe text is! 
Simply insert "_____" (5 underscores) at the beginning of the line immediately following the 
end of the recipe text.    When the Recipe Translator encounters this control string, it will 
cease importing the current recipe and begin looking for the next beginning-of-recipe 
header.You now have precise control over where the recipe text ends, so you nolonger have 
to bother removing e-mail headers and trailers from your text files prior to importing.    No 
more surprise text in the "Notes" section!

Exclude Categories When Importing (optional)    
Hate all those foreign categories that get added to your cookbook everytime you import a 
recipe?    Now you can simply turn off the import of all categories by unchecking the "Include 
Categories" box in the Import dialog window.But you want to include categories, at least some
of the time? No problem!    The include/exclude option can be set on each import.

End-of-Section Delimiter: "|" (vertical bar)
Have you had difficulty with those troublesome BLANK lines that are required in the Generic 
import formats?    Well, no need to fret anymore.    Instead of ensuring those required lines are
truly BLANK, simply insert a "|" (vertical bar) at the beginning of each separator line.    This 
indicates to the Recipe Translator that it has encountered the end of that recipe section.You 
can, of course, continue to use BLANK lines as end-of-section indicators.    Just beware that if
the line contains even one "space", the recipe will not import correctly. When you use the "|" 
control character, you need not worry if the line is blank.

Ingredient Lines With All Spaces (or Tabs) Will be Preserved
You may now use lines with only spaces or tabs in the Ingredient section to separate groups 
of ingredients!    In past releases, if you did not include at least one displayable character in 
an ingredient line, the line was stripped when the recipe was imported. In Version 4.0, these 
lines (which appear to be "blank") will be kept in the ingredient section.(Note that this applies 
only recipes imported in the MXP format. Ingredient lines with all spaces or tabs in the 
Generic format will be stripped when imported.)

"Notes" Line No Longer Required in Generic Import Format
In MasterCook Version 3.0, Mac users were required to have the one line of "Notes" in the 
generic import format. This has been changed, so if you don't want to use the "Notes" section 
of the recipe, you no longer have to!    The Generic format may now include just the title, 
ingredients, and directions, and, of course, the required format controls. 

Improvements in Importing MealMaster Recipes 

MealMaster recipes that contain two-columns of ingredients and dividers can now be 
successfully imported into MasterCook!    In addition, recipes with MealMaster dividers are 
now imported with a divider that looks good in MasterCook.    Example of a part of a 
MealMaster, 2-column recipe with dividers:

---------------------------------ICE CREAM------------------------------            

1 qt Vanilla ice cream                                      1 c    Heath bars;chopped

-------------------------------CARAMEL SAUCE----------------------------



    1 1/3 c    Whipping cream                                            2 tb Unsalted butter; cut into

            1 c    Sugar                                                                            4 pieces            

3 tb Water



Window Menu
MasterCook uses the standard Window menu. The top portion of this menu contains commands 
for manipulating document windows in MasterCook: Cascade, Arrange Icons, Recipe Clipboard, 
Bookshelf, Close All Recipes and Close All.

You can also select the Import Results command, which reports translation errors for files you 
import into MasterCook.

The lower portion of the Window menu lists all open MasterCook document windows. The first    
item in this list will always be the currently open cookbook followed by the names of all other 
windows in the order they were opened. These window names are preceded by their type: if a 
window contains a recipe, then the name is preceded by "Recipe:"; if the window contains a 
menu, it appears on the Window menu as "Menu:" followed by the menu name.

You can also hide the Control Bar from this menu.

See Also
Commands



Wine List
Creating a Wine List

Editing a Wine List

Printing a Wine List

To create a wine list:
1. Choose Wine List from the Tools menu.

2. To add a wine to the list, click the New button in the Wine List dialog box.

3. Type the wine's producer, type of wine, color, year, number of bottles, peak year and serving 
suggestions in the appropriate text boxes.

4. Click the Save button.

5. Click the Close button to exit the dialog box.

To edit a wine list:
1. Choose Wine List from the Tools menu.

2. To add a new wine, click the New button and enter the information.

3. Click the Save button to add the new wine.

4. To edit an existing wine, click the name of the wine and then click the Edit button.

5. Make the necessary changes and then click the Save button.

6. Click the Close button to exit the dialog box.

To print a wine list:
1. Choose Wine List from the Tools menu.

2. Click the Print button. A dialog box is displayed indicating the list is being sent to the printer.

See Also
Tools Menu



Yields
The amount of edible food provided by a raw foodstuff after processing.



Yields & Equivalents
To find a yield or equivalent for an ingredient:
1. Choose Yields & Equivalents from the Tools menu.

2. Select the item in the Ingredients list for which you want a yield or equivalent by typing the 
first few letters of the ingredient or clicking on it in the list.

3. Click the Close button to exit the window.



Drag and Drop
MasterCook's drag and drop feature allows you to select an item, such as a recipe, and "drag" it 
to the place where you want to move it (such as to another cookbook, menu, meal plan, etc.).



Fast-fill
MasterCook's fast-fill feature displays a drop-down list of items, automatically scrolls to the item 
most like the one you are typing, and "fills in" the rest of the word or phrase that it "thinks" you 
want to use based on the letters you've already typed.

To close this pop-up window, click the left mouse button once anywhere outside of it.



Icon
A graphical representation for various elements in Windows.

To close this pop-up window, click the left mouse button once anywhere outside of it.



Icon-buttons
Buttons containing symbolic pictures rather than words that let you access a specific function.

To close this pop-up window, click the left mouse button once anywhere outside of it.



Keyboard Shortcuts
      

Function Keyboard
Shortcut

Open CTRL+O

Close CTRL+W

Save CTRL+S

Print CTRL+P

Undo CTRL+Z

Redo CTRL+Y

Cut CTRL+X

Copy Recipes CTRL+C

Paste CTRL+V

Select All CTRL+A

Clear CTRL+DEL

Delete Rows CTRL+D

Insert Blank Row CTRL+I

Link with Ingredient CTRL+K

New Recipe CTRL+N

Open Recipe CTRL+R

Save Recipe CTRL+S

Mail Recipe CTRL+M

Search Recipes CTRL+F

Nutritional Analysis CTRL+J

Lookup CTRL+L

Ingredients list CTRL+E

Video Tips CTRL+T

Utensils CTRL+U

Glossary CTRL+G

Recipe Clipboard CTRL+B

Previous/Next Page  and 

Previous/Next Recipe ALT +  and 

First Recipe CTRL + 

Last Recipe CTRL + 






